aboutsummaryrefslogtreecommitdiff
path: root/news/inn
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-08-30 00:39:07 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-08-30 00:39:07 +0000
commit4cba7980c204a2478b2deb33489d86b9bb03f3f6 (patch)
tree6b86c2c4b3579bd9117c91abb2cee466611c027a /news/inn
parentd5f501da8c10f86acf2fff813d5f51e5ebc171d2 (diff)
downloadports-4cba7980c204a2478b2deb33489d86b9bb03f3f6.tar.gz
ports-4cba7980c204a2478b2deb33489d86b9bb03f3f6.zip
For the inn ports:
- Fix build in the case where the host machine has either no DNS, or an incomplete hostname. - Use a generic placeholder in the default config file rather than the build machine's name. - Pet portlint(1) while here.
Notes
Notes: svn path=/head/; revision=171644
Diffstat (limited to 'news/inn')
-rw-r--r--news/inn/Makefile15
-rw-r--r--news/inn/files/patch-lib_innconf.c11
2 files changed, 13 insertions, 13 deletions
diff --git a/news/inn/Makefile b/news/inn/Makefile
index 9c8a9346cfee..f8f2d7d3027d 100644
--- a/news/inn/Makefile
+++ b/news/inn/Makefile
@@ -45,19 +45,6 @@ CONFIGURE_ARGS+= --mandir=${PREFIX}/man \
--enable-ipv6 \
--with-etc-dir=${ETC_DIR}
-# Attempt to avoid failures later on, when
-# makedbz is executed: we need a valid hostname.
-
-.if exists(/bin/hostname)
-HOSTNAME!= /bin/hostname
-. if ${HOSTNAME} != ""
-HOSTNAME:= ${HOSTNAME:C/[^\.]//g}
-. if ${HOSTNAME} == ""
-IGNORE= requires a fully-qualified hostname in order to build
-. endif
-. endif
-.endif
-
.if defined(WITH_BERKELEYDB)
CONFIGURE_ARGS+= --with-berkeleydb
. if !defined(WITH_BDB_VER)
@@ -185,6 +172,8 @@ post-install:
.endfor
@${CHOWN} root:news ${PREFIX}/news/bin/auth/passwd/ckpasswd
@${CHMOD} 4755 ${PREFIX}/news/bin/auth/passwd/ckpasswd
+ @${FIND} ${WRKSRC} -name "inn.conf" \
+ | ${XARGS} ${REINPLACE_CMD} -e 's/^pathhost:.*/pathhost: host.example.com/'
@${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} CHECK-CONF ${ETC_DIR}
@(if [ ! -f ${PREFIX}/news/db/history ] ; then \
${ECHO} 'Creating empty history database...' ; \
diff --git a/news/inn/files/patch-lib_innconf.c b/news/inn/files/patch-lib_innconf.c
new file mode 100644
index 000000000000..05d8eadfb946
--- /dev/null
+++ b/news/inn/files/patch-lib_innconf.c
@@ -0,0 +1,11 @@
+--- lib/innconf.c.orig Mon Mar 20 04:14:57 2006
++++ lib/innconf.c Sat Aug 26 00:22:04 2006
+@@ -395,7 +395,7 @@
+
+ if (GetFQDN(innconf->domain) == NULL) {
+ warn("hostname does not resolve or domain not set in inn.conf");
+- okay = false;
++/* okay = false; */
+ }
+ if (innconf->mta == NULL) {
+ warn("must set mta in inn.conf");