aboutsummaryrefslogtreecommitdiff
path: root/news/nntp
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-22 11:18:13 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-22 11:18:13 +0000
commit7206deaa2e6c18ca38908c233cdfd9a83fc34c95 (patch)
tree03b79d2ed18fa545f67018a4b4d6b96ae28f6367 /news/nntp
parenta5ced7b5bb09bbed89a93e3e2949cab917bf1f53 (diff)
downloadports-7206deaa2e6c18ca38908c233cdfd9a83fc34c95.tar.gz
ports-7206deaa2e6c18ca38908c233cdfd9a83fc34c95.zip
- Attempt to unbreak parallel (-jX) builds: call sub-makes correctly
- Pad pkg-message display for consistency of port vs. package install - Cleanup the port a bit: drop gratuitous variables, use REINPLACE_CMD instead of MV/SED, convert to OptionsNG, etc. Reported by: marino Approved by: miwi, bapt (portmgr, implicit)
Notes
Notes: svn path=/head/; revision=325184
Diffstat (limited to 'news/nntp')
-rw-r--r--news/nntp/Makefile31
1 files changed, 17 insertions, 14 deletions
diff --git a/news/nntp/Makefile b/news/nntp/Makefile
index 3c24310a2171..0703251661f8 100644
--- a/news/nntp/Makefile
+++ b/news/nntp/Makefile
@@ -1,4 +1,4 @@
-# Created by: adam
+# Created by: Adam David <adam@FreeBSD.org>
# $FreeBSD$
PORTNAME= nntp
@@ -16,7 +16,6 @@ COMMENT= NNTP with NOV support
BUILD_DEPENDS= ${LOCALBASE}/lib/libcnews.a:${PORTSDIR}/news/cnews
-MAKE_JOBS_UNSAFE= yes
NO_WRKSUBDIR= yes
MAN1= nntpxmit.1
MAN8= nntpd.8c acttimes.8c
@@ -24,7 +23,6 @@ PLIST_SUB+= VARBASE=${VARBASE}
PLIST_SUB+= NEWSBIN=${NEWSBIN:S=^${PREFIX}/==}
PLIST_SUB+= NEWSCTL=${NEWSCTL:S=^${VARBASE}/==}
-MODIFY= conf.h Makefile
DOCSFILES1= AUTHORIZE CHANGES README README-conf.h SYSLOG doc/rfc977
DOCSFILES2= server support xfer xmit
@@ -38,13 +36,15 @@ MAKE_ENV+= DBLIBS="${LOCALBASE}/lib/libcnews.a -lcrypt -lutil"
MAKE_ENV+= ETCDIR="${LOCALBASE}/sbin" BINDIR="${NEWSBIN}"
MAKE_ENV+= MANDIR="${LOCALBASE}/man"
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-extract:
@${CP} ${WRKSRC}/conf.h.dist ${WRKSRC}/conf.h
-pre-configure:
-.for i in ${MODIFY}
- @${MV} ${WRKSRC}/${i} ${WRKSRC}/${i}.sed
- ${SED} \
+post-patch:
+ @${REINPLACE_CMD} \
-e "s=/usr/local/news/lib/bin/config=${NEWSBIN}/config=" \
-e "s=/usr/local/news/cnewsbin=${NEWSBIN}=" \
-e "s=/usr/local/news/lib=${NEWSCTL}=" \
@@ -53,20 +53,23 @@ pre-configure:
-e "s=/usr/local/bin=${PREFIX}/bin=" \
-e "s=/usr/local/sbin=${PREFIX}/sbin=" \
-e "s=/usr/local/man=${PREFIX}/man=" \
- ${WRKSRC}/${i}.sed >${WRKSRC}/${i}
-.endfor
+ ${WRKSRC}/Makefile ${WRKSRC}/conf.h
+# Try to fix parallel builds (-jX)
+ @${REINPLACE_CMD} \
+ -E 's=cd (.+); (\$$\(MAKE\))=\2 -C \1=' \
+ ${WRKSRC}/Makefile
post-install:
${INSTALL_DATA} ${WRKSRC}/overview.fmt ${NEWSCTL}/overview.fmt
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in ${DOCSFILES1}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
-.endfor
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOCSFILES1:S=^=${WRKSRC}/=} ${DOCSDIR}
.for i in ${DOCSFILES2}
${INSTALL_DATA} ${WRKSRC}/${i}/README ${DOCSDIR}/${i}-README
.endfor
.endif
+ @${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
.include <bsd.port.mk>