aboutsummaryrefslogtreecommitdiff
path: root/news/p5-News-Article
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-11-14 23:40:22 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-11-14 23:40:22 +0000
commitb0b6643138f8127f7faef3f676dd8068866ba1c8 (patch)
tree9c7484883f0e9eda8310f71fcc9161b03688e554 /news/p5-News-Article
parent8479530a04df555a0a55a8bf1c168e82e1125fc4 (diff)
downloadports-b0b6643138f8127f7faef3f676dd8068866ba1c8.tar.gz
ports-b0b6643138f8127f7faef3f676dd8068866ba1c8.zip
- use Net::NNTP from p5-Net instead of system perl
- add optional dependency of PGP::Sign - update URL in pkg-descr Reviewed by: Don Croyle <croyle@gelemna.org>
Notes
Notes: svn path=/head/; revision=121619
Diffstat (limited to 'news/p5-News-Article')
-rw-r--r--news/p5-News-Article/Makefile16
-rw-r--r--news/p5-News-Article/pkg-descr2
2 files changed, 15 insertions, 3 deletions
diff --git a/news/p5-News-Article/Makefile b/news/p5-News-Article/Makefile
index 2d2fd8a91ed3..b2f92c787e26 100644
--- a/news/p5-News-Article/Makefile
+++ b/news/p5-News-Article/Makefile
@@ -7,7 +7,7 @@
PORTNAME= News-Article
PORTVERSION= 1.27
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= news perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= News
@@ -16,9 +16,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Object for handling Usenet articles in mail or news form
+BUILD_DEPENDS= ${SITE_PERL}/Net/NNTP.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${SITE_PERL}/Net/NNTP.pm:${PORTSDIR}/net/p5-Net
+
PERL_CONFIGURE= yes
MAN3= News::Article.3 News::AutoReply.3 News::FormArticle.3 \
News::FormReply.3
-.include <bsd.port.mk>
+OPTIONS= PGP_SIGN "PGP::Sign support for header signing" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_PGP_SIGN)
+BUILD_DEPENDS+= ${SITE_PERL}/PGP/Sign.pm:${PORTSDIR}/security/p5-PGP-Sign
+RUN_DEPENDS+= ${SITE_PERL}/PGP/Sign.pm:${PORTSDIR}/security/p5-PGP-Sign
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/news/p5-News-Article/pkg-descr b/news/p5-News-Article/pkg-descr
index cef0c8da5707..61bc8d435487 100644
--- a/news/p5-News-Article/pkg-descr
+++ b/news/p5-News-Article/pkg-descr
@@ -2,4 +2,4 @@ This module allows for creating articles from scratch, or reading them
from various data sources; various header manipulations, and posting
via NNTP or mailing via a sendmail-workalike.
-WWW: http://search.cpan.org/dist/News-Article/
+WWW: http://www.erlenstar.demon.co.uk/perl/