aboutsummaryrefslogtreecommitdiff
path: root/news/plor
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1997-01-17 14:32:45 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1997-01-17 14:32:45 +0000
commitfc9629704432021d4328284b052f67d98de33d82 (patch)
treec4a2e4384a3d360038accb1883f5b6999acf23a0 /news/plor
parent9eb9d5227bbe12dd437c52cd3af998594bb3c09e (diff)
downloadports-fc9629704432021d4328284b052f67d98de33d82.tar.gz
ports-fc9629704432021d4328284b052f67d98de33d82.zip
New port:
plor - An alpha-release reader for reading SOUP and QWK packets. Reviewed & Modified by: max Submitted by: Tim Vanderhoek <ac199@freenet.hamilton.on.ca>
Notes
Notes: svn path=/head/; revision=5374
Diffstat (limited to 'news/plor')
-rw-r--r--news/plor/Makefile37
-rw-r--r--news/plor/distinfo1
-rw-r--r--news/plor/files/patch-aa45
-rw-r--r--news/plor/files/patch-ab32
-rw-r--r--news/plor/files/plor.110
-rw-r--r--news/plor/pkg-comment1
-rw-r--r--news/plor/pkg-descr7
-rw-r--r--news/plor/pkg-plist11
8 files changed, 144 insertions, 0 deletions
diff --git a/news/plor/Makefile b/news/plor/Makefile
new file mode 100644
index 000000000000..ef593b940cfc
--- /dev/null
+++ b/news/plor/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: plor
+# Version Required: 0.1 alpha
+# Date Created: 30 Dec 1996
+# Whom: Tim Vanderhoek <ac199@freenet.hamilton.on.ca>
+#
+# $Id$
+#
+
+DISTNAME= plor
+PKGNAME= plor-0.1
+CATEGORIES= news
+# supposedly the primary site is sunsite, but the version there is
+# out-of-date, so... sunsite.unc.edu /pub/Linux/system/BBS/mail/ if you
+# want to try again...
+MASTER_SITES= ftp://ftp.dei.unipd.it/pub/pluto/developers/
+
+MAINTAINER= ac199@freenet.hamilton.on.ca
+
+EXTRACT_SUFX= .tgz
+MAN1= plor.1
+
+DOCFILES= BUGS HISTORY PER_ZENO TODO plor-1.html plor-2.html \
+ plor.html plor.txt
+
+do-install:
+.if !defined{NOPORTDOCS}
+ @${MKDIR} ${PREFIX}/share/doc/plor
+ (for f in ${DOCFILES}; do \
+ ${INSTALL_DATA} ${WRKSRC}/docs/$$f ${PREFIX}/share/doc/plor; \
+ done)
+ ${INSTALL_DATA} ${FILESDIR}/porting.notes ${PREFIX}/share/doc/plor
+.endif
+ ${INSTALL_MAN} ${FILESDIR}/plor.1 ${PREFIX}/man/man1/plor.1
+ perl -pi -e '$$a = '\''${PREFIX}/doc/plor/'\''; $$a =~ s/([^\w\/])/\\$$1/g; s/FUNKYTOKENHERE/$$a/' ${PREFIX}/man/man1/plor.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/plor ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/news/plor/distinfo b/news/plor/distinfo
new file mode 100644
index 000000000000..262896cdd7ab
--- /dev/null
+++ b/news/plor/distinfo
@@ -0,0 +1 @@
+MD5 (plor.tgz) = 2be4f7717f4a5e51c67f80d871ad6dc9
diff --git a/news/plor/files/patch-aa b/news/plor/files/patch-aa
new file mode 100644
index 000000000000..461886f5c908
--- /dev/null
+++ b/news/plor/files/patch-aa
@@ -0,0 +1,45 @@
+--- Makefile.orig Thu Oct 31 06:36:14 1996
++++ Makefile Fri Jan 17 22:56:42 1997
+@@ -14,12 +14,12 @@
+ INCLUDE = ./include/
+ #LIBS =
+
+-ifdef DEBUG
++.ifdef DEBUG
+ #CFLAGS = -g -Wall -m486 -O2 -ansi -pedantic -finline-functions
+-FLAGS = -g -Wall -m486 -O3 -ansi -pedantic -fomit-frame-pointer
+-else
+-FLAGS = -m486 -O3 -fomit-frame-pointer
+-endif
++FLAGS = -g -Wall -m486 -O3 -ansi -pedantic -fomit-frame-pointer -D_HAVE_PARAM_H
++.else
++FLAGS = -m486 -O3 -fomit-frame-pointer -D_HAVE_PARAM_H
++.endif
+
+ CFLAGS = -I$(INCLUDE) $(FLAGS)
+
+@@ -28,18 +28,18 @@
+
+ ############# END USER CONFIGURATION ##################
+
+-ifdef DEBUG
++.ifdef DEBUG
+ all: TODO $(OBJECTS) del plor
+-else
++.else
+ all: $(OBJECTS) del plor
+-endif
++.endif
+
+ plor: $(OBJECTS)
+ $(CC) $(FLAGS) $(OBJECTS) $(LIBS) -o plor
+-ifdef DEBUG
+-else
++.ifdef DEBUG
++.else
+ strip plor
+-endif
++.endif
+
+ # OBJECTS to compile
+ main.o: main.c
diff --git a/news/plor/files/patch-ab b/news/plor/files/patch-ab
new file mode 100644
index 000000000000..7f2d360cf29e
--- /dev/null
+++ b/news/plor/files/patch-ab
@@ -0,0 +1,32 @@
+diff -ud work/plor/main.c src/main.c
+--- work/plor/main.c Sun Oct 27 09:24:00 1996
++++ ./main.c Mon Dec 30 09:40:07 1996
+@@ -19,10 +19,15 @@
+
+ */
+
++#ifdef _HAVE_PARAM_H
++#include <sys/param.h>
++#endif
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdlib.h>
++#if !defined(BSD)
+ #include <getopt.h>
++#endif
+
+ /* will be included when we will have locale support
+ #include <locale.h>
+@@ -75,10 +80,10 @@
+ Show_SConf();
+ break;
+ case '3':
+- printf("Help on Line, not yet supported!!!");
++ printf("Help on Line, not yet supported!!!\n");
+ continue;
+ case '4':
+- printf("Replies not yet implemented!!!");
++ printf("Replies not yet implemented!!!\n");
+ continue;
+ case '5':
+ case 'q':
diff --git a/news/plor/files/plor.1 b/news/plor/files/plor.1
new file mode 100644
index 000000000000..4bfdf687b040
--- /dev/null
+++ b/news/plor/files/plor.1
@@ -0,0 +1,10 @@
+.Dd Dec 30, 1996
+.Dt PLOR 1
+.Sh NAME
+.Nm plor
+.Nd read messages in a SOUP (HDPF) or QWK packet
+.Sh DESCRIPTION
+.Ar Plor
+is documented is FUNKYTOKENHERE.
+.Sh SEE ALSO
+.Xr slnr 1
diff --git a/news/plor/pkg-comment b/news/plor/pkg-comment
new file mode 100644
index 000000000000..212f7c1704d1
--- /dev/null
+++ b/news/plor/pkg-comment
@@ -0,0 +1 @@
+An alpha-release reader for reading SOUP and QWK packets.
diff --git a/news/plor/pkg-descr b/news/plor/pkg-descr
new file mode 100644
index 000000000000..755b42092694
--- /dev/null
+++ b/news/plor/pkg-descr
@@ -0,0 +1,7 @@
+This is a port of plor (which stands for Pluto Offline Linux Reader).
+Plor reads soup and qwk message packets. It is alpha software, and
+does not yet support the creation of reply packets, nor does it
+support advanced features such as kill-files.
+
+- Tim Vanderhoek
+ac199@freenet.hamilton.on.ca
diff --git a/news/plor/pkg-plist b/news/plor/pkg-plist
new file mode 100644
index 000000000000..ac59dd9213a1
--- /dev/null
+++ b/news/plor/pkg-plist
@@ -0,0 +1,11 @@
+bin/plor
+man/man1/plor.1.gz
+share/doc/plor/BUGS
+share/doc/plor/HISTORY
+share/doc/plor/PER_ZENO
+share/doc/plor/TODO
+share/doc/plor/plor-1.html
+share/doc/plor/plor-2.html
+share/doc/plor/plor.html
+share/doc/plor/plor.txt
+share/doc/plor/porting.notes