aboutsummaryrefslogtreecommitdiff
path: root/news/tin
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2006-01-19 19:51:38 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2006-01-19 19:51:38 +0000
commit8436f2d7f788e623b50ad7339e711ba1a34a23bd (patch)
tree328b8f478063a8a07ed055d1bb51a1b7260917cd /news/tin
parenta6dbbc031873e6e0d4c46562fd8a019682cf22f5 (diff)
downloadports-8436f2d7f788e623b50ad7339e711ba1a34a23bd.tar.gz
ports-8436f2d7f788e623b50ad7339e711ba1a34a23bd.zip
Fix allocation off-by-one
Submitted by: Aleksey Salow <aleksey.salow@gmail.com>
Notes
Notes: svn path=/head/; revision=153896
Diffstat (limited to 'news/tin')
-rw-r--r--news/tin/Makefile1
-rw-r--r--news/tin/files/patch-src-mail.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/news/tin/Makefile b/news/tin/Makefile
index 0ab771a78a1f..9edaab4035e3 100644
--- a/news/tin/Makefile
+++ b/news/tin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tin
PORTVERSION= 1.8.0
+PORTREVISION= 1
CATEGORIES+= news ipv6
MASTER_SITES= http://mirrors.rcn.net/pub/news/tin/stable/ \
ftp://mirrors.rcn.net/pub/news/tin/stable/ \
diff --git a/news/tin/files/patch-src-mail.c b/news/tin/files/patch-src-mail.c
new file mode 100644
index 000000000000..6b21288435f1
--- /dev/null
+++ b/news/tin/files/patch-src-mail.c
@@ -0,0 +1,11 @@
+--- src/mail.c.orig Wed Jan 18 23:29:18 2006
++++ src/mail.c Wed Jan 18 23:29:28 2006
+@@ -369,7 +369,7 @@
+ space = strlen(ptr) + 1;
+ groupname = my_malloc(space);
+ } else {
+- while (strlen(ptr) > space) { /* realloc needed? */
++ while (strlen(ptr) + 1 > space) { /* realloc needed? */
+ space <<= 1; /* double size */
+ groupname = my_realloc(groupname, space);
+ }