aboutsummaryrefslogtreecommitdiff
path: root/news/tin
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2014-05-04 15:21:21 +0000
committerJohan van Selst <johans@FreeBSD.org>2014-05-04 15:21:21 +0000
commita2703243a4b9918348be1d7ae2002261efb67fb6 (patch)
tree311301b54a70a408a26f732ac8ad8c1d2056aff2 /news/tin
parente0fc4ee41d543c38fee9d46ba1a62d7adab45f8a (diff)
downloadports-a2703243a4b9918348be1d7ae2002261efb67fb6.tar.gz
ports-a2703243a4b9918348be1d7ae2002261efb67fb6.zip
Update to tin 2.2.1
Notes
Notes: svn path=/head/; revision=352959
Diffstat (limited to 'news/tin')
-rw-r--r--news/tin/Makefile72
-rw-r--r--news/tin/distinfo4
-rw-r--r--news/tin/pkg-plist3
3 files changed, 25 insertions, 54 deletions
diff --git a/news/tin/Makefile b/news/tin/Makefile
index 93a4bb764559..64b1263e12f7 100644
--- a/news/tin/Makefile
+++ b/news/tin/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tin
-PORTVERSION= 2.2.0
+PORTVERSION= 2.2.1
CATEGORIES+= news ipv6
MASTER_SITES= ftp://ftp.tin.org/pub/news/clients/tin/v${PORTVERSION:R}/ \
ftp://ftp.sunet.se/pub/news/readers/tin/v${PORTVERSION:R}/ \
@@ -24,20 +24,30 @@ LIB_DEPENDS= libuu.so:${PORTSDIR}/converters/uulib \
libpcre.so:${PORTSDIR}/devel/pcre
RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support
-USE_BZIP2= yes
-USES= gmake iconv shebangfix
+USES= gmake iconv shebangfix tar:bzip2
GNU_CONFIGURE= yes
SHEBANG_FILES= tools/opt-case.pl tools/tinews.pl tools/url_handler.pl \
tools/w2r.pl
TIN_EDITOR?= /usr/bin/ee
TIN_SCREEN?= ncursesw
-OPTIONS_DEFINE= GNUPG ISPELL METAMAIL CANLOCK NNTP_ONLY
-OPTIONS_DEFAULT=GNUPG ISPELL METAMAIL
-CANLOCK_DESC= Enable Cancel-Lock key support via libcanlock
-NNTP_ONLY= Only read news via NNTP (no spool dir support)
-
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= GNUPG ISPELL METAMAIL CANLOCK NNTP_ONLY NLS
+OPTIONS_DEFAULT= GNUPG ISPELL METAMAIL
+OPTIONS_SUB= yes
+NNTP_ONLY_DESC= Only read news via NNTP (no spool dir support)
+NNTP_ONLY_CONFIGURE_ENABLE=nntp-only
+GNUPG_RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+GNUPG_CONFIGURE_ON= --with-gpg=${PREFIX}/bin/gpg \
+ --without-pgp --without-pgpk
+GNUPG_CONFIGURE_OFF= --disable-pgp-gpg
+ISPELL_RUN_DEPENDS= ispell:${PORTSDIR}/textproc/aspell-ispell
+ISPELL_CONFIGURE_ARGS= --with-ispell=${PREFIX}/bin/ispell
+METAMAIL_RUN_DEPENDS= metamail:${PORTSDIR}/mail/metamail
+METAMAIL_CONFIGURE_ARGS=--with-metamail=${PREFIX}/bin/metamail
+CANLOCK_DESC= Enable Cancel-Lock key support via libcanlock
+CANLOCK_CONFIGURE_ENABLE=cancel-locks
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
# --with-mime-default-charset=US-ASCII needed to build tin in the non-ascii
# national environment.
@@ -58,41 +68,6 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
ALL_TARGET= build
-.if ${PORT_OPTIONS:MNNTP_ONLY}
-CONFIGURE_ARGS+= --enable-nntp-only
-.endif
-
-.if ${PORT_OPTIONS:MGNUPG}
-RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
-CONFIGURE_ARGS+= --with-gpg=${PREFIX}/bin/gpg \
- --without-pgp --without-pgpk
-.else
-CONFIGURE_ARGS+= --disable-pgp-gpg
-.endif
-
-.if ${PORT_OPTIONS:MISPELL}
-RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/aspell-ispell
-CONFIGURE_ARGS+= --with-ispell=${PREFIX}/bin/ispell
-.endif
-
-.if ${PORT_OPTIONS:MMETAMAIL}
-RUN_DEPENDS+= metamail:${PORTSDIR}/mail/metamail
-CONFIGURE_ARGS+= --with-metamail=${PREFIX}/bin/metamail
-.endif
-
-.if ${PORT_OPTIONS:MCANLOCK}
-CONFIGURE_ARGS+= --enable-cancel-locks
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-CONFIGURE_ARGS+= --enable-nls
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
post-patch:
${REINPLACE_CMD} -Ee 's:5/(mmdf|mbox):5/tin_\1:g' \
${WRKSRC}/src/Makefile.in
@@ -112,15 +87,12 @@ post-patch:
${WRKSRC}/tools/tinurl_handler.pl
post-build:
-.if ${PORT_OPTIONS:MNLS}
cd ${WRKSRC}/po; ${GMAKE}
-.endif
post-install:
cd ${STAGEDIR}${PREFIX}/etc;\
- ${INSTALL_DATA} ${WRKSRC}/doc/tin.defaults tin.defaults.dist;\
- if [ ! -f tin.defaults ] ; then \
- ${CP} tin.defaults.dist tin.defaults; \
- fi
+ ${INSTALL_DATA} ${WRKSRC}/doc/tin.defaults tin.defaults.dist;\
+ ${CP} -pn tin.defaults.dist tin.defaults;
+ ln -sf tin ${STAGEDIR}${PREFIX}/bin/rtin
.include <bsd.port.mk>
diff --git a/news/tin/distinfo b/news/tin/distinfo
index 8a9dfc9d830e..218324e37cd7 100644
--- a/news/tin/distinfo
+++ b/news/tin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tin-2.2.0.tar.bz2) = ba25cc3345675810c85cc0bddcce5474370ce91dce91d8433176f0de858b5b44
-SIZE (tin-2.2.0.tar.bz2) = 1836169
+SHA256 (tin-2.2.1.tar.bz2) = 2356661d26823dbfdf06f6a2efd5f0a2141f470c5d25fbdd55842ff342f41f01
+SIZE (tin-2.2.1.tar.bz2) = 1834572
diff --git a/news/tin/pkg-plist b/news/tin/pkg-plist
index 32259226f904..55894e9b5880 100644
--- a/news/tin/pkg-plist
+++ b/news/tin/pkg-plist
@@ -1,8 +1,7 @@
bin/metamutt
bin/opt-case.pl
+bin/rtin
bin/tin
-@exec ln -fs %f %B/rtin
-@unexec rm -f %B/rtin
bin/tinews.pl
bin/tinurl_handler.pl
bin/w2r.pl