aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-01-13 15:28:12 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-01-13 15:28:12 +0000
commit1d0edd85f9dae3e075891f7a3aaf1ef1a6b98081 (patch)
treed45c11bd1e29ff12a0f95dbe5b3edc0072f53983 /news
parentc7f394ab81b4db52afb04b10a0a4f341c7678330 (diff)
downloadports-1d0edd85f9dae3e075891f7a3aaf1ef1a6b98081.tar.gz
ports-1d0edd85f9dae3e075891f7a3aaf1ef1a6b98081.zip
Add a new patch/files dir to news/klibido port to enable support
for up to 20 simultaneous server connections instead of the default limit of 10. This will allow users with Giganews accounts to take full advantage of their max connections allowed. PR: ports/107851 Submitted by: Conrad J. Sabatier (maintainer)
Notes
Notes: svn path=/head/; revision=182298
Diffstat (limited to 'news')
-rw-r--r--news/klibido/Makefile3
-rw-r--r--news/klibido/files/patch-src_addserver.cpp20
2 files changed, 23 insertions, 0 deletions
diff --git a/news/klibido/Makefile b/news/klibido/Makefile
index 61a2d5f1bb6b..6d832891019e 100644
--- a/news/klibido/Makefile
+++ b/news/klibido/Makefile
@@ -7,6 +7,7 @@
PORTNAME= klibido
PORTVERSION= 0.2.5
+PORTREVISION= 1
CATEGORIES= news
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,6 +22,8 @@ USE_KDELIBS_VER= 3
USE_XLIB= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
+INSTALLS_ICONS= yes
+USE_GETTEXT= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include/db44 ${PTHREAD_CFLAGS}" \
CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include/db44" \
diff --git a/news/klibido/files/patch-src_addserver.cpp b/news/klibido/files/patch-src_addserver.cpp
new file mode 100644
index 000000000000..c1c10197ae92
--- /dev/null
+++ b/news/klibido/files/patch-src_addserver.cpp
@@ -0,0 +1,20 @@
+--- src/addserver.cpp.orig Tue Dec 12 20:12:32 2006
++++ src/addserver.cpp Tue Dec 12 20:13:17 2006
+@@ -27,7 +27,7 @@
+ buttonOk->setIconSet(KGlobal::iconLoader()->loadIcon("button_ok", KIcon::Small, 0, false));
+ buttonCancel->setIconSet(KGlobal::iconLoader()->loadIcon("button_cancel", KIcon::Small, 0, false));
+ m_priorityInput->setRange(1,10,1,false);
+- m_threadInput->setRange(1,10,1,false);
++ m_threadInput->setRange(1,20,1,false);
+ m_timeoutInput->setRange(60,600,5,false);
+ m_threadTimeoutInput->setRange(1,30,1,false);
+ validator=new QIntValidator(1,65535,this);
+@@ -90,7 +90,7 @@
+ buttonOk->setIconSet(KGlobal::iconLoader()->loadIcon("button_ok", KIcon::Small, 0, false));
+ buttonCancel->setIconSet(KGlobal::iconLoader()->loadIcon("button_cancel", KIcon::Small, 0, false));
+ m_priorityInput->setRange(1,10,1,false);
+- m_threadInput->setRange(1,10,1,false);
++ m_threadInput->setRange(1,20,1,false);
+ m_timeoutInput->setRange(60,600,5,false);
+ m_threadTimeoutInput->setRange(1,30,1,false);
+ validator=new QIntValidator(1,65535,this);