aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
commit29747f458a1eb2ce23b4594b09d0256dd62760b8 (patch)
tree1b71ba5d9ffdd308b6c18130f7c116f5bab5dc12 /news
parent7aad84f808b93baa6a7077ce0b47573b9c4c79a0 (diff)
downloadports-29747f458a1eb2ce23b4594b09d0256dd62760b8.tar.gz
ports-29747f458a1eb2ce23b4594b09d0256dd62760b8.zip
Chase the GNOME X11BASE to LOCALBASE move, and fix the build with the
new freetype2 where needed. Submitted by: mezz, ahze, pav, and many others Approved by: portmgr (implicit, kris)
Notes
Notes: svn path=/head/; revision=175261
Diffstat (limited to 'news')
-rw-r--r--news/pan/Makefile25
-rw-r--r--news/pan/distinfo6
-rw-r--r--news/pan/files/patch-Makefile.in11
-rw-r--r--news/pan/files/patch-pan.desktop.in7
-rw-r--r--news/pan/files/patch-pan_base_text-massager.c36
-rw-r--r--news/pan/pkg-descr8
-rw-r--r--news/pan/pkg-plist45
7 files changed, 60 insertions, 78 deletions
diff --git a/news/pan/Makefile b/news/pan/Makefile
index f479040534b1..962fee2862bd 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -3,27 +3,25 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/news/pan/Makefile,v 1.4 2006/10/11 11:55:59 ahze Exp $
#
PORTNAME= pan
-PORTVERSION= 0.14.2.91
-PORTREVISION= 4
+PORTVERSION= 0.116
CATEGORIES= news gnome
-MASTER_SITES= http://pan.rebelbase.com/download/releases/${PORTVERSION}/SOURCE/ \
- http://pan.rebelbase.com/download/obsolete/${PORTVERSION}/SOURCE/
-DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
+MASTER_SITES= http://pan.rebelbase.com/download/releases/${PORTVERSION}/source/
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= Threaded GNOME 2 newsreader based on Agent for Windows
+COMMENT= Threaded GTK+2 newsreader based on Agent for Windows
-LIB_DEPENDS= gnet-2.0.0:${PORTSDIR}/net/gnet2 \
- pcre.0:${PORTSDIR}/devel/pcre-utf8
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre-utf8 \
+ gmime-2.0.4:${PORTSDIR}/mail/gmime2
+USE_XLIB= yes
USE_BZIP2= yes
-USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack gnometarget libxml2 gtk20
+USE_GNOME= gnomehack gnometarget gtk20 intlhack
USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
@@ -34,13 +32,10 @@ OPTIONS= GTKSPELL "Enable spell checking support" on
.include <bsd.port.pre.mk>
.if defined(WITHOUT_GTKSPELL)
-CONFIGURE_ARGS+= --disable-gtkspell
+CONFIGURE_ARGS+= --without-gtkspell
.else
LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell
+CONFIGURE_ARGS+= --with-gtkspell
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|apps/Internet|applications|g' \
- ${WRKSRC}/Makefile.in
-
.include <bsd.port.post.mk>
diff --git a/news/pan/distinfo b/news/pan/distinfo
index 8f6d26a61224..e12076ec4dd2 100644
--- a/news/pan/distinfo
+++ b/news/pan/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/pan-0.14.2.91.tar.bz2) = 4770d899a1c1ba968ce96bc5aeb07b62
-SHA256 (gnome2/pan-0.14.2.91.tar.bz2) = 1658c22fbe29ac0b88d2ae8e487247bad40618809719819297ecf0b7ae69a9ab
-SIZE (gnome2/pan-0.14.2.91.tar.bz2) = 1919099
+MD5 (gnome2/pan-0.116.tar.bz2) = 590587dea07f23f5e87562fdddd67d4a
+SHA256 (gnome2/pan-0.116.tar.bz2) = 77965bcceff35ae591ee477ac3229d22eb5998687cd8f1f6eb95b8abc0ce760b
+SIZE (gnome2/pan-0.116.tar.bz2) = 1402968
diff --git a/news/pan/files/patch-Makefile.in b/news/pan/files/patch-Makefile.in
deleted file mode 100644
index 1ffb18687e4c..000000000000
--- a/news/pan/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Thu Jul 24 22:49:46 2003
-+++ Makefile.in Thu Jul 24 22:49:56 2003
-@@ -116,7 +116,7 @@
- XML_CFLAGS = @XML_CFLAGS@
- XML_LIBS = @XML_LIBS@
-
--SUBDIRS = po gmime pan docs tests
-+SUBDIRS = po gmime pan docs
-
- DESKTOP_IN_FILES = pan.desktop.in
- DESKTOP_FILES = $(DESKTOP_IN_FILES:.desktop.in=.desktop)
diff --git a/news/pan/files/patch-pan.desktop.in b/news/pan/files/patch-pan.desktop.in
deleted file mode 100644
index 19781ac29ab6..000000000000
--- a/news/pan/files/patch-pan.desktop.in
+++ /dev/null
@@ -1,7 +0,0 @@
---- pan.desktop.in.orig Sun Feb 27 16:13:23 2005
-+++ pan.desktop.in Sun Feb 27 16:14:07 2005
-@@ -6,3 +6,4 @@
- Icon=pan.png
- Terminal=false
- Type=Application
-+Categories=Application;Network;News;
diff --git a/news/pan/files/patch-pan_base_text-massager.c b/news/pan/files/patch-pan_base_text-massager.c
deleted file mode 100644
index 0d17a321bdb0..000000000000
--- a/news/pan/files/patch-pan_base_text-massager.c
+++ /dev/null
@@ -1,36 +0,0 @@
---- pan/base/text-massager.c.orig Mon Jan 26 00:51:26 2004
-+++ pan/base/text-massager.c Mon Jan 26 00:55:48 2004
-@@ -250,23 +250,29 @@
- char * pch;
- char * line_start;
- char * end;
-+ int pos;
-
- /* walk through the entire string */
- linefeed_here = NULL;
-- for (line_start=pch=str->str, end=line_start+str->len; pch!=end; )
-+ for (pos = 0, line_start=pch=str->str, end=line_start+str->len; pch<end; )
- {
- /* a linefeed could go here; remember this space */
-- if (isspace((guchar)*pch) || *pch=='\n')
-+ if (g_unichar_isspace(g_utf8_get_char (pch)) || *pch=='\n')
- linefeed_here = pch;
-
- /* line's too long; add a linefeed if we can */
-- if (pch-line_start>=column && linefeed_here!=NULL)
-+ if (pos>=column && linefeed_here!=NULL)
- {
- *linefeed_here = '\n';
- pch = line_start = linefeed_here + 1;
- linefeed_here = NULL;
-+ pos = 0;
-+ }
-+ else
-+ {
-+ pch = g_utf8_next_char (pch);
-+ ++ pos;
- }
-- else ++pch;
- }
- }
-
diff --git a/news/pan/pkg-descr b/news/pan/pkg-descr
index 7dba56b05697..9f09a421f788 100644
--- a/news/pan/pkg-descr
+++ b/news/pan/pkg-descr
@@ -1,6 +1,6 @@
-A powerful and easy to use newsreader for GNOME 2.
-
-Pan has many features for easy reading and posting, displaying
-and saving attachments, and offline newsreading.
+Pan is a newsreader, loosely based on Agent and Gravity, which attempts to
+be pleasant to use for new and advanced users alike. It has all the typical
+features found in newsreaders, and also supports offline reading, multiple
+connections, and a number of features for power users and alt.binaries fans.
WWW: http://pan.rebelbase.com/
diff --git a/news/pan/pkg-plist b/news/pan/pkg-plist
index bc80927dfa34..6f56a3218ff3 100644
--- a/news/pan/pkg-plist
+++ b/news/pan/pkg-plist
@@ -1,13 +1,14 @@
bin/pan
-share/gnome/applications/pan.desktop
-share/gnome/pixmaps/pan.png
+share/applications/pan.desktop
share/locale/am/LC_MESSAGES/pan.mo
share/locale/az/LC_MESSAGES/pan.mo
+share/locale/bg/LC_MESSAGES/pan.mo
share/locale/ca/LC_MESSAGES/pan.mo
share/locale/cs/LC_MESSAGES/pan.mo
share/locale/da/LC_MESSAGES/pan.mo
share/locale/de/LC_MESSAGES/pan.mo
share/locale/el/LC_MESSAGES/pan.mo
+share/locale/en_CA/LC_MESSAGES/pan.mo
share/locale/en_GB/LC_MESSAGES/pan.mo
share/locale/es/LC_MESSAGES/pan.mo
share/locale/et/LC_MESSAGES/pan.mo
@@ -15,6 +16,7 @@ share/locale/fi/LC_MESSAGES/pan.mo
share/locale/fr/LC_MESSAGES/pan.mo
share/locale/ga/LC_MESSAGES/pan.mo
share/locale/gl/LC_MESSAGES/pan.mo
+share/locale/hr/LC_MESSAGES/pan.mo
share/locale/hu/LC_MESSAGES/pan.mo
share/locale/it/LC_MESSAGES/pan.mo
share/locale/ja/LC_MESSAGES/pan.mo
@@ -22,14 +24,17 @@ share/locale/ko/LC_MESSAGES/pan.mo
share/locale/lt/LC_MESSAGES/pan.mo
share/locale/lv/LC_MESSAGES/pan.mo
share/locale/ms/LC_MESSAGES/pan.mo
+share/locale/nb/LC_MESSAGES/pan.mo
share/locale/nl/LC_MESSAGES/pan.mo
share/locale/no/LC_MESSAGES/pan.mo
share/locale/pl/LC_MESSAGES/pan.mo
share/locale/pt/LC_MESSAGES/pan.mo
share/locale/pt_BR/LC_MESSAGES/pan.mo
+share/locale/ro/LC_MESSAGES/pan.mo
share/locale/ru/LC_MESSAGES/pan.mo
share/locale/sk/LC_MESSAGES/pan.mo
share/locale/sl/LC_MESSAGES/pan.mo
+share/locale/sq/LC_MESSAGES/pan.mo
share/locale/sr/LC_MESSAGES/pan.mo
share/locale/sr@Latn/LC_MESSAGES/pan.mo
share/locale/sv/LC_MESSAGES/pan.mo
@@ -37,3 +42,39 @@ share/locale/tr/LC_MESSAGES/pan.mo
share/locale/uk/LC_MESSAGES/pan.mo
share/locale/vi/LC_MESSAGES/pan.mo
share/locale/zh_CN/LC_MESSAGES/pan.mo
+share/locale/zh_TW/LC_MESSAGES/pan.mo
+share/pixmaps/pan.png
+@dirrmtry share/pixmaps
+@dirrmtry share/applications
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
+@dirrmtry share/locale/zh_CN/LC_MESSAGES
+@dirrmtry share/locale/zh_CN
+@dirrmtry share/locale/uk/LC_MESSAGES
+@dirrmtry share/locale/uk
+@dirrmtry share/locale/sr/LC_MESSAGES
+@dirrmtry share/locale/sr
+@dirrmtry share/locale/sl/LC_MESSAGES
+@dirrmtry share/locale/sl
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
+@dirrmtry share/locale/ro/LC_MESSAGES
+@dirrmtry share/locale/ro
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/no/LC_MESSAGES
+@dirrmtry share/locale/no
+@dirrmtry share/locale/ko/LC_MESSAGES
+@dirrmtry share/locale/ko
+@dirrmtry share/locale/gl/LC_MESSAGES
+@dirrmtry share/locale/gl
+@dirrmtry share/locale/fi/LC_MESSAGES
+@dirrmtry share/locale/fi
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca