aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-04-25 08:18:54 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-04-25 08:18:54 +0000
commit83550de70211bd40f235bd410116f46f6482fe20 (patch)
tree8627082cc9a73a314129533640235d24e1a79e9c /news
parent65b278b4f2308b911c07420e27786419800caf10 (diff)
downloadports-83550de70211bd40f235bd410116f46f6482fe20.tar.gz
ports-83550de70211bd40f235bd410116f46f6482fe20.zip
New Port: news/knzb
Knzb is a KDE binary newsgroup download tool. It parses and loads nzb files, such as those from Newzbin.com (An nzb file is an xml 'index' file, for news posts). PR: ports/76302 Submitted by: Tim Welch <twelch@thepentagon.org>
Notes
Notes: svn path=/head/; revision=134108
Diffstat (limited to 'news')
-rw-r--r--news/Makefile1
-rw-r--r--news/knzb/Makefile29
-rw-r--r--news/knzb/distinfo2
-rw-r--r--news/knzb/pkg-descr5
-rw-r--r--news/knzb/pkg-plist6
5 files changed, 43 insertions, 0 deletions
diff --git a/news/Makefile b/news/Makefile
index c149f2273e55..d7cfb2234193 100644
--- a/news/Makefile
+++ b/news/Makefile
@@ -40,6 +40,7 @@
SUBDIR += inn-stable
SUBDIR += klibido
SUBDIR += knews
+ SUBDIR += knzb
SUBDIR += leafnode
SUBDIR += leafnode+
SUBDIR += mmail
diff --git a/news/knzb/Makefile b/news/knzb/Makefile
new file mode 100644
index 000000000000..09128294fb82
--- /dev/null
+++ b/news/knzb/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: knzb
+# Date created: 15 January 2005
+# Whom: Tim Welch <twelch@thepentagon.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= knzb
+PORTVERSION= 0.3
+CATEGORIES= news
+MASTER_SITES= http://dmp.org.uk/linux/knzb/download/
+
+MAINTAINER= ports@freebsd.org
+COMMENT= KDE binary newsgroup download tool
+
+USE_BZIP2= yes
+WRKSRC= ${WRKDIR}/knzb
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_QT_VER= 3
+USE_KDELIBS_VER= 3
+NO_INSTALL_MANPAGES= yes
+
+pre-configure:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${TOUCH} -f
+
+.include <bsd.port.mk>
diff --git a/news/knzb/distinfo b/news/knzb/distinfo
new file mode 100644
index 000000000000..ae3757c0ffe0
--- /dev/null
+++ b/news/knzb/distinfo
@@ -0,0 +1,2 @@
+MD5 (knzb-0.3.tar.bz2) = 5c348e5d3d1fa4232e661db72b06f8a0
+SIZE (knzb-0.3.tar.bz2) = 507035
diff --git a/news/knzb/pkg-descr b/news/knzb/pkg-descr
new file mode 100644
index 000000000000..79a979f59a7c
--- /dev/null
+++ b/news/knzb/pkg-descr
@@ -0,0 +1,5 @@
+Knzb is a KDE binary newsgroup download tool. It parses and loads nzb files,
+such as those from Newzbin.com (An nzb file is an xml 'index' file, for
+news posts).
+
+WWW: http://dmp.org.uk/linux/knzb/
diff --git a/news/knzb/pkg-plist b/news/knzb/pkg-plist
new file mode 100644
index 000000000000..3614428ea2b1
--- /dev/null
+++ b/news/knzb/pkg-plist
@@ -0,0 +1,6 @@
+bin/knzb
+share/applnk/Applications/knzb.desktop
+share/apps/knzb/knzbui.rc
+share/icons/locolor/16x16/apps/knzb.png
+share/icons/locolor/32x32/apps/knzb.png
+@dirrm share/apps/knzb