aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-27 10:20:38 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-27 10:20:38 +0000
commit999e63c02164030bb4b0c3240f37773923a092ba (patch)
tree5c31ca1769bcb5afe37fbb5416874be30a258f60 /news
parent325a61af62e9a335753635e1594a8d5189ccac3f (diff)
downloadports-999e63c02164030bb4b0c3240f37773923a092ba.tar.gz
ports-999e63c02164030bb4b0c3240f37773923a092ba.zip
Support stage
Fix shebang
Notes
Notes: svn path=/head/; revision=337690
Diffstat (limited to 'news')
-rw-r--r--news/mail2nntp/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/news/mail2nntp/Makefile b/news/mail2nntp/Makefile
index da20a0a2f23f..b55addc9e095 100644
--- a/news/mail2nntp/Makefile
+++ b/news/mail2nntp/Makefile
@@ -13,22 +13,18 @@ LICENSE= GPLv2
RUN_DEPENDS= p5-NNTPClient>=0:${PORTSDIR}/news/p5-NNTPClient
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
NO_BUILD= yes
+SHEBANG_FILES= mail2nntp.pl
PORTDOCS= *
PLIST_FILES= bin/mail2nntp.pl
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/mail2nntp.pl ${PREFIX}/bin
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Changelog ${DOCSDIR}
-.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/mail2nntp.pl ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Changelog ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>