aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorOllivier Robert <roberto@FreeBSD.org>2002-07-30 14:16:28 +0000
committerOllivier Robert <roberto@FreeBSD.org>2002-07-30 14:16:28 +0000
commitc49e45aafbfe06891040560a66c8c53176d7c5bd (patch)
tree543b941450d6c3c102b86dd5705c2d925ebc4bb3 /news
parent9a35cb0bc6e3d3467cf941aabb2b7f57395dd243 (diff)
downloadports-c49e45aafbfe06891040560a66c8c53176d7c5bd.tar.gz
ports-c49e45aafbfe06891040560a66c8c53176d7c5bd.zip
Newspost is a full-featured Usenet binary autoposter. It is meant as
an all-in-one posting solution. In addition to posting files, it can post text prefixes, and generate and post .SFV files and .PAR volumes. WWW: http://newspost.unixcab.org/ AUTHOR: Jim Faulkner <newspost@unixcab.org> PR: ports/40916 Submitted by: Michael L. Hostbaek (mich@freebsdcluster.org)
Notes
Notes: svn path=/head/; revision=63739
Diffstat (limited to 'news')
-rw-r--r--news/newspost/Makefile35
-rw-r--r--news/newspost/distinfo1
-rw-r--r--news/newspost/pkg-comment1
-rw-r--r--news/newspost/pkg-descr9
-rw-r--r--news/newspost/pkg-plist3
5 files changed, 49 insertions, 0 deletions
diff --git a/news/newspost/Makefile b/news/newspost/Makefile
new file mode 100644
index 000000000000..faa0448b5026
--- /dev/null
+++ b/news/newspost/Makefile
@@ -0,0 +1,35 @@
+# ex:ts=8
+# Ports collection makefile for: newspost
+# Date created: Tue Jul 23, 2002
+# Whom: Michael L. Hostbaek (mich@freebsdcluster.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= newspost
+PORTVERSION= 2.0
+CATEGORIES= news
+MASTER_SITES= http://newspost.unixcab.org/download/
+
+MAINTAINER= mich@freebsdcluster.org
+
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}
+
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|^CC|#CC|g" \
+ -e "s|^OPT_FLAGS|#OPT_FLAGS|g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/man/man1/newspost.1 ${PREFIX}/man/man1
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
+.endif
+
+MAN1= newspost.1
+
+.include <bsd.port.mk>
diff --git a/news/newspost/distinfo b/news/newspost/distinfo
new file mode 100644
index 000000000000..6b5f7cfb0af7
--- /dev/null
+++ b/news/newspost/distinfo
@@ -0,0 +1 @@
+MD5 (newspost-2.0.tar.gz) = 664f96c37b2a6566cf55dc4e040648fe
diff --git a/news/newspost/pkg-comment b/news/newspost/pkg-comment
new file mode 100644
index 000000000000..70fd0d03441c
--- /dev/null
+++ b/news/newspost/pkg-comment
@@ -0,0 +1 @@
+Newspost is a full-featured USEnet binary autoposter
diff --git a/news/newspost/pkg-descr b/news/newspost/pkg-descr
new file mode 100644
index 000000000000..02b46170227e
--- /dev/null
+++ b/news/newspost/pkg-descr
@@ -0,0 +1,9 @@
+Newspost is a full-featured USEnet binary autoposter. It is meant as
+an all-in-one posting solution. In addition to posting files, it can
+post text prefixes, and generate and post .SFV files and .PAR volumes.
+
+WWW: http://newspost.unixcab.org/
+AUTHOR: Jim Faulkner <newspost@unixcab.org>
+
+ - Michael L. Hostbaek
+ mich@freebsdcluster.org
diff --git a/news/newspost/pkg-plist b/news/newspost/pkg-plist
new file mode 100644
index 000000000000..e99b31bc1835
--- /dev/null
+++ b/news/newspost/pkg-plist
@@ -0,0 +1,3 @@
+bin/newspost
+share/doc/newspost/README
+@dirrm share/doc/newspost