aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-04-10 11:15:25 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-04-10 11:15:25 +0000
commitca117d27ee55b5f016f4ed6afc30b821746505b8 (patch)
tree45cacd1af0466d1167c190aa2dc34bed8c124979 /news
parent849fa4c9c6fb4be4e2c7508d8355abafe542a327 (diff)
downloadports-ca117d27ee55b5f016f4ed6afc30b821746505b8.tar.gz
ports-ca117d27ee55b5f016f4ed6afc30b821746505b8.zip
- Optionize docs
- Switch to options helpers
Notes
Notes: svn path=/head/; revision=438143
Diffstat (limited to 'news')
-rw-r--r--news/nntpcache/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/news/nntpcache/Makefile b/news/nntpcache/Makefile
index 5c93ff712122..a1c50d1888ac 100644
--- a/news/nntpcache/Makefile
+++ b/news/nntpcache/Makefile
@@ -28,7 +28,7 @@ SHEBANG_FILES= contrib/perlnewshound/newshound.pl
AUTHINFO_EXT= authinfo_pam.ext
USE_RC_SUBR= nntpcached
-OPTIONS_DEFINE= LDAP RADIUS SPAMPHOBIA
+OPTIONS_DEFINE= LDAP RADIUS SPAMPHOBIA DOCS
SPAMPHOBIA_DESC= Spamphobia NoCeM support
RADIUS_CONFIGURE_WITH= authinfo-radius
@@ -51,11 +51,10 @@ SPAMPHOBIA_PATCH_SITES= http://people.freebsd.org/~leeym/:SPAMPHOBIA
SPAMPHOBIA_PATCHFILES= ${DISTNAME}-spamphobia-${REVISEDATE}.diff.gz:SPAMPHOBIA
post-configure:
- ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} -C ${WRKSRC}/src ${AUTHINFO_EXT}
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} -C ${WRKSRC}/src ${AUTHINFO_EXT}
-post-install:
- @ ${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC} && ${FIND} ${PORTDOCS} \
- | ${CPIO_CMD} ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DOCSDIR})
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>