aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-09-07 21:11:32 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-09-07 21:11:32 +0000
commitd5df9881cb84ef7b3b8eaf8683dea9cb4052be22 (patch)
tree9f4231b524aa094587e6fad0028918e0bfca33e3 /news
parentd256da64fc94ab887acc8255c19c06382456c140 (diff)
downloadports-d5df9881cb84ef7b3b8eaf8683dea9cb4052be22.tar.gz
ports-d5df9881cb84ef7b3b8eaf8683dea9cb4052be22.zip
- Fix build with OpenSSL >= 1.0 [1]
- Mark MAKE_JOBS_UNSAFE: ===> Building for nzbget-0.8.0 /usr/bin/make all-am make: illegal option -- - usage: make [-BPSXeiknpqrstv] [-C directory] [-D variable] [-d flags] [-E variable] [-f makefile] [-I directory] [-j max_jobs] [-m directory] [-V variable] [variable=value] [target ...] PR: ports/171196 [1] Submitted by: freebsd@nagilum.org [1] Approved by: maintainer
Notes
Notes: svn path=/head/; revision=303829
Diffstat (limited to 'news')
-rw-r--r--news/nzbget/Makefile1
-rw-r--r--news/nzbget/files/patch-TLS.cpp32
2 files changed, 33 insertions, 0 deletions
diff --git a/news/nzbget/Makefile b/news/nzbget/Makefile
index 9c03053780ee..b6b50be8bd0e 100644
--- a/news/nzbget/Makefile
+++ b/news/nzbget/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
GNU_CONFIGURE= yes
CONFIGURE_ENV= LOCALBASE="${LOCALBASE}"
+MAKE_JOBS_UNSAFE=yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= ${PTHREAD_LIBS}
CFLAGS+= ${PTHREAD_CFLAGS}
diff --git a/news/nzbget/files/patch-TLS.cpp b/news/nzbget/files/patch-TLS.cpp
new file mode 100644
index 000000000000..e691fb837cd5
--- /dev/null
+++ b/news/nzbget/files/patch-TLS.cpp
@@ -0,0 +1,32 @@
+--- TLS.cpp.orig 2011-06-14 23:47:22.000000000 +0200
++++ TLS.cpp 2012-08-31 09:27:41.000000000 +0200
+@@ -908,7 +908,7 @@
+ char *buf;
+ int bufsize;
+ /* needed to get the DNS subjectAltNames: */
+- STACK *subj_alt_names;
++ STACK_OF(GENERAL_NAME) *subj_alt_names;
+ int subj_alt_names_count;
+ GENERAL_NAME *subj_alt_name;
+ /* did we find a name matching hostname? */
+@@ -960,7 +960,7 @@
+ /* Try the DNS subjectAltNames. */
+ match_found = 0;
+ if ((subj_alt_names =
+- (STACK*)X509_get_ext_d2i(x509cert, NID_subject_alt_name, NULL, NULL)))
++ (STACK_OF(GENERAL_NAME) *)X509_get_ext_d2i(x509cert, NID_subject_alt_name, NULL, NULL)))
+ {
+ subj_alt_names_count = sk_GENERAL_NAME_num(subj_alt_names);
+ for (i = 0; i < subj_alt_names_count; i++)
+@@ -1105,7 +1105,11 @@
+
+ #ifdef HAVE_OPENSSL
+
++ #if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ const SSL_METHOD *ssl_method = NULL;
++ #else
+ SSL_METHOD *ssl_method = NULL;
++ #endif
+
+ ssl_method = force_sslv3 ? SSLv3_client_method() : SSLv23_client_method();
+ if (!ssl_method)