aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2013-11-27 22:33:26 +0000
committerThierry Thomas <thierry@FreeBSD.org>2013-11-27 22:33:26 +0000
commitdb9989e931d1144b340fae9c6290092e61f63741 (patch)
treefb7e82063cb21996d3feb5a24b32f9b9a402b402 /news
parent2c976bf6fd7e82bda791f38c963b42967156b4fc (diff)
downloadports-db9989e931d1144b340fae9c6290092e61f63741.tar.gz
ports-db9989e931d1144b340fae9c6290092e61f63741.zip
- Chase the update of INN;
- Stagify.
Notes
Notes: svn path=/head/; revision=335070
Diffstat (limited to 'news')
-rw-r--r--news/newsx/Makefile26
-rw-r--r--news/newsx/files/patch-configure16
-rw-r--r--news/newsx/pkg-plist8
3 files changed, 29 insertions, 21 deletions
diff --git a/news/newsx/Makefile b/news/newsx/Makefile
index b0edbed7974f..826a3dfd9ea0 100644
--- a/news/newsx/Makefile
+++ b/news/newsx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= newsx
PORTVERSION= 1.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= news
MASTER_SITES= http://www.kvaleberg.org/pub/
@@ -18,10 +18,6 @@ BUILD_DEPENDS= ${LOCALBASE}/news/lib/libcnews.a:${PORTSDIR}/news/cnews
BUILD_DEPENDS= ${LOCALBASE}/news/lib/libinn.a:${PORTSDIR}/news/inn
.endif
-.if defined(PACKAGE_BUILDING)
-IGNORE= a configured INN is required
-.endif
-
GNU_CONFIGURE= yes
CONFLICTS= leafnode-1.*
@@ -38,11 +34,8 @@ CONFIGURE_ARGS+= --without-history
DOCS= AUTHORS COPYING ChangeLog FAQ INSTALL NEWS README TODO
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e "s:%%LOCALBASE%%:${LOCALBASE}:g" ${WRKSRC}/configure
-
pre-configure:
+ ${REINPLACE_CMD} -e "s:%%LOCALBASE%%:${LOCALBASE}:g" ${WRKSRC}/configure
@${ECHO} "*********************************************************"
@${ECHO} "If the configure step fails, then you probably don't have"
@${ECHO} "a news server package installed. Try installing INN from"
@@ -50,20 +43,19 @@ pre-configure:
@${ECHO} "again."
@${ECHO} "*********************************************************"
-pre-install:
- @${STRIP_CMD} ${WRKSRC}/src/newsx
+post-build:
+.if !defined(WITH_DEBUG)
+ ${STRIP_CMD} ${WRKSRC}/src/newsx
+.endif
post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/news/spool/inhosts
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for FILE in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}
.endfor
@${ECHO} "Documentation installed in ${DOCSDIR}."
.endif
-MAN1= newsq.1
-MAN5= newsx.conf.5 in.hosts.5
-MAN8= newsx.8
-
.include <bsd.port.mk>
diff --git a/news/newsx/files/patch-configure b/news/newsx/files/patch-configure
index 05398e5bea9d..945040469c6e 100644
--- a/news/newsx/files/patch-configure
+++ b/news/newsx/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Sun May 18 19:25:34 2003
-+++ configure Sun May 18 23:45:15 2003
+--- configure.orig 2003-05-18 19:25:34.000000000 +0200
++++ configure 2013-11-27 17:22:07.000000000 +0100
@@ -253,7 +253,7 @@
#
# Initializations.
@@ -29,3 +29,15 @@
# Check whether --with-newshome or --without-newshome was given.
+@@ -1890,7 +1890,11 @@
+ # it has been reported that some INN 2.1 had its own VERSION
+ VERSION_save="$VERSION"
+ VERSION=
++ prefix_orig="${prefix}"
++ exec_prefix_orig="${exec_prefix}"
+ . $NEWSCONFIG
++ prefix="${prefix_orig}"
++ exec_prefix="${exec_prefix_orig}"
+ INN_VERSION="$VERSION"
+ VERSION="$VERSION_save"
+ INN_NEWSUMASK=`umask`
diff --git a/news/newsx/pkg-plist b/news/newsx/pkg-plist
index ac7c428723a8..75d5ea001746 100644
--- a/news/newsx/pkg-plist
+++ b/news/newsx/pkg-plist
@@ -1,5 +1,9 @@
-bin/newsx
bin/newsq
+bin/newsx
+man/man1/newsq.1.gz
+man/man5/in.hosts.5.gz
+man/man5/newsx.conf.5.gz
+man/man8/newsx.8.gz
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
@@ -9,6 +13,6 @@ bin/newsq
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm news/spool/inhosts
+@dirrmtry news/spool/inhosts
@dirrmtry news/spool
@dirrmtry news