aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-02-08 22:45:48 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-02-08 22:45:48 +0000
commitf646cfe7078a1729eba79818651e83e3534c53dd (patch)
tree841d8c4270039c77bfd3070b4d06f44dd4d21b9b /news
parentbea3479ee218b730a9888b26b16e72a084e200f6 (diff)
downloadports-f646cfe7078a1729eba79818651e83e3534c53dd.tar.gz
ports-f646cfe7078a1729eba79818651e83e3534c53dd.zip
news/nzbhydra2: update to 2.3.6
- while here, also address the issue of the missing data directory PR: 235545 Submitted by: Daniel Shafer <daniel@shafer.cc> (maintainer) Differential Revision: https://reviews.freebsd.org/D19091
Notes
Notes: svn path=/head/; revision=492464
Diffstat (limited to 'news')
-rw-r--r--news/nzbhydra2/Makefile4
-rw-r--r--news/nzbhydra2/distinfo6
-rw-r--r--news/nzbhydra2/files/nzbhydra2.in17
3 files changed, 15 insertions, 12 deletions
diff --git a/news/nzbhydra2/Makefile b/news/nzbhydra2/Makefile
index 9f8ba34838af..e45b55a0eca3 100644
--- a/news/nzbhydra2/Makefile
+++ b/news/nzbhydra2/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= nzbhydra2
-DISTVERSION= 2.3.4
+DISTVERSION= 2.3.6
DISTVERSIONSUFFIX= -linux
CATEGORIES= news java
MASTER_SITES= https://github.com/theotherp/${PORTNAME}/releases/download/v${DISTVERSION}/
@@ -32,7 +32,7 @@ JAVA_RUN= yes
USERS= nzbhydra2
GROUPS= nzbhydra2
-PLIST_FILES= ${DATADIR}/lib/core-2.3.4-exec.jar \
+PLIST_FILES= ${DATADIR}/lib/core-2.3.6-exec.jar \
${DATADIR}/nzbhydra2 \
${DATADIR}/nzbhydra2wrapper.py \
${DATADIR}/changelog.md \
diff --git a/news/nzbhydra2/distinfo b/news/nzbhydra2/distinfo
index 15a7a3356ac0..48b4652c4fdc 100644
--- a/news/nzbhydra2/distinfo
+++ b/news/nzbhydra2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1549150850
-SHA256 (nzbhydra2-2.3.4-linux.zip) = 4c999d26886531ddba66d7c8e656da3fba50476abd722d8823d3cd128d8d5132
-SIZE (nzbhydra2-2.3.4-linux.zip) = 61624259
+TIMESTAMP = 1549478817
+SHA256 (nzbhydra2-2.3.6-linux.zip) = e3aef24aac61f9094f80cd7d93821a103058b4410bafe3ec7d183abaf40bd5dc
+SIZE (nzbhydra2-2.3.6-linux.zip) = 61625733
diff --git a/news/nzbhydra2/files/nzbhydra2.in b/news/nzbhydra2/files/nzbhydra2.in
index e32b254e59de..cf60b53eef29 100644
--- a/news/nzbhydra2/files/nzbhydra2.in
+++ b/news/nzbhydra2/files/nzbhydra2.in
@@ -21,7 +21,7 @@
# as wheel.
# nzbhydra2_dir: Directory where nzbhydra lives.
# Default: %%PREFIX%%/share/nzbhydra2
-# nzbhydra2_datafolder: Data directory for nzbhydra (DB, Logs, config)
+# nzbhydra2_data_dir: Data directory for nzbhydra (DB, Logs, config)
# Default: %%PREFIX%%/nzbhydra2
. /etc/rc.subr
@@ -35,14 +35,17 @@ load_rc_config ${name}
: ${nzbhydra2_user:="nzbhydra2"}
: ${nzbhydra2_group:="nzbhydra2"}
: ${nzbhydra2_dir:="%%PREFIX%%/share/nzbhydra2"}
-: ${nzbhydra2_datafolder:="%%PREFIX%%/nzbhydra2"}
+: ${nzbhydra2_data_dir:="%%PREFIX%%/nzbhydra2"}
pidfile="/var/run/nzbhydra2/nzbhydra2.pid"
command="%%PYTHON_CMD%%"
-command_args="${nzbhydra2_dir}/nzbhydra2wrapper.py --datafolder ${nzbhydra2_datafolder} --pidfile ${pidfile} --daemon --nobrowser --java %%JAVA%%"
+command_args="${nzbhydra2_dir}/nzbhydra2wrapper.py --datafolder ${nzbhydra2_data_dir} --pidfile ${pidfile} --daemon --nobrowser --java %%JAVA%%"
+start_precmd=nzbhydra2_precmd
+
+nzbhydra2_precmd()
+{
+ export XDG_CONFIG_HOME=${nzbhydra2_data_dir}
-start_precmd="prestart"
-prestart() {
if [ -f ${pidfile} ]; then
rm -f ${pidfile}
echo "Removing stale pidfile."
@@ -50,8 +53,8 @@ prestart() {
install -d -o ${nzbhydra2_user} -g ${nzbhydra2_group} ${pidfile%/*}
fi
- if [ ! -d ${nzbhydra2_datadir} ]; then
- install -d -o ${nzbhydra2_user} -g ${nzbhydra2_group} ${nzbhydra2_datadir}
+ if [ ! -d ${nzbhydra2_data_dir} ]; then
+ install -d -o ${nzbhydra2_user} -g ${nzbhydra2_group} ${nzbhydra2_data_dir}
fi
}