aboutsummaryrefslogtreecommitdiff
path: root/palm/pilot-link
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2001-08-24 19:35:11 +0000
committerMikhail Teterin <mi@FreeBSD.org>2001-08-24 19:35:11 +0000
commit4ecea026d6a8e64fc59cb5fdb7f53b9fcff76734 (patch)
treefa220c15b401d20764388f8400594144858ff12a /palm/pilot-link
parent494e6a1cb7871a25f7a4c64a2e98daa4cb54d29c (diff)
downloadports-4ecea026d6a8e64fc59cb5fdb7f53b9fcff76734.tar.gz
ports-4ecea026d6a8e64fc59cb5fdb7f53b9fcff76734.zip
Upgrade to 0.9.5, use -lgiconv.
Notes
Notes: svn path=/head/; revision=46816
Diffstat (limited to 'palm/pilot-link')
-rw-r--r--palm/pilot-link/Makefile32
-rw-r--r--palm/pilot-link/distinfo2
-rw-r--r--palm/pilot-link/files/patch-ab20
-rw-r--r--palm/pilot-link/files/patch-getopt8
-rw-r--r--palm/pilot-link/files/patch-iconv7
-rw-r--r--palm/pilot-link/pkg-descr4
-rw-r--r--palm/pilot-link/pkg-plist2
7 files changed, 51 insertions, 24 deletions
diff --git a/palm/pilot-link/Makefile b/palm/pilot-link/Makefile
index 30a65ec6abe4..96459c070bb1 100644
--- a/palm/pilot-link/Makefile
+++ b/palm/pilot-link/Makefile
@@ -6,36 +6,44 @@
#
PORTNAME= pilot-link
-PORTVERSION= 0.9.3
-CATEGORIES= palm comms tk82
-MASTER_SITES= ftp://ryeham.ee.ryerson.ca/pub/PalmOS/ \
- ftp://ftp.forth.org/pub/PalmOS/ryerson/
+PORTVERSION= 0.9.5
+CATEGORIES= palm comms tk83
+MASTER_SITES= http://www.gnu-designs.com/pilot-link/source/
DISTNAME= ${PORTNAME}.${PORTVERSION}
MAINTAINER= dima@freebsd.org
-LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
+LIB_DEPENDS= tk83:${PORTSDIR}/x11-toolkits/tk83 \
+ giconv:${PORTSDIR}/converters/libiconv
+USE_BZIP2= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
USE_PERL5= yes
PREFIX= ${LOCALBASE}/pilot
-CONFIGURE_ARGS= --with-perl5=${PERL5}
-
-.include <bsd.port.pre.mk>
-
-CFLAGS!= ${ECHO} "${CFLAGS}" | ${SED} -e 's/-O[0-9a-z]*//g'
+CONFIGURE_ARGS= --with-perl5=${PERL5} --with-libiconv=${LOCALBASE}
MAN1= dlpsh.1 ietf2datebook.1 install-datebook.1 \
install-hinote.1 install-memo.1 install-user.1 \
pilot-xfer.1 read-ical.1
MAN7= pilot-link.7
+CFLAGS+= -I${LOCALBASE}/include
+
post-patch:
- @${CHMOD} 755 ${WRKSRC}/${CONFIGURE_SCRIPT}
+ # FreeBSD installs -lgiconv instead of -liconv. Patch configure.
+ ${PERL} -pi -e 's/([^g])iconv.h/\1giconv.h/g;' \
+ -e 's/-liconv/-lgiconv/g' ${WRKSRC}/${CONFIGURE_SCRIPT} \
+ ${WRKSRC}/libsock/util.c
+ # Remove the FORCE tag, which forced recompiling/relinking
+ # of the otherwise up-to-date files.
+ ${PERL} -pi -e 's/: FORCE/:/;' -e 's/getopt.h//;' ${WRKSRC}/Makefile.in
+ # When the day comes, and pilot-link starts using longopt,
+ # we'll start using -lgnugetopt. No need for this files:
+ ${RM} -f ${WRKSRC}/getopt*
post-install:
@${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/pilot-link.sh > ${LOCALBASE}/etc/rc.d/pilot-link.sh
@${CHMOD} 750 ${LOCALBASE}/etc/rc.d/pilot-link.sh
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/palm/pilot-link/distinfo b/palm/pilot-link/distinfo
index 898c45520e1f..449f11f0e1af 100644
--- a/palm/pilot-link/distinfo
+++ b/palm/pilot-link/distinfo
@@ -1 +1 @@
-MD5 (pilot-link.0.9.3.tar.gz) = c985505028a441f53a25fc2a3838a847
+MD5 (pilot-link.0.9.5.tar.bz2) = f5f4eb673fe277b2738c889bb355b269
diff --git a/palm/pilot-link/files/patch-ab b/palm/pilot-link/files/patch-ab
index e31a1919be46..5d3eee04be8f 100644
--- a/palm/pilot-link/files/patch-ab
+++ b/palm/pilot-link/files/patch-ab
@@ -21,64 +21,64 @@
# Extract the first word of "ranlib", so it can be a program name with args.
@@ -2643,5 +2643,5 @@
if test "x$with_tcl" = "xyes" || test "x$with_tcl" = "x" ; then
- for tcl_path in /usr/local/tcl8.2 /usr/local/tcl8.0 /usr/local/tcl7.6 /usr/local/tcl7.5 /usr/local /usr /usr/local/tcl7.4; do
+ for tcl_path in /usr/local/tcl8.3 /usr/local/tcl8.0 /usr/local/tcl7.6 /usr/local/tcl7.5 /usr/local /usr /usr/local/tcl7.4; do
- if test -f $tcl_path/lib/tclConfig.sh; then
-+ if test -f $tcl_path/lib/tcl8.2/tclConfig.sh; then
++ if test -f $tcl_path/lib/tcl8.3/tclConfig.sh; then
with_tcl=$tcl_path; break
elif test -f $tcl_path/lib/itcl/tclConfig.sh; then
@@ -2684,5 +2684,5 @@
echo "$ac_t""not used" 1>&6
else
- tclConfig="$with_tcl/lib$itcl/tclConfig.sh"
-+ tclConfig="$with_tcl/lib/tcl8.2$itcl/tclConfig.sh"
++ tclConfig="$with_tcl/lib/tcl8.3$itcl/tclConfig.sh"
if test ! -f $tclConfig; then
echo "$ac_t""Unable to find tclConfig.sh" 1>&6
@@ -2690,5 +2690,5 @@
. $tclConfig
echo "$ac_t""version $TCL_VERSION from $tclConfig" 1>&6
- TCL_INC="-I$TCL_PREFIX/include$itcl"
-+ TCL_INC="-I$TCL_PREFIX/include/tcl8.2$itcl"
++ TCL_INC="-I$TCL_PREFIX/include/tcl8.3$itcl"
TCL_BIN="$TCL_EXEC_PREFIX/bin"
TCLLIBS="$TCL_LIB_SPEC $TCL_LIBS"
@@ -2701,5 +2701,5 @@
if test "x$with_itcl" = "xyes" || test "x$with_itcl" = "x"; then
for itcl_path in $with_tcl; do
- if test -f $itcl_path/lib$itcl/itclConfig.sh; then
-+ if test -f $itcl_path/lib/tcl8.2$itcl/itclConfig.sh; then
++ if test -f $itcl_path/lib/tcl8.3$itcl/itclConfig.sh; then
with_itcl=$itcl_path; break
fi
@@ -2719,5 +2719,5 @@
echo "$ac_t""not used" 1>&6
else
- itclConfig="$with_itcl/lib$itcl/itclConfig.sh"
-+ itclConfig="$with_itcl/lib/tcl8.2$itcl/itclConfig.sh"
++ itclConfig="$with_itcl/lib/tcl8.3$itcl/itclConfig.sh"
if test ! -f $itclConfig; then
echo "$ac_t""Unable to find itclConfig.sh" 1>&6
@@ -2725,5 +2725,5 @@
. $itclConfig
echo "$ac_t""version $ITCL_VERSION from $itclConfig" 1>&6
- ITCL_INC="-I$TK_PREFIX/include$itcl"
-+ ITCL_INC="-I$TK_PREFIX/include/tcl8.2$itcl"
++ ITCL_INC="-I$TK_PREFIX/include/tcl8.3$itcl"
#TK_BIN="$TK_EXEC_PREFIX/bin"
#TKLIBS="$TK_LIB_SPEC $TCL_LIB_SPEC $TK_LIBS"
@@ -2743,5 +2743,5 @@
if test "x$with_tk" = "xyes" || test "x$with_tk" = "x"; then
for tk_path in $with_tcl; do
- if test -f $tk_path/lib$itcl/tkConfig.sh; then
-+ if test -f $tk_path/lib/tk8.2$itcl/tkConfig.sh; then
++ if test -f $tk_path/lib/tk8.3$itcl/tkConfig.sh; then
with_tk=$tk_path; break
fi
@@ -2761,5 +2761,5 @@
echo "$ac_t""not used" 1>&6
else
- tkConfig="$with_tk/lib$itcl/tkConfig.sh"
-+ tkConfig="$with_tk/lib/tk8.2$itcl/tkConfig.sh"
++ tkConfig="$with_tk/lib/tk8.3$itcl/tkConfig.sh"
if test ! -f $tkConfig; then
echo "$ac_t""Unable to find tkConfig.sh" 1>&6
@@ -2767,5 +2767,5 @@
. $tkConfig
echo "$ac_t""version $TK_VERSION from $tkConfig" 1>&6
- TK_INC="-I$TK_PREFIX/include$itcl"
-+ TK_INC="-I$TK_PREFIX/include/tk8.2$itcl"
++ TK_INC="-I$TK_PREFIX/include/tk8.3$itcl"
TK_BIN="$TK_EXEC_PREFIX/bin"
TKLIBS="$TK_LIB_SPEC $TCL_LIB_SPEC $TK_LIBS"
diff --git a/palm/pilot-link/files/patch-getopt b/palm/pilot-link/files/patch-getopt
new file mode 100644
index 000000000000..84ed178740af
--- /dev/null
+++ b/palm/pilot-link/files/patch-getopt
@@ -0,0 +1,8 @@
+Don' link include this useless getopt reimplementations into every
+executable. When/if pilot-link starts to use the longopt/getopt_long, it
+should check if the libc or the libgnugetopt has them first.
+
++++ Makefile.in Fri Aug 24 10:17:57 2001
+@@ -102,1 +102,1 @@ PERLEXECS = pilot-undelete ietf2datebook
+-GETOPT = getopt.o getopt1.o
++GETOPT =
diff --git a/palm/pilot-link/files/patch-iconv b/palm/pilot-link/files/patch-iconv
new file mode 100644
index 000000000000..a74bf261bf7e
--- /dev/null
+++ b/palm/pilot-link/files/patch-iconv
@@ -0,0 +1,7 @@
+If we use iconv -- link pisock with it, so others don't have to:
+
+--- libsock/Makefile.in Tue Jun 19 12:25:26 2001
++++ libsock/Makefile.in Fri Aug 24 10:09:20 2001
+@@ -57,1 +57,1 @@
+- -o libpisock.la $(OBJS)
++ -o libpisock.la $(OBJS) @ICONV_LIBS@
diff --git a/palm/pilot-link/pkg-descr b/palm/pilot-link/pkg-descr
index 7bba675a735f..c3c619b075d2 100644
--- a/palm/pilot-link/pkg-descr
+++ b/palm/pilot-link/pkg-descr
@@ -2,3 +2,7 @@ pilot-link is a series of tools designed to extract and add data to a PalmPilot
organizer. There are programs in here to transfer data, debug the pilot,
synchronize with calendars, and a set of include files and libraries with which
you may build your own applications in C, C++, Perl5, Tcl, Java, and Python.
+
+It does NOT (yet) support USB linked PDAa.
+
+WWW: http://www.gnu-designs.com/pilot-link/
diff --git a/palm/pilot-link/pkg-plist b/palm/pilot-link/pkg-plist
index a724e9218de4..be02e8f57d17 100644
--- a/palm/pilot-link/pkg-plist
+++ b/palm/pilot-link/pkg-plist
@@ -74,7 +74,7 @@ include/pi-version.h
lib/libpicc.a
lib/libpisock.a
lib/libpisock.so
-lib/libpisock.so.3.1
+lib/libpisock.so.4.0
lib/pix/b1.gif
lib/pix/b2.gif
lib/pix/b3.gif