aboutsummaryrefslogtreecommitdiff
path: root/palm/synce-libsynce/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-27 13:18:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-27 13:18:41 +0000
commitffaa1bfe8a9a5c076f0cf6e5c434d0a5285aae2d (patch)
tree73ba22119f9d193d7b1289b87dd11cbbd4f12105 /palm/synce-libsynce/Makefile
parentc13b98c55f0a47c490318324b4659416bb0d8dd5 (diff)
downloadports-ffaa1bfe8a9a5c076f0cf6e5c434d0a5285aae2d.tar.gz
ports-ffaa1bfe8a9a5c076f0cf6e5c434d0a5285aae2d.zip
- Update to 0.12
- Pass maintainership to submitter PR: Bakulin Ilya <webmaster@kibab.com>
Notes
Notes: svn path=/head/; revision=217658
Diffstat (limited to 'palm/synce-libsynce/Makefile')
-rw-r--r--palm/synce-libsynce/Makefile38
1 files changed, 29 insertions, 9 deletions
diff --git a/palm/synce-libsynce/Makefile b/palm/synce-libsynce/Makefile
index 0e6b69eedb67..60f97f679b9d 100644
--- a/palm/synce-libsynce/Makefile
+++ b/palm/synce-libsynce/Makefile
@@ -4,22 +4,42 @@
#
# $FreeBSD$
-PORTNAME= synce-libsynce
-PORTVERSION= 0.9.3
+PORTNAME= libsynce
+PORTVERSION= 0.12
CATEGORIES= palm
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= synce
+MASTER_SITES= SF/synce
+PKGNAMEPREFIX= synce-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= webmaster@kibab.com
COMMENT= Library to support communication with WinCE devices
-MAN1= synce.1
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
+ hal.1:${PORTSDIR}/sysutils/hal
-USE_ICONV= yes
GNU_CONFIGURE= yes
-WRKSRC= ${WRKDIR}/libsynce-${PORTVERSION}
+USE_AUTOTOOLS= libtool:15
+USE_ICONV= yes
+USE_GNOME= gnomehack gnometarget
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
+CONFIGURE_ARGS+= --with-libiconv-prefix="${LOCALBASE}" \
+ --enable-dccm-file-support=no \
+ --enable-hal-support=yes \
+ --enable-odccm-support=no
+
+MAN3= synce_info_new.3 wstrlen.3 wstrcpy.3 wstrdup.3 \
+ synce_get_directory.3 synce_get_connection_filename.3 \
+ synce_strerror.3 wstr_to_ascii.3 time_fields_from_filetime.3 \
+ date_from_tm.3 synce_error.3 synce_info_destroy.3 \
+ synce_get_subdirectory.3 synce_get_script_directory.3 \
+ synce_set_connection_filename.3 wstr_to_current.3 \
+ synce_set_default_connection_filename.3 wstr_to_utf8.3 \
+ wstr_from_ascii.3 wstr_from_utf8.3 wstr_from_current.3 \
+ wstr_free_string.3 wstr_append.3 wstr_equal.3 \
+ time_fields_to_filetime.3 date_to_tm.3 synce_warning.3 \
+ synce_info.3 synce_debug.3 synce_trace.3 \
+ synce_warning_unless.3 synce_log_set_level.3 \
+ synce_log_use_syslog.3
+MAN7= synce.7
USE_LDCONFIG= yes