aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-11-30 13:53:05 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2012-11-30 13:53:05 +0000
commit6026d0fee3e92a5b004cee7807e9ec159a3dfb0c (patch)
tree122ab5f682296edd9c93ac23dc2f3f63a32056ad /palm
parent34d97af841b2d49b3bba5e95cf64f6fcab0de7c0 (diff)
downloadports-6026d0fee3e92a5b004cee7807e9ec159a3dfb0c.tar.gz
ports-6026d0fee3e92a5b004cee7807e9ec159a3dfb0c.zip
- Fix the code instead of suppressing the compiler error
Feature safe: yes Approved by: bapt (previous commit was his)
Notes
Notes: svn path=/head/; revision=308011
Diffstat (limited to 'palm')
-rw-r--r--palm/palm-db-tools/Makefile2
-rw-r--r--palm/palm-db-tools/files/patch-libflatfile-Database.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/palm/palm-db-tools/Makefile b/palm/palm-db-tools/Makefile
index 9b138e9720e8..e11cf56e4f83 100644
--- a/palm/palm-db-tools/Makefile
+++ b/palm/palm-db-tools/Makefile
@@ -20,7 +20,7 @@ PLIST_FILES= lib/libpdbtools.so \
bin/pdb2csv
post-patch:
- @${REINPLACE_CMD} -e "s|-Wno-deprecated|& -fPIC -DPIC -Wno-error|" \
+ @${REINPLACE_CMD} -e "s|-Wno-deprecated|& -fPIC -DPIC|" \
${WRKSRC}/libflatfile/Makefile.in ${WRKSRC}/libpalm/Makefile.in \
${WRKSRC}/libsupport/Makefile.in ${WRKSRC}/flatfile/Makefile.in
diff --git a/palm/palm-db-tools/files/patch-libflatfile-Database.cpp b/palm/palm-db-tools/files/patch-libflatfile-Database.cpp
new file mode 100644
index 000000000000..5c28dbe529b6
--- /dev/null
+++ b/palm/palm-db-tools/files/patch-libflatfile-Database.cpp
@@ -0,0 +1,11 @@
+--- libflatfile/Database.cpp.orig 2012-11-30 14:43:18.000000000 +0100
++++ libflatfile/Database.cpp 2012-11-30 14:48:11.000000000 +0100
+@@ -208,7 +208,7 @@
+ // Ensure that the field numbers are within range.
+ for (PalmLib::FlatFile::ListView::const_iterator i = lv.begin();
+ i != lv.end(); ++i) {
+- if ((*i).field < 0 || (*i).field >= getNumOfFields())
++ if ((*i).field >= getNumOfFields())
+ return;
+ }
+ m_listviews.push_back(lv);