aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-04-27 18:25:24 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-04-27 18:25:24 +0000
commit95e70819761ed898d6a4ea9874d4bd43a5491f3e (patch)
tree05c37dd385b99b953046290a1ad749042e2d1c51 /palm
parent284101cc39e019e4530f6878d10381ed2e68a3d5 (diff)
downloadports-95e70819761ed898d6a4ea9874d4bd43a5491f3e.tar.gz
ports-95e70819761ed898d6a4ea9874d4bd43a5491f3e.zip
- Convert USE_ICONV=yes to USES=iconv
- Change USE_GNOME=pkgconfig|gnomehack to USES=pathfix|pkgconfig and USE_GETTEXT=yes to USES=gettext while here
Notes
Notes: svn path=/head/; revision=316683
Diffstat (limited to 'palm')
-rw-r--r--palm/pilot-link/Makefile3
-rw-r--r--palm/synce-hal/Makefile2
-rw-r--r--palm/synce-librapi2/Makefile3
-rw-r--r--palm/synce-librra/Makefile3
-rw-r--r--palm/synce-libsynce/Makefile3
-rw-r--r--palm/synce-vdccm/Makefile2
6 files changed, 6 insertions, 10 deletions
diff --git a/palm/pilot-link/Makefile b/palm/pilot-link/Makefile
index 0a3e220ac0e0..2226c7d3154b 100644
--- a/palm/pilot-link/Makefile
+++ b/palm/pilot-link/Makefile
@@ -13,9 +13,8 @@ COMMENT= Suite of tools used to connect and sync your Palm handled
BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig iconv
USE_BZIP2= yes
-USE_ICONV= yes
GNU_CONFIGURE= yes
CFLAGS+= -I${WRKSRC}/popt -I${LOCALBASE}/include
CONFIGURE_ARGS+=--with-libiconv=${LOCALBASE} --with-included-popt --enable-conduits --enable-xsltproc
diff --git a/palm/synce-hal/Makefile b/palm/synce-hal/Makefile
index 563dbcc68eb0..5ba39b7dd53c 100644
--- a/palm/synce-hal/Makefile
+++ b/palm/synce-hal/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= synce.0:${PORTSDIR}/palm/synce-libsynce \
dbus-1.3:${PORTSDIR}/devel/dbus \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
-USE_ICONV= yes
+USES= iconv
USE_PYTHON_RUN= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-hal-addon-dir=${PREFIX}/libexec \
diff --git a/palm/synce-librapi2/Makefile b/palm/synce-librapi2/Makefile
index a52fdfb483cf..51e3da440722 100644
--- a/palm/synce-librapi2/Makefile
+++ b/palm/synce-librapi2/Makefile
@@ -19,8 +19,7 @@ CONFLICTS= popular-[0-9]*
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
-USE_ICONV= yes
-USES= pathfix
+USES= pathfix iconv
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-libiconv="${LOCALBASE}" \
--with-libsynce="${LOCALBASE}"
diff --git a/palm/synce-librra/Makefile b/palm/synce-librra/Makefile
index 53719ed552a2..349655823c5e 100644
--- a/palm/synce-librra/Makefile
+++ b/palm/synce-librra/Makefile
@@ -23,9 +23,8 @@ OPTIONS?= TOOLS "Build with minor rra command line tools" on \
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
-USE_ICONV= yes
USE_LDCONFIG= yes
-USES= pathfix
+USES= pathfix iconv
CONFIGURE_ARGS+= --with-libsynce="${LOCALBASE}" \
--with-libmimedir="${LOCALBASE}"
diff --git a/palm/synce-libsynce/Makefile b/palm/synce-libsynce/Makefile
index 5a295d43ae61..52c32a24a222 100644
--- a/palm/synce-libsynce/Makefile
+++ b/palm/synce-libsynce/Makefile
@@ -18,8 +18,7 @@ LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
-USE_ICONV= yes
-USES= pathfix
+USES= pathfix iconv
CONFIGURE_ARGS+= --with-libiconv-prefix="${LOCALBASE}" \
--enable-dccm-file-support=no \
--enable-hal-support=yes \
diff --git a/palm/synce-vdccm/Makefile b/palm/synce-vdccm/Makefile
index 48f12beed7dd..9ef41c3d8a3d 100644
--- a/palm/synce-vdccm/Makefile
+++ b/palm/synce-vdccm/Makefile
@@ -20,7 +20,7 @@ MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
WANT_GNOME= yes
-USE_ICONV= yes
+USES= iconv
CONFIGURE_ARGS= --with-libiconv=${LOCALBASE} \
--with-libsynce=${LOCALBASE}