aboutsummaryrefslogtreecommitdiff
path: root/polish/kadu
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2017-05-11 16:59:56 +0000
committerPawel Pekala <pawel@FreeBSD.org>2017-05-11 16:59:56 +0000
commit51cc59a6a8aa481be72ebb74e7989bfa9afd9259 (patch)
tree889226c120d2d508119255935b194ec3ff95cc23 /polish/kadu
parent93bd0c4d1e0e18721728b5c14e414b6d955eee51 (diff)
downloadports-51cc59a6a8aa481be72ebb74e7989bfa9afd9259.tar.gz
ports-51cc59a6a8aa481be72ebb74e7989bfa9afd9259.zip
Fix segfault on program exit
Notes
Notes: svn path=/head/; revision=440635
Diffstat (limited to 'polish/kadu')
-rw-r--r--polish/kadu/Makefile2
-rw-r--r--polish/kadu/files/patch-kadu-core_gui_actions_action-description.cpp12
2 files changed, 13 insertions, 1 deletions
diff --git a/polish/kadu/Makefile b/polish/kadu/Makefile
index 9e4ef52404e2..76a310aab2c0 100644
--- a/polish/kadu/Makefile
+++ b/polish/kadu/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kadu
PORTVERSION= 4.3
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= polish net-im
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/:kadu \
diff --git a/polish/kadu/files/patch-kadu-core_gui_actions_action-description.cpp b/polish/kadu/files/patch-kadu-core_gui_actions_action-description.cpp
new file mode 100644
index 000000000000..40e5d83c94f3
--- /dev/null
+++ b/polish/kadu/files/patch-kadu-core_gui_actions_action-description.cpp
@@ -0,0 +1,12 @@
+--- kadu-core/gui/actions/action-description.cpp.orig 2017-01-24 21:36:21 UTC
++++ kadu-core/gui/actions/action-description.cpp
+@@ -103,7 +103,8 @@ void ActionDescription::registerAction(Actions *action
+
+ void ActionDescription::unregisterAction(Actions *actions)
+ {
+- actions->remove(this);
++ if (actions)
++ actions->remove(this);
+ }
+
+ void ActionDescription::actionAboutToBeDestroyed(Action *action)