aboutsummaryrefslogtreecommitdiff
path: root/polish
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-08-04 12:57:34 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-08-04 12:57:34 +0000
commit83f65c5ce7af9b4755552c72421bee455e1ca53b (patch)
tree11a2626d62bca3ac7eadca0f6398708e11ecd244 /polish
parent602d7369f178bcb37b9b75a3ee260e0f4660eb8a (diff)
downloadports-83f65c5ce7af9b4755552c72421bee455e1ca53b.tar.gz
ports-83f65c5ce7af9b4755552c72421bee455e1ca53b.zip
Move configurationfile from /etc to ${PREFIX}/etc.
Corected also shell from /bin/bash to /bin/sh PR: 53565 Submitted by: Krzysztof Stryjek <wtp@mud.pl>
Notes
Notes: svn path=/head/; revision=86282
Diffstat (limited to 'polish')
-rw-r--r--polish/sms/Makefile9
-rw-r--r--polish/sms2/Makefile9
2 files changed, 18 insertions, 0 deletions
diff --git a/polish/sms/Makefile b/polish/sms/Makefile
index dd714485edd4..5aec5f917076 100644
--- a/polish/sms/Makefile
+++ b/polish/sms/Makefile
@@ -18,11 +18,20 @@ LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
WRKSRC= ${WRKDIR}/sms
USE_GMAKE= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= # empty
MAKE_ARGS= CXX="${CXX}"
.if defined(NOPORTDOCS)
MAKE_ARGS+= NOPORTDOCS=1
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's,/etc/smsrc,${PREFIX}/etc/smsrc,' \
+ ${WRKSRC}/sms.h \
+ ${WRKSRC}/README.smsrc
+ @${REINPLACE_CMD} -e 's,bash,sh,' \
+ ${WRKSRC}/contrib/sms-conf
+
post-install:
${STRIP_CMD} ${PREFIX}/bin/sms
diff --git a/polish/sms2/Makefile b/polish/sms2/Makefile
index dd714485edd4..5aec5f917076 100644
--- a/polish/sms2/Makefile
+++ b/polish/sms2/Makefile
@@ -18,11 +18,20 @@ LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
WRKSRC= ${WRKDIR}/sms
USE_GMAKE= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= # empty
MAKE_ARGS= CXX="${CXX}"
.if defined(NOPORTDOCS)
MAKE_ARGS+= NOPORTDOCS=1
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's,/etc/smsrc,${PREFIX}/etc/smsrc,' \
+ ${WRKSRC}/sms.h \
+ ${WRKSRC}/README.smsrc
+ @${REINPLACE_CMD} -e 's,bash,sh,' \
+ ${WRKSRC}/contrib/sms-conf
+
post-install:
${STRIP_CMD} ${PREFIX}/bin/sms