aboutsummaryrefslogtreecommitdiff
path: root/polish
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 05:31:28 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 06:00:48 +0000
commit915dbfaa562e20c8402d3873f8bfbf07899f9f8a (patch)
tree31846497e11ce47118708aa782fe87dbb6a7599f /polish
parentaa9edcc217007fd4a39e10ee17805dd350c25381 (diff)
downloadports-915dbfaa562e20c8402d3873f8bfbf07899f9f8a.tar.gz
ports-915dbfaa562e20c8402d3873f8bfbf07899f9f8a.zip
*/*hyphen: Avoid using %% in Makefile
Use ${DATAIDR} instead of %%DATADIR%%
Diffstat (limited to 'polish')
-rw-r--r--polish/hyphen/Makefile2
-rw-r--r--polish/hyphen/Makefile 25
2 files changed, 26 insertions, 1 deletions
diff --git a/polish/hyphen/Makefile b/polish/hyphen/Makefile
index cedf1a78f2da..5ab3f039402a 100644
--- a/polish/hyphen/Makefile
+++ b/polish/hyphen/Makefile
@@ -16,7 +16,7 @@ NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/hyph_pl_PL.dic
+PLIST_FILES= ${DATADIR}/hyph_pl_PL.dic
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/
diff --git a/polish/hyphen/Makefile b/polish/hyphen/Makefile
new file mode 100644
index 000000000000..cedf1a78f2da
--- /dev/null
+++ b/polish/hyphen/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= hyphen
+PORTVERSION= 2007.04.16
+PORTREVISION= 1
+CATEGORIES= polish textproc
+MASTER_SITES= LOCAL/sunpoet/${PORTNAME}/
+DISTNAME= hyph_pl_PL-${PORTVERSION:C/\.//g}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Polish hyphenation rules
+
+LICENSE= LGPL21
+
+USES= zip
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/hyph_pl_PL.dic
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/hyph_pl_PL.dic ${STAGEDIR}${DATADIR}/
+
+.include <bsd.port.mk>