aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/barry
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-09-21 01:21:22 +0000
committerWill Andrews <will@FreeBSD.org>2002-09-21 01:21:22 +0000
commitfef04938ed988cc0e7231ea538f2284873f5d20d (patch)
treee4997f25b476f164d548e0f2dca092b6b5d0bb53 /ports-mgmt/barry
parentf9270878e3b96e5f68aad7b80a4cb34791a08b19 (diff)
downloadports-fef04938ed988cc0e7231ea538f2284873f5d20d.tar.gz
ports-fef04938ed988cc0e7231ea538f2284873f5d20d.zip
Add barry 0.5.3, a nice KDE frontend to the ports system.
Notes
Notes: svn path=/head/; revision=66948
Diffstat (limited to 'ports-mgmt/barry')
-rw-r--r--ports-mgmt/barry/Makefile29
-rw-r--r--ports-mgmt/barry/distinfo1
-rw-r--r--ports-mgmt/barry/files/patch-Makefile33
-rw-r--r--ports-mgmt/barry/pkg-comment1
-rw-r--r--ports-mgmt/barry/pkg-descr1
-rw-r--r--ports-mgmt/barry/pkg-plist23
6 files changed, 88 insertions, 0 deletions
diff --git a/ports-mgmt/barry/Makefile b/ports-mgmt/barry/Makefile
new file mode 100644
index 000000000000..098c01b156f6
--- /dev/null
+++ b/ports-mgmt/barry/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: barry
+# Date created: 19 September 2002
+# Whom: Brad Davis <so14k@so14k.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= barry
+PORTVERSION= 0.5.3
+CATEGORIES= sysutils kde
+MASTER_SITES= http://frerich.ath.cx/barry/
+
+MAINTAINER= so14k@so14k.com
+
+USE_BZIP2= yes
+USE_KDELIBS_VER=3
+MAKE_ENV= QTDIR="${X11BASE}" KDEDIR="${LOCALBASE}" PREFIX="${PREFIX}"
+USE_REINPLACE= yes
+
+pre-build:
+ ${REINPLACE_CMD} "s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/Makefile
+
+do-build:
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} .depend)
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS})
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/barry/distinfo b/ports-mgmt/barry/distinfo
new file mode 100644
index 000000000000..b5a08f9fc1ef
--- /dev/null
+++ b/ports-mgmt/barry/distinfo
@@ -0,0 +1 @@
+MD5 (barry-0.5.3.tar.bz2) = 9996a2d1861b94b9bf99e046712c605d
diff --git a/ports-mgmt/barry/files/patch-Makefile b/ports-mgmt/barry/files/patch-Makefile
new file mode 100644
index 000000000000..3dc940ed90a4
--- /dev/null
+++ b/ports-mgmt/barry/files/patch-Makefile
@@ -0,0 +1,33 @@
+--- Makefile Mon Aug 5 17:30:26 2002
++++ Makefile.new Fri Sep 20 20:11:35 2002
+@@ -1,6 +1,7 @@
+ CXX=g++
+ QTDIR?=/usr/X11R6
+ KDEDIR?=/usr/local
++PREFIX?=/usr/local
+ MOC=$(QTDIR)/bin/moc
+ INCLUDES=-I$(QTDIR)/include -I$(KDEDIR)/include
+ LIBRARIES=-L$(QTDIR)/lib -L$(KDEDIR)/lib
+@@ -39,14 +40,14 @@
+
+ install: barry
+ echo Installing barry $(VERSION)...
+- install -o root -g wheel -p -s -m 755 barry $(KDEDIR)/bin
+- mkdir -p $(KDEDIR)/share/apps/barry
+- install -o root -g wheel -p -m 444 barryui.rc $(KDEDIR)/share/apps/barry
+- install -o root -g wheel -p -m 444 barry.desktop $(KDEDIR)/share/applnk/Utilities
+- install -o root -g wheel -p -m 444 hi16-app-barry.png $(KDEDIR)/share/icons/hicolor/16x16/apps/barry.png
+- install -o root -g wheel -p -m 444 hi32-app-barry.png $(KDEDIR)/share/icons/hicolor/32x32/apps/barry.png
+- install -o root -g wheel -p -m 444 hi48-app-barry.png $(KDEDIR)/share/icons/hicolor/48x48/apps/barry.png
+- install -o root -g wheel -p -m 444 eventsrc $(KDEDIR)/share/apps/barry
++ install -o root -g wheel -p -s -m 755 barry $(PREFIX)/bin
++ mkdir -p $(PREFIX)/share/apps/barry
++ install -o root -g wheel -p -m 444 barryui.rc $(PREFIX)/share/apps/barry
++ install -o root -g wheel -p -m 444 barry.desktop $(PREFIX)/share/applnk/Utilities
++ install -o root -g wheel -p -m 444 hi16-app-barry.png $(PREFIX)/share/icons/hicolor/16x16/apps/barry.png
++ install -o root -g wheel -p -m 444 hi32-app-barry.png $(PREFIX)/share/icons/hicolor/32x32/apps/barry.png
++ install -o root -g wheel -p -m 444 hi48-app-barry.png $(PREFIX)/share/icons/hicolor/48x48/apps/barry.png
++ install -o root -g wheel -p -m 444 eventsrc $(PREFIX)/share/apps/barry
+ cd po/; $(MAKE) $(.TARGET)
+ cd splashdata/; $(MAKE) $(.TARGET)
+
diff --git a/ports-mgmt/barry/pkg-comment b/ports-mgmt/barry/pkg-comment
new file mode 100644
index 000000000000..c9e483220396
--- /dev/null
+++ b/ports-mgmt/barry/pkg-comment
@@ -0,0 +1 @@
+A nice KDE frontend to the ports system
diff --git a/ports-mgmt/barry/pkg-descr b/ports-mgmt/barry/pkg-descr
new file mode 100644
index 000000000000..f47fb4748fb8
--- /dev/null
+++ b/ports-mgmt/barry/pkg-descr
@@ -0,0 +1 @@
+A nice KDE frontend to the ports system.
diff --git a/ports-mgmt/barry/pkg-plist b/ports-mgmt/barry/pkg-plist
new file mode 100644
index 000000000000..af19574f0866
--- /dev/null
+++ b/ports-mgmt/barry/pkg-plist
@@ -0,0 +1,23 @@
+bin/barry
+share/applnk/Utilities/barry.desktop
+share/apps/barry/background.png
+share/apps/barry/barryui.rc
+share/apps/barry/bgtable.png
+share/apps/barry/eventsrc
+share/apps/barry/kdelogo2.png
+share/apps/barry/khelpcenter.png
+share/apps/barry/konq.css
+share/apps/barry/lines.png
+share/apps/barry/lines2.png
+share/apps/barry/pointers.png
+share/apps/barry/shadow1.png
+share/apps/barry/splashscreen.html
+share/icons/hicolor/16x16/apps/barry.png
+share/icons/hicolor/32x32/apps/barry.png
+share/icons/hicolor/48x48/apps/barry.png
+share/locale/de/LC_MESSAGES/barry.mo
+share/locale/es/LC_MESSAGES/barry.mo
+share/locale/ko/LC_MESSAGES/barry.mo
+share/locale/nl/LC_MESSAGES/barry.mo
+share/locale/sv/LC_MESSAGES/barry.mo
+@dirrm share/apps/barry