aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/fastest_sites
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2011-03-10 14:42:15 +0000
committerWesley Shields <wxs@FreeBSD.org>2011-03-10 14:42:15 +0000
commit4102f10ac7e544b780e26bdbc1cc3d78dee85fcb (patch)
treed896c894a4cf17ddeb0b7492194a0d0ca1d434f0 /ports-mgmt/fastest_sites
parentfe5eb7fd476febbe69f68e3d08ca8fbaf25980f7 (diff)
downloadports-4102f10ac7e544b780e26bdbc1cc3d78dee85fcb.tar.gz
ports-4102f10ac7e544b780e26bdbc1cc3d78dee85fcb.zip
Add a patch to fix an issue under python 2.7.
While here, drop MD5 from distinfo. Discussed at: http://forums.freebsd.org/showthread.php?p=126331#post126331 Submitted by: avilla@, jhelfman@e-e.com
Notes
Notes: svn path=/head/; revision=270608
Diffstat (limited to 'ports-mgmt/fastest_sites')
-rw-r--r--ports-mgmt/fastest_sites/Makefile1
-rw-r--r--ports-mgmt/fastest_sites/distinfo1
-rw-r--r--ports-mgmt/fastest_sites/files/patch-fastest_sites-20081104.py12
3 files changed, 13 insertions, 1 deletions
diff --git a/ports-mgmt/fastest_sites/Makefile b/ports-mgmt/fastest_sites/Makefile
index 5c717d3a28fd..f686eb599bf0 100644
--- a/ports-mgmt/fastest_sites/Makefile
+++ b/ports-mgmt/fastest_sites/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fastest_sites
PORTVERSION= 20081104
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= http://www.semicomplete.com/files/fastest_sites/
DISTNAME= ${PORTNAME}-${PORTVERSION}.py
diff --git a/ports-mgmt/fastest_sites/distinfo b/ports-mgmt/fastest_sites/distinfo
index 68984c6f5075..e39da3a3db06 100644
--- a/ports-mgmt/fastest_sites/distinfo
+++ b/ports-mgmt/fastest_sites/distinfo
@@ -1,3 +1,2 @@
-MD5 (fastest_sites-20081104.py) = 040b582c974ece826297e97bef15ead2
SHA256 (fastest_sites-20081104.py) = 7759b8f048dfcda0107fbd3e072fcf1c039136774b7f0835ccdc97fb93dbe74b
SIZE (fastest_sites-20081104.py) = 5008
diff --git a/ports-mgmt/fastest_sites/files/patch-fastest_sites-20081104.py b/ports-mgmt/fastest_sites/files/patch-fastest_sites-20081104.py
new file mode 100644
index 000000000000..ce6957740c41
--- /dev/null
+++ b/ports-mgmt/fastest_sites/files/patch-fastest_sites-20081104.py
@@ -0,0 +1,12 @@
+--- ./fastest_sites-20081104.py.orig 2011-03-09 21:42:34.682812592 -0500
++++ ./fastest_sites-20081104.py 2011-03-09 21:42:44.067806352 -0500
+@@ -66,6 +66,9 @@
+ self._host = host
+ self._port = AsyncConnect.schemes[scheme]
+
++ def handle_error(self):
++ pass
++
+ def handle_connect(self):
+ pass
+