aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/fbsdmon/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-02-04 00:56:53 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-02-04 00:56:53 +0000
commit34a815e881d176d2d183aa5fe5600bd9620dfa43 (patch)
treea0ed754d6ce84ece8e2b3a8c66dbf5df56b91c5f /ports-mgmt/fbsdmon/Makefile
parent4bab1e932ad2b3e1036f737977b285ba47632a18 (diff)
downloadports-34a815e881d176d2d183aa5fe5600bd9620dfa43.tar.gz
ports-34a815e881d176d2d183aa5fe5600bd9620dfa43.zip
Add new port: fbsdmon
Submit system and ports statistics to fbsdmon.org. Statistics can be sent from command line, from rc script or from periodic script. WWW: http://fbsdmon.org/ PR: ports/164608 Submitted by: Grzegorz Blach <magik at roorback.net> Approved by: rene (mentor)
Notes
Notes: svn path=/head/; revision=290366
Diffstat (limited to 'ports-mgmt/fbsdmon/Makefile')
-rw-r--r--ports-mgmt/fbsdmon/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/ports-mgmt/fbsdmon/Makefile b/ports-mgmt/fbsdmon/Makefile
new file mode 100644
index 000000000000..a983b4c1abba
--- /dev/null
+++ b/ports-mgmt/fbsdmon/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: fbsdmon
+# Date created: 21 January 2012
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fbsdmon
+PORTVERSION= 0.90
+CATEGORIES= ports-mgmt sysutils
+MASTER_SITES= http://files.roorback.net/
+
+MAINTAINER= magik@roorback.net
+COMMENT= Sumbit system and ports statistics to fbsdmon.org
+
+LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
+ jansson.6:${PORTSDIR}/devel/jansson \
+
+SUB_FILES= 600.fbsdmon pkg-message
+USE_RC_SUBR= fbsdmon
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/fbsdmon ${PREFIX}/sbin
+ ${MKDIR} /var/db/fbsdmon
+ ${MKDIR} ${PREFIX}/etc/periodic/weekly
+ ${INSTALL_SCRIPT} ${WRKDIR}/600.fbsdmon ${PREFIX}/etc/periodic/weekly
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>