aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/genplist/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-20 12:40:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-20 12:40:28 +0000
commitdb02ec76cee6894e5c856e29f1a5a49f4d127ddc (patch)
tree477f9fc8af0c46361a58c157788d2f092192fc6a /ports-mgmt/genplist/Makefile
parent43e4f23ceac49d6cd57ec50425782ca9365b577d (diff)
downloadports-db02ec76cee6894e5c856e29f1a5a49f4d127ddc.tar.gz
ports-db02ec76cee6894e5c856e29f1a5a49f4d127ddc.zip
Genplist automatically creates a static plist for a port by installing it
into a temporary directory, and then examining the directory tree. The process is based on the instructions for plist generation in the FreeBSD Porter's Handbook. WWW: http://www.neuro.mcw.edu/~bacon/FreeBSD_MRI PR: ports/111892 Submitted by: Jason Bacon bacon at smithers.neuro.mcw.edu Sponsord by: addport
Notes
Notes: svn path=/head/; revision=190440
Diffstat (limited to 'ports-mgmt/genplist/Makefile')
-rw-r--r--ports-mgmt/genplist/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/ports-mgmt/genplist/Makefile b/ports-mgmt/genplist/Makefile
new file mode 100644
index 000000000000..6d95dc5ab72a
--- /dev/null
+++ b/ports-mgmt/genplist/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: genplist
+# Date created: 2007-04-19
+# Whom: Jason Bacon bacon@smithers.neuro.mcw.edu
+#
+# $FreeBSD$
+#
+
+PORTNAME= genplist
+PORTVERSION= 0.1
+CATEGORIES= ports-mgmt
+MASTER_SITES= http://www.neuro.mcw.edu/~bacon/Ports/distfiles/
+
+MAINTAINER= bacon@smithers.neuro.mcw.edu
+COMMENT= Generates a static plist for a port
+
+NO_BUILD= yes
+
+PLIST_FILES= bin/genplist
+
+MAN1= genplist.1
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/genplist ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/genplist.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>