aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2019-05-31 09:54:49 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2019-05-31 09:54:49 +0000
commitb49bc9fc24aaf88da80f3d99a53af3f773f613c4 (patch)
tree617665c22ba7795a680865287e4e5c4eb61c895a /ports-mgmt/pkg
parent938674217f0c2b1477b1b6732cbf000a030d1bd6 (diff)
downloadports-b49bc9fc24aaf88da80f3d99a53af3f773f613c4.tar.gz
ports-b49bc9fc24aaf88da80f3d99a53af3f773f613c4.zip
Update to 1.11
Improvements: * better ABI name on linux * lots of changes in internal API to use fd when possible * 410.pkg-audit now uses anticongestion on freebsd 12+ * completion improvements * add an extra line when printing pkg-messages to improve readability * add %q to pkg_printf(3) and pkg-query(8) to print altabi * make pkg version -r imply -R * New build system based on autosetup * pkg is now a semi static binary * Add 3 new aliases: - rall-depends: showing depenencies of a non installed package - rcomment: showing only the comment of a non installed package - rdesc: showing only the description of a non installed package * close stdin when running scripts * Tons of bug fixes Removal: * removed option: pkg repo -L * removed script: pkg2ng
Notes
Notes: svn path=/head/; revision=503131
Diffstat (limited to 'ports-mgmt/pkg')
-rw-r--r--ports-mgmt/pkg/Makefile24
-rw-r--r--ports-mgmt/pkg/distinfo6
-rw-r--r--ports-mgmt/pkg/files/patch-166328
-rw-r--r--ports-mgmt/pkg/files/patch-170213
-rw-r--r--ports-mgmt/pkg/files/patch-60666a116
-rw-r--r--ports-mgmt/pkg/files/patch-javavmwrapper34
-rw-r--r--ports-mgmt/pkg/files/patch-src_Makefile.in11
-rw-r--r--ports-mgmt/pkg/pkg-plist3
8 files changed, 13 insertions, 122 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index 9afa38203aac..40012325b9a6 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -1,27 +1,27 @@
# $FreeBSD$
PORTNAME= pkg
-DISTVERSION= 1.10.5
-PORTREVISION= 5
+DISTVERSION= 1.11.0
_PKG_VERSION= ${DISTVERSION}
CATEGORIES= ports-mgmt
-MASTER_SITES= \
- http://files.etoilebsd.net/${PORTNAME}/ \
- LOCAL/portmgr \
- http://mirror.shatow.net/freebsd/${PORTNAME}/ \
+#MASTER_SITES= \
+# http://files.etoilebsd.net/${PORTNAME}/ \
+# LOCAL/portmgr \
+# http://mirror.shatow.net/freebsd/${PORTNAME}/ \
MAINTAINER= pkg@FreeBSD.org
COMMENT= Package manager
LICENSE= BSD2CLAUSE
+USE_GITHUB= yes
+GH_ACCOUNT= freebsd
+
USE_LDCONFIG= yes
-USES= libtool tar:xz
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-maintainer-mode
-INSTALL_TARGET= install-strip
+HAS_CONFIGURE= yes
PORTDOCS= NEWS
PORTSCOUT= ignore:1
+CONFIGURE_ARGS= --mandir=${PREFIX}/man
# Use a submake as 'deinstall install' needs to reevaluate PKG_CMD
# so that pkg-static is used from the wrkdir
@@ -80,10 +80,6 @@ PKG_DEPENDS=
PKG_BIN= ${WRKSRC}/src/pkg-static
.endif
-post-install:
- @${MV} ${STAGEDIR}${PREFIX}/lib/libpkg_static.a \
- ${STAGEDIR}${PREFIX}/lib/libpkg.a
-
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/NEWS ${STAGEDIR}${DOCSDIR}/NEWS
diff --git a/ports-mgmt/pkg/distinfo b/ports-mgmt/pkg/distinfo
index 1edacb3f4817..21908d603f7a 100644
--- a/ports-mgmt/pkg/distinfo
+++ b/ports-mgmt/pkg/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1518650836
-SHA256 (pkg-1.10.5.tar.xz) = c2e5ff8505a7f859fd579dc3974822575de8178868fd2497cec0ec18f06da041
-SIZE (pkg-1.10.5.tar.xz) = 2216560
+TIMESTAMP = 1559295992
+SHA256 (freebsd-pkg-1.11.0_GH0.tar.gz) = 0b85372a4c820eb639d0fb95e6225f90a9f817cb8bed6bc5b0b2eccaeafdb32f
+SIZE (freebsd-pkg-1.11.0_GH0.tar.gz) = 3560696
diff --git a/ports-mgmt/pkg/files/patch-1663 b/ports-mgmt/pkg/files/patch-1663
deleted file mode 100644
index e2c9c6a00cb4..000000000000
--- a/ports-mgmt/pkg/files/patch-1663
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/libpkg/pkg_jobs_conflicts.c b/libpkg/pkg_jobs_conflicts.c
-index 886e100c..141c69f9 100644
---- libpkg/pkg_jobs_conflicts.c.orig
-+++ libpkg/pkg_jobs_conflicts.c
-@@ -477,7 +477,8 @@ pkg_conflicts_check_chain_conflict(struct pkg_job_universe_item *it,
- it->pkg->uid);
-
- if (p != NULL) {
-- pkg_jobs_universe_process_item(j->universe, p, &cun);
-+ if (pkg_jobs_universe_process_item(j->universe, p, &cun))
-+ continue;
- assert(cun != NULL);
- pkg_conflicts_register_chain(j, it, cun, fcur->path);
- }
-diff --git a/libpkg/pkg_jobs_universe.c b/libpkg/pkg_jobs_universe.c
-index 1a5a2c72..725825ac 100644
---- libpkg/pkg_jobs_universe.c.orig
-+++ libpkg/pkg_jobs_universe.c
-@@ -570,6 +570,9 @@ pkg_jobs_universe_process_item(struct pkg_jobs_universe *universe, struct pkg *p
- * flag that means that we have already tried to check our universe
- */
- rc = pkg_jobs_universe_add_pkg(universe, pkg, false, &found);
-+ if (rc == EPKG_CONFLICT)
-+ return (rc);
-+
- if (result)
- *result = found;
-
diff --git a/ports-mgmt/pkg/files/patch-1702 b/ports-mgmt/pkg/files/patch-1702
deleted file mode 100644
index c6f52daa58e6..000000000000
--- a/ports-mgmt/pkg/files/patch-1702
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/libpkg/pkg.c b/libpkg/pkg.c
-index 0c472b39..b4ee9ec3 100644
---- libpkg/pkg.c
-+++ libpkg/pkg.c
-@@ -1668,7 +1668,7 @@ pkg_is_config_file(struct pkg *p, const char *path,
- return (false);
-
- kh_find(pkg_config_files, p->config_files, path, *cfile);
-- if (cfile == NULL) {
-+ if (*cfile == NULL) {
- *file = NULL;
- return (false);
- }
diff --git a/ports-mgmt/pkg/files/patch-60666a1 b/ports-mgmt/pkg/files/patch-60666a1
deleted file mode 100644
index 73527ddd2403..000000000000
--- a/ports-mgmt/pkg/files/patch-60666a1
+++ /dev/null
@@ -1,16 +0,0 @@
---- libpkg/pkg_ports.c
-+++ libpkg/pkg_ports.c
-@@ -353,13 +353,6 @@ meta_file(struct plist *p, char *line, struct file_attr *a, bool is_config)
- pkg_addconfig_file(p->pkg, path, content);
- free(content);
- }
-- } else {
-- if (is_config) {
-- pkg_emit_error("Plist error, @config %s: not a regular "
-- "file", line);
-- free(buf);
-- return (EPKG_FATAL);
-- }
- }
-
- if (S_ISDIR(st.st_mode) &&
diff --git a/ports-mgmt/pkg/files/patch-javavmwrapper b/ports-mgmt/pkg/files/patch-javavmwrapper
deleted file mode 100644
index 1d3c37c0c041..000000000000
--- a/ports-mgmt/pkg/files/patch-javavmwrapper
+++ /dev/null
@@ -1,34 +0,0 @@
-diff --git libpkg/pkg_add.c libpkg/pkg_add.c
-index 87fb248..778336c 100644
---- libpkg/pkg_add.c
-+++ libpkg/pkg_add.c
-@@ -859,14 +859,21 @@ pkg_add_cleanup_old(struct pkgdb *db, struct pkg *old, struct pkg *new, int flag
- * Execute pre deinstall scripts
- */
- if ((flags & PKG_ADD_NOSCRIPT) == 0) {
-- if ((flags & PKG_ADD_USE_UPGRADE_SCRIPTS) == PKG_ADD_USE_UPGRADE_SCRIPTS)
-- ret = pkg_script_run(old, PKG_SCRIPT_PRE_UPGRADE);
-- else
-- ret = pkg_script_run(old, PKG_SCRIPT_PRE_DEINSTALL);
-- if (ret != EPKG_OK && pkg_object_bool(pkg_config_get("DEVELOPER_MODE")))
-- return (ret);
-- else
-- ret = EPKG_OK;
-+ bool buggydeinstall = false;
-+ if (strcmp(old->name, "javavmwrapper") == 0 &&
-+ (strcmp(old->version, "2.5") == 0 ||
-+ strcmp(old->version, "2.5_1") == 0))
-+ buggydeinstall = true;
-+ if (!buggydeinstall) {
-+ if ((flags & PKG_ADD_USE_UPGRADE_SCRIPTS) == PKG_ADD_USE_UPGRADE_SCRIPTS)
-+ ret = pkg_script_run(old, PKG_SCRIPT_PRE_UPGRADE);
-+ else
-+ ret = pkg_script_run(old, PKG_SCRIPT_PRE_DEINSTALL);
-+ if (ret != EPKG_OK && pkg_object_bool(pkg_config_get("DEVELOPER_MODE")))
-+ return (ret);
-+ else
-+ ret = EPKG_OK;
-+ }
- }
-
- /* Now remove files that no longer exist in the new package */
diff --git a/ports-mgmt/pkg/files/patch-src_Makefile.in b/ports-mgmt/pkg/files/patch-src_Makefile.in
deleted file mode 100644
index c92666b8d983..000000000000
--- a/ports-mgmt/pkg/files/patch-src_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig 2018-02-14 23:08:02 UTC
-+++ src/Makefile.in
-@@ -619,7 +619,7 @@ pkg_static_LDADD = @OS_LDFLAGS@ $(pkg_OBJECTS) \
- $(top_builddir)/libpkg/libpkg_static.la \
- $(top_builddir)/compat/libbsd_compat.la @LIBJAIL_LIB@ \
- @LDNS_LIBS@ @OS_LIBS@ -larchive -lz -lutil -lbz2 -llzma -lssl \
-- -lcrypto -lm $(am__append_2) $(am__append_3) $(am__append_4)
-+ -lpthread -lcrypto -lm $(am__append_2) $(am__append_3) $(am__append_4)
- DYNPROG = pkg
- @BUILD_STATIC_TRUE@pkg_static_LDFLAGS = -all-static
- dist_sysconf_DATA = pkg.conf.sample
diff --git a/ports-mgmt/pkg/pkg-plist b/ports-mgmt/pkg/pkg-plist
index 34e2566432a5..fc362bb6e5df 100644
--- a/ports-mgmt/pkg/pkg-plist
+++ b/ports-mgmt/pkg/pkg-plist
@@ -9,7 +9,6 @@ include/pkg.h
lib/libpkg.a
lib/libpkg.so
lib/libpkg.so.4
-lib/libpkg.so.4.0.0
libdata/pkgconfig/pkg.pc
man/man3/pkg_printf.3.gz
man/man3/pkg_repos.3.gz
@@ -24,7 +23,6 @@ man/man8/pkg-backup.8.gz
man/man8/pkg-check.8.gz
man/man8/pkg-clean.8.gz
man/man8/pkg-config.8.gz
-man/man8/pkg-convert.8.gz
man/man8/pkg-create.8.gz
man/man8/pkg-delete.8.gz
man/man8/pkg-fetch.8.gz
@@ -52,5 +50,4 @@ man/man8/pkg-which.8.gz
man/man8/pkg.8.gz
sbin/pkg
sbin/pkg-static
-sbin/pkg2ng
share/zsh/site-functions/_pkg