aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portal
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-12-09 22:53:34 +0000
committerJohn Marino <marino@FreeBSD.org>2016-12-09 22:53:34 +0000
commitd2f03589b6dd3a73bd319b41d79f4962c5144bfb (patch)
tree624dd96a49e4dd5311ec8f5d96957e1101c30626 /ports-mgmt/portal
parentcecaf8dd5ea62de5e0b5fee367cb56a20ed4cb7a (diff)
downloadports-d2f03589b6dd3a73bd319b41d79f4962c5144bfb.tar.gz
ports-d2f03589b6dd3a73bd319b41d79f4962c5144bfb.zip
ports-mgmt/portal: Support ports ncurses and honor FLAGS
Approved by: general and ncurses blankets
Notes
Notes: svn path=/head/; revision=428259
Diffstat (limited to 'ports-mgmt/portal')
-rw-r--r--ports-mgmt/portal/Makefile2
-rw-r--r--ports-mgmt/portal/files/patch-Makefile11
2 files changed, 13 insertions, 0 deletions
diff --git a/ports-mgmt/portal/Makefile b/ports-mgmt/portal/Makefile
index 6d20dc9d6610..07cb336c4685 100644
--- a/ports-mgmt/portal/Makefile
+++ b/ports-mgmt/portal/Makefile
@@ -19,6 +19,8 @@ USE_GITHUB= yes
GH_ACCOUNT= culot
USES= ncurses compiler:c++11-lib
+CFLAGS+= -I${NCURSESINC}
+LDFLAGS+= -L${NCURSESLIB}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/ports-mgmt/portal/files/patch-Makefile b/ports-mgmt/portal/files/patch-Makefile
new file mode 100644
index 000000000000..cfe6972e7b24
--- /dev/null
+++ b/ports-mgmt/portal/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2016-12-03 18:56:16 UTC
++++ Makefile
+@@ -24,7 +24,7 @@ DEFS= -DVERSION=${VERSION}
+ all: ${PROG}
+
+ ${PROG}: ${OBJS}
+- ${CC} ${CXXFLAGS} -o ${.TARGET} ${OBJS} ${LDADD}
++ ${CC} ${CXXFLAGS} -o ${.TARGET} ${OBJS} ${LDFLAGS} ${LDADD}
+
+ .cc.o:
+ ${CC} ${CXXFLAGS} ${CPPFLAGS} ${DEFS} -c ${.IMPSRC}