aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/porteasy
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2004-08-25 09:45:22 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2004-08-25 09:45:22 +0000
commit59ec3b081b41355d97d7bbc9bda2286dc20d5a92 (patch)
tree5806e2a71e271da066c0b5865fd44583cf356962 /ports-mgmt/porteasy
parent01e6779790ff4aa9198fe0abbbeea5950a379fce (diff)
downloadports-59ec3b081b41355d97d7bbc9bda2286dc20d5a92.tar.gz
ports-59ec3b081b41355d97d7bbc9bda2286dc20d5a92.zip
Watch out for undefined values when resolving port origins. This makes
-I / -s work properly when some of the installed ports have since been deleted from the ports tree. Submitted by: Thomas-Martin Seck <tmseck@netcologne.de>
Notes
Notes: svn path=/head/; revision=117238
Diffstat (limited to 'ports-mgmt/porteasy')
-rw-r--r--ports-mgmt/porteasy/Makefile2
-rw-r--r--ports-mgmt/porteasy/src/porteasy.pl8
2 files changed, 6 insertions, 4 deletions
diff --git a/ports-mgmt/porteasy/Makefile b/ports-mgmt/porteasy/Makefile
index f51b03d0e15f..80e100aff989 100644
--- a/ports-mgmt/porteasy/Makefile
+++ b/ports-mgmt/porteasy/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= porteasy
-PORTVERSION= 2.7.16
+PORTVERSION= 2.7.17
CATEGORIES= misc
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/porteasy/src/porteasy.pl b/ports-mgmt/porteasy/src/porteasy.pl
index ecbb90528428..388c4b9f3dd7 100644
--- a/ports-mgmt/porteasy/src/porteasy.pl
+++ b/ports-mgmt/porteasy/src/porteasy.pl
@@ -33,7 +33,7 @@ use strict;
use Fcntl;
use Getopt::Long;
-my $VERSION = "2.7.16";
+my $VERSION = "2.7.17";
my $COPYRIGHT = "Copyright (c) 2000-2004 Dag-Erling Smørgrav. " .
"All rights reserved.";
@@ -446,7 +446,7 @@ sub find_moved($) {
read_moved();
}
while (exists($moved{$port}) && $moved{$port}->[1] gt $date) {
- if (!defined($moved{$port}->[0])) {
+ if (!$moved{$port}->[0]) {
info("$port was removed" .
" on $moved{$port}->[1]: $moved{$port}->[2]");
return undef;
@@ -478,7 +478,9 @@ sub add_port($$) {
} else {
$realport = find_port($port);
}
- $realport = find_moved($realport);
+ if ($realport) {
+ $realport = find_moved($realport);
+ }
}
if (!$realport) {
return 1;