aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portmk
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2006-01-23 04:29:32 +0000
committerMark Linimon <linimon@FreeBSD.org>2006-01-23 04:29:32 +0000
commit2fe508315b9fa972d174c3de61bc5f1910183dae (patch)
treed7aee8451d04ea04d02c414e339cdd03552ab3fc /ports-mgmt/portmk
parent00800393a02c35d1d9903941f9f26e5b2a154e99 (diff)
downloadports-2fe508315b9fa972d174c3de61bc5f1910183dae.tar.gz
ports-2fe508315b9fa972d174c3de61bc5f1910183dae.zip
Update to the latest patches running on the cluster.
Notes
Notes: svn path=/head/; revision=154211
Diffstat (limited to 'ports-mgmt/portmk')
-rw-r--r--ports-mgmt/portmk/Mk/bsd.port.mk23
1 files changed, 18 insertions, 5 deletions
diff --git a/ports-mgmt/portmk/Mk/bsd.port.mk b/ports-mgmt/portmk/Mk/bsd.port.mk
index cb1ec7438b39..68e644936cfe 100644
--- a/ports-mgmt/portmk/Mk/bsd.port.mk
+++ b/ports-mgmt/portmk/Mk/bsd.port.mk
@@ -120,6 +120,10 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# ${MASTER_SITE_OVERRIDE})
# EXTRACT_ONLY - If set, a subset of ${DISTFILES} you want to
# actually extract.
+# ALWAYS_KEEP_DISTFILES - If set, the package building cluster will save the distfiles along
+# with the packages. This may be required to comply with some
+# licenses, e.g. GPL in some cases.
+# Default: not set.
#
# (NOTE: by convention, the MAINTAINER entry (see above) should go here.)
#
@@ -1561,10 +1565,6 @@ CONFIGURE_ENV+= MAKE=${GMAKE}
MAKE_ENV+= CC="${CC}" CXX="${CXX}"
.endif
-.if defined(USE_DOS2UNIX)
-USE_REINPLACE= yes
-.endif
-
.if defined(USE_GCC)
.if exists(${DEVELPORTSDIR}/Mk/bsd.gcc.mk)
.include "${DEVELPORTSDIR}/Mk/bsd.gcc.mk"
@@ -1912,11 +1912,14 @@ RUN_DEPENDS+= ${PERL5}:${PORTSDIR}/lang/${PERL_PORT}
.endif
.endif
+# XXX
+#.if defined(USE_AUTOTOOLS)
.if exists(${DEVELPORTSDIR}/Mk/bsd.autotools.mk)
.include "${DEVELPORTSDIR}/Mk/bsd.autotools.mk"
.else
.include "${PORTSDIR}/Mk/bsd.autotools.mk"
.endif
+#.endif
.if defined(WANT_GNOME) || defined(USE_GNOME) || defined(USE_GTK)
.if exists(${DEVELPORTSDIR}/Mk/bsd.gnome.mk)
@@ -3345,7 +3348,7 @@ patch-dos2unix:
.endfor
.endif
.else
- ${DO_NADA}
+ @${DO_NADA}
.endif
.endif
@@ -4547,6 +4550,16 @@ ${deptype:L}-depends:
${ECHO_MSG} "===> ${PKGNAME} depends on package: $$prog - not found"; \
notfound=1; \
fi; \
+ if [ $$notfound != 0 ]; then \
+ inverse_dep=`${ECHO_CMD} $$prog | ${SED} \
+ -e 's/<=/=gt=/; s/</=ge=/; s/>=/=lt=/; s/>/=le=/' \
+ -e 's/=gt=/>/; s/=ge=/>=/; s/=lt=/</; s/=le=/<=/'`; \
+ pkg_info=`${PKG_INFO} -E "$$inverse_dep" || ${TRUE}`; \
+ if [ "$$pkg_info" != "" ]; then \
+ ${ECHO_MSG} "===> Found $$pkg_info, but you need to upgrade to $$prog."; \
+ exit 1; \
+ fi; \
+ fi; \
elif ${WHICH} "$$prog" > /dev/null 2>&1 ; then \
${ECHO_MSG} "===> ${PKGNAME} depends on executable: $$prog - found"; \
if [ ${_DEPEND_ALWAYS} = 1 ]; then \