aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portsnap/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-04-09 16:34:31 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-04-09 16:58:31 +0000
commit0e9127b12dfbaf987bfcaa16f22dcfa5a42543ae (patch)
treed2286120d423e169b561c3109173cece183a9010 /ports-mgmt/portsnap/Makefile
parent19c5ede3df809ec3e0909b4169f63c528a55e2a3 (diff)
downloadports-0e9127b12dfbaf987bfcaa16f22dcfa5a42543ae.tar.gz
ports-0e9127b12dfbaf987bfcaa16f22dcfa5a42543ae.zip
ports-mgmt/portsnap: Resurrect
portsnap will be removed from the base from 14.0-RELEASE onwards. To facilitate usage of portsnap from 14.0-RELEASE onwards extract portsnap from base and create seperate port. Portsnap is a system for securely updating the ports tree by distributing signed compressed snapshots. This is the client half of that system; it downloads compressed snapshots into /usr/local/portsnap ("portsnap fetch") and uses those to extract a ports tree into /usr/ports ("portsnap extract") or update an existing tree ("portsnap update"). In addition to operating entirely over HTTP, portsnap can use under a tenth of the bandwidth required by CVSup if a copy of the ports tree is being updated every few days. Approved by: portmgr
Diffstat (limited to 'ports-mgmt/portsnap/Makefile')
-rw-r--r--ports-mgmt/portsnap/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/ports-mgmt/portsnap/Makefile b/ports-mgmt/portsnap/Makefile
new file mode 100644
index 000000000000..965acd484a0c
--- /dev/null
+++ b/ports-mgmt/portsnap/Makefile
@@ -0,0 +1,41 @@
+PORTNAME= portsnap
+PORTVERSION= 1.1
+PORTREVISION= 1
+CATEGORIES= ports-mgmt net
+MASTER_SITES= http://www.daemonology.net/portsnap/
+
+MAINTAINER= bofh@FreBSD.org
+COMMENT= Provides secure snapshots of the ports directory
+WWW= http://www.daemonology.net/portsnap/
+
+LICENSE= BSD2CLAUSE
+
+SUB_FILES= pkg-message
+
+PLIST_FILES= "@sample etc/portsnap.conf.sample" \
+ libexec/make_index \
+ sbin/portsnap \
+ man/man5/portsnap.conf.5.gz \
+ man/man8/portsnap.8.gz
+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1500000
+IGNORE= portsnap is in base systems but will be removed from 14.0-RELEASE
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" \
+ ${WRKSRC}/portsnap \
+ ${WRKSRC}/portsnap.conf.5 \
+ ${WRKSRC}/portsnap.8
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/portsnap ${STAGEDIR}/${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/make_index ${STAGEDIR}/${PREFIX}/libexec
+ ${INSTALL_MAN} ${WRKSRC}/portsnap.conf.5 ${STAGEDIR}/${PREFIX}/man/man5/
+ ${INSTALL_MAN} ${WRKSRC}/portsnap.8 ${STAGEDIR}/${PREFIX}/man/man8/
+ ${INSTALL_DATA} ${WRKSRC}/portsnap.conf \
+ ${STAGEDIR}/${PREFIX}/etc/portsnap.conf.sample
+
+.include <bsd.port.post.mk>