aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/tinderbox
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2014-03-25 20:49:20 +0000
committerChris Rees <crees@FreeBSD.org>2014-03-25 20:49:20 +0000
commitf8d56b3f61f92f9aecf84ec626065ae1bae586bf (patch)
tree60ba4b6367a93c4b3fb94e04e21294c4522fbcde /ports-mgmt/tinderbox
parent7e931f19997b0d848ba5c891f1846ea6b30083a8 (diff)
downloadports-f8d56b3f61f92f9aecf84ec626065ae1bae586bf.tar.gz
ports-f8d56b3f61f92f9aecf84ec626065ae1bae586bf.zip
Fix enterBuild-- also fixed upstream
PR: ports/184943 Submitted by: Anes Mukhametov <anes@anes.su> Allow masking of PHP use and markup logs PR: ports/167601 Submitted by: Jarrod Sayers <jarrod@downtools.com.au>
Notes
Notes: svn path=/head/; revision=349193
Diffstat (limited to 'ports-mgmt/tinderbox')
-rw-r--r--ports-mgmt/tinderbox/Makefile17
-rw-r--r--ports-mgmt/tinderbox/files/patch-enterbuild17
2 files changed, 33 insertions, 1 deletions
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index cccd3c4b62e4..ed31d5c1cf0f 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tinderbox
PORTVERSION= 4.1.0
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= http://tinderbox.marcuscom.com/ \
http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
@@ -21,7 +22,7 @@ OPTIONS_MULTI_DB= PGSQL MYSQL SQLITE
OPTIONS_RADIO= WEB
OPTIONS_RADIO_WEB= APACHE HIAWATHA LIGHTTPD NGINX
-OPTIONS_DEFINE= CHECK_ROOT EMAILS LSOF LOG_COMPRESS
+OPTIONS_DEFINE= CHECK_ROOT EMAILS LSOF LOG_COMPRESS HIDE_PHP HIDE_MARKUP
CHECK_ROOT_DESC= Check if ./tc is run by uid 0
EMAILS_DESC= Support for build failure/completion emails
@@ -29,6 +30,8 @@ LSOF_DESC= For killMountProcesses() when using nullfs
LOG_COMPRESS_DESC= Support bzip log compression
HIAWATHA_DESC= Hiawatha server
NGINX_DESC= Nginx server
+HIDE_PHP_DESC= Hide index.php in webui templates
+HIDE_MARKUP_DESC= Hide display_markup_log action
OPTIONS_DEFAULT= MYSQL APACHE CHECK_ROOT EMAILS LSOF \
LOG_COMPRESS
@@ -101,6 +104,18 @@ post-patch:
${REINPLACE_CMD} -e 's/^if \[ `id -u` != 0 \]; then/if false; then/' \
${WRKSRC}/tc
.endif
+.if defined(WEBUI)
+. if ${PORT_OPTIONS:MHIDE_PHP}
+ @${REINPLACE_CMD} -e 's#index.php\?#\?#g;s#index.php#\?#g' \
+ ${WRKSRC}/webui/templates/*/*.tpl
+. endif
+. if ${PORT_OPTIONS:MHIDE_MARKUP}
+ @${REINPLACE_CMD} -e 's#<a href="[^"]*">markup</a>#markup#g' \
+ -e 's#>markup_log.*;#>markup_log(-1,-1)#g' \
+ ${WRKSRC}/webui/templates/*/*.tpl ${WRKSRC}/webui/index.php
+. endif
+.endif
+ @${FIND} ${WRKSRC} -name '*.orig' -or -name '*.bak' -delete
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/tinderbox/scripts
diff --git a/ports-mgmt/tinderbox/files/patch-enterbuild b/ports-mgmt/tinderbox/files/patch-enterbuild
new file mode 100644
index 000000000000..0bd892c9edb6
--- /dev/null
+++ b/ports-mgmt/tinderbox/files/patch-enterbuild
@@ -0,0 +1,17 @@
+diff -u lib/tc_command.sh.orig lib/tc_command.sh
+--- lib/tc_command.sh.orig
++++ lib/tc_command.sh
+@@ -1284,11 +1284,12 @@ enterBuild () {
+ return 1
+ fi
+
++ tc=$(tinderLoc scripts tc)
+ portstree=$(${tc} getPortsTreeForBuild -b ${build})
+ sleepName=$(echo ${portDir} | sed -e 'y/\//_/')
+ buildPortFullDir=${buildRoot}/usr/ports/${portDir}
+ portsTreeDir=$(tinderLoc portstree ${portstree})
+- portFullDir=${portsTreeDir}/${portDir}
++ portFullDir=${portsTreeDir}/ports/${portDir}
+
+ if [ ! -d ${portFullDir} ]; then
+ echo "enterBuild: Build environment does not exist yet, sleeping."