aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2024-04-22 11:34:21 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2024-04-23 08:36:31 +0000
commit215a14b79ce22003a98d5f0351d26a1e4a585a47 (patch)
tree082b0885e79fb86610b16f368fdcd8565ee6c0ef /ports-mgmt
parentbb944edf78e536fc0f985e4457749c85d50f9968 (diff)
downloadports-215a14b79ce22003a98d5f0351d26a1e4a585a47.tar.gz
ports-215a14b79ce22003a98d5f0351d26a1e4a585a47.zip
ports-mgmt/pkg: Remove pre-everything target
It displays messages related to conversion from ancient pkg_* tools to pkg. But support of the former ended with FreeBSD 9 and ports framework doesn't support them either. Reviewed by: bapt Differential Revision: https://reviews.freebsd.org/D44902
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg/Makefile24
1 files changed, 0 insertions, 24 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index bb603044883d..a10feb5745c5 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -41,30 +41,6 @@ MAKE_ARGS+= DEBUG_FLAGS="${DEBUG_FLAGS}"
.if ${WITH_PKG} == devel
IGNORE= WITH_PKG is defined to 'devel', this version is the stable one
.endif
-.if exists(${LOCALBASE}/sbin/pkg_info) || exists(/usr/sbin/pkg_info)
-NB_OLDPKGS!= pkg_info 2>/dev/null | wc -l
-.if exists(${PKG_BIN})
-NB_NEWPKGS!= ${PKG_INFO} -aq | wc -l
-.else
-NB_NEWPKGS= 0
-.endif
-# Only show the pre-everything notice if they have not already
-# converted any packages
-.if ${NB_OLDPKGS} > 0 && ${NB_NEWPKGS} == 0 && !defined(UPGRADEPKG)
-
-pre-everything::
- @${ECHO_CMD} "You are about to convert your system to pkg while you have ports/packages"; \
- ${ECHO_CMD} "installed with the old pkg_install tools."; \
- ${ECHO_CMD} ""; \
- ${ECHO_CMD} "To switch to pkg:"; \
- ${ECHO_CMD} " 1) Install ports-mgmt/pkg"; \
- ${ECHO_CMD} " cd ports-mgmt/pkg && make UPGRADEPKG=1 install clean"; \
- ${ECHO_CMD} " 2) Convert your package database by running pkg2ng"; \
- ${ECHO_CMD} ""; \
- exit 1
-
-.endif
-.endif
.endif
#define PKG_DEPENDS to nothing to avoid infinite loop looking for pkg :)