aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2022-01-31 14:17:07 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2022-01-31 14:17:07 +0000
commit278771d60cbc937f1cf7224db0ace55e692701f9 (patch)
tree687f981985f39644a776f2a96104974eccae78c7 /ports-mgmt
parent9920504e62df76115306b7c46356ce0a493b3334 (diff)
downloadports-278771d60cbc937f1cf7224db0ace55e692701f9.tar.gz
ports-278771d60cbc937f1cf7224db0ace55e692701f9.zip
ports-mgmt/portscout: Bugfix with empty MASTER_SITES, bump PORTREVISION
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portscout/Makefile1
-rw-r--r--ports-mgmt/portscout/files/patch-Portscout_DataSrc_Ports.pm11
2 files changed, 12 insertions, 0 deletions
diff --git a/ports-mgmt/portscout/Makefile b/ports-mgmt/portscout/Makefile
index 8f59121a6d82..63fb9efb247a 100644
--- a/ports-mgmt/portscout/Makefile
+++ b/ports-mgmt/portscout/Makefile
@@ -2,6 +2,7 @@
PORTNAME= portscout
PORTVERSION= 0.8.1.4
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MAINTAINER= koobs@FreeBSD.org
diff --git a/ports-mgmt/portscout/files/patch-Portscout_DataSrc_Ports.pm b/ports-mgmt/portscout/files/patch-Portscout_DataSrc_Ports.pm
new file mode 100644
index 000000000000..a878688be9a6
--- /dev/null
+++ b/ports-mgmt/portscout/files/patch-Portscout_DataSrc_Ports.pm
@@ -0,0 +1,11 @@
+--- Portscout/DataSrc/Ports.pm.orig 2019-10-11 12:05:53 UTC
++++ Portscout/DataSrc/Ports.pm
+@@ -454,6 +454,8 @@ sub BuildPort
+ $site =~ s/\/+$/\//;
+ $site =~ s/:[A-Za-z0-9][A-Za-z0-9\,]*$//g; # site group spec.
+
++ next if ($site eq "");
++
+ $site = URI->new($site)->canonical;
+ next if (length $site->host == 0);
+