aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2010-01-28 21:47:17 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2010-01-28 21:47:17 +0000
commitbd4db3adf7086cbf9916b7e8101aa3215827e672 (patch)
tree86c3b1362b8cd5772ba1624e0b01d08341072a35 /ports-mgmt
parent31c0d6f2840ee6c0c7c098bf10c5b974938585c6 (diff)
downloadports-bd4db3adf7086cbf9916b7e8101aa3215827e672.tar.gz
ports-bd4db3adf7086cbf9916b7e8101aa3215827e672.zip
Add support for www/hiawatha for WebUI.
PR: 142090 Submitted by: Chris Petrik
Notes
Notes: svn path=/head/; revision=248770
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/tinderbox/Makefile7
-rw-r--r--ports-mgmt/tinderbox/files/pkg-message.in11
2 files changed, 16 insertions, 2 deletions
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index 6f92a18640cc..0cadb6c980aa 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -23,6 +23,7 @@ OPTIONS= PGSQL "With pgsql" Off \
CVSUP "Use cvsup for updates" Off \
WEBUI "Install web interface" On \
APACHE "Use Apache for web interface" On \
+ HIAWATHA "Use Hiawatha for web interface" Off \
LIGHTTPD "Use LightHTTPD for web interface" Off \
CHECK_FOR_ROOT "Check if ./tc is run by uid 0" On \
LSOF "For killMountProcesses() when using nullfs" On
@@ -83,6 +84,8 @@ RUN_DEPENDS+= cvsup:${PORTSDIR}/net/cvsup-without-gui
USE_APACHE= 1.3+
.elif defined(WITH_LIGHTTPD) && defined(WITH_WEBUI)
RUN_DEPENDS+= lighttpd:${PORTSDIR}/www/lighttpd
+.elif defined(WITH_HIAWATHA) && defined(WITH_WEBUI)
+RUN_DEPENDS+= hiawatha:${PORTSDIR}/www/hiawatha
.endif
.if defined(WITH_LSOF)
@@ -90,8 +93,8 @@ RUN_DEPENDS+= lsof:${PORTSDIR}/sysutils/lsof
.endif
pre-everything::
-.if (!defined(WITHOUT_APACHE) || defined(WITH_LIGHTTPD)) && !defined(WITH_WEBUI)
- @${ECHO_CMD} "It doesn't make sense to depend on Apache or LightHTTPD if not using either web interface."
+.if (!defined(WITHOUT_APACHE) || defined(WITH_LIGHTTPD) || defined(WITH_HIAWATHA)) && !defined(WITH_WEBUI)
+ @${ECHO_CMD} "It doesn't make sense to depend on Apache, LightHTTPD or Hiawatha if not using any web interface."
@${FALSE}
.endif
diff --git a/ports-mgmt/tinderbox/files/pkg-message.in b/ports-mgmt/tinderbox/files/pkg-message.in
index ef714324b6ea..df8d22faf10a 100644
--- a/ports-mgmt/tinderbox/files/pkg-message.in
+++ b/ports-mgmt/tinderbox/files/pkg-message.in
@@ -19,6 +19,7 @@ The following walkthrough is the webserver setup:
Allow from all
</Directory>
+
- In your Lighttpd configuration:
Turn on "mod_alias" and add the following lines:
@@ -29,6 +30,16 @@ alias.url = ( "/tb/logs/" => "%%PREFIX%%/tinderbox/logs/",
"/tb/" => "%%PREFIX%%/tinderbox/scripts/webui/" )
dir-listing.activate = "enable"
+
+- In you Hiawatha configuration:
+
+Alias is a built in command, no need to load any special mod
+
+Alias = /tb/logs:%%PREFIX%%/tinderbox/logs
+Alias = /tb/packages:%%PREFIX%%/tinderbox/packages
+Alias = /tb/errors:%%PREFIX%%/tinderbox/errors
+Alias = /tb/:%%PREFIX%%/tinderbox/scripts/webui
+
Check your system by going to http://localhost/tb/
=============================================================================