aboutsummaryrefslogtreecommitdiff
path: root/portuguese
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 05:31:28 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 06:00:48 +0000
commit915dbfaa562e20c8402d3873f8bfbf07899f9f8a (patch)
tree31846497e11ce47118708aa782fe87dbb6a7599f /portuguese
parentaa9edcc217007fd4a39e10ee17805dd350c25381 (diff)
downloadports-915dbfaa562e20c8402d3873f8bfbf07899f9f8a.tar.gz
ports-915dbfaa562e20c8402d3873f8bfbf07899f9f8a.zip
*/*hyphen: Avoid using %% in Makefile
Use ${DATAIDR} instead of %%DATADIR%%
Diffstat (limited to 'portuguese')
-rw-r--r--portuguese/hyphen/Makefile4
-rw-r--r--portuguese/hyphen/Makefile 27
2 files changed, 29 insertions, 2 deletions
diff --git a/portuguese/hyphen/Makefile b/portuguese/hyphen/Makefile
index 5efdf8f44b1d..55042c535793 100644
--- a/portuguese/hyphen/Makefile
+++ b/portuguese/hyphen/Makefile
@@ -16,8 +16,8 @@ NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/hyph_pt_BR.dic \
- %%DATADIR%%/hyph_pt_PT.dic
+PLIST_FILES= ${DATADIR}/hyph_pt_BR.dic \
+ ${DATADIR}/hyph_pt_PT.dic
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/
diff --git a/portuguese/hyphen/Makefile b/portuguese/hyphen/Makefile
new file mode 100644
index 000000000000..5efdf8f44b1d
--- /dev/null
+++ b/portuguese/hyphen/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= hyphen
+PORTVERSION= 2004.04.15
+PORTREVISION= 1
+CATEGORIES= portuguese textproc
+MASTER_SITES= LOCAL/sunpoet/${PORTNAME}/
+DISTNAME= hyph_pt_PT-${PORTVERSION:C/\.//g}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Portuguese hyphenation rules
+
+LICENSE= LGPL21
+
+USES= zip
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/hyph_pt_BR.dic \
+ %%DATADIR%%/hyph_pt_PT.dic
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/hyph_pt_PT.dic ${STAGEDIR}${DATADIR}/
+ ${LN} -s hyph_pt_PT.dic ${STAGEDIR}${DATADIR}/hyph_pt_BR.dic
+
+.include <bsd.port.mk>