aboutsummaryrefslogtreecommitdiff
path: root/print/a2ps
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-04-27 16:00:26 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-04-27 16:00:26 +0000
commit03156fbc9e57b8833d571c09fe86a65de05d8966 (patch)
treea41583195bf11eaddcc25d81461b4a49df2cefca /print/a2ps
parentbfd963a8d0744b35d2c9acd4b82023eadad3a02d (diff)
downloadports-03156fbc9e57b8833d571c09fe86a65de05d8966.tar.gz
ports-03156fbc9e57b8833d571c09fe86a65de05d8966.zip
Add libpaper support to print/a2ps-*[1], print/c2ps-*, print/lprps-*,
graphics/jpeg2ps-*, and merge the papersize-suffixed versions into single ones respectively as print/psutils did. Approved by: dinoex (maintainer) [1]
Notes
Notes: svn path=/head/; revision=316672
Diffstat (limited to 'print/a2ps')
-rw-r--r--print/a2ps/Makefile102
-rw-r--r--print/a2ps/distinfo4
-rw-r--r--print/a2ps/files/patch-ad11
-rw-r--r--print/a2ps/files/patch-ae18
-rw-r--r--print/a2ps/files/patch-contrib-emacs-Makefile.in25
-rw-r--r--print/a2ps/files/patch-contrib-tmpdircreation116
-rw-r--r--print/a2ps/files/patch-etc-Makefile.in11
-rw-r--r--print/a2ps/files/patch-intl-localealias.c20
-rw-r--r--print/a2ps/files/patch-lib-xgethostname.c19
-rw-r--r--print/a2ps/files/patch-printers.c13
-rw-r--r--print/a2ps/files/patch-select.c57
-rw-r--r--print/a2ps/files/patch-xgethostname.c12
-rw-r--r--print/a2ps/pkg-descr13
-rw-r--r--print/a2ps/pkg-plist294
14 files changed, 715 insertions, 0 deletions
diff --git a/print/a2ps/Makefile b/print/a2ps/Makefile
new file mode 100644
index 000000000000..9f0eab002d5b
--- /dev/null
+++ b/print/a2ps/Makefile
@@ -0,0 +1,102 @@
+# Created by: Chuck Robey <chuckr@freebsd.org>
+# $FreeBSD$
+
+PORTNAME= a2ps
+PORTVERSION= 4.13b
+PORTREVISION= 5
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_GNU} \
+ ${MASTER_SITE_LOCAL:S/$/:i18n/}
+MASTER_SITE_SUBDIR= ${PORTNAME} hrs/a2ps/:i18n
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Formats an ASCII file for printing on a postscript printer
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= paper:${PORTSDIR}/print/libpaper
+
+USE_PERL5= yes
+USE_CSTD= gnu89
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+MAN1= a2ps.1 ogonkify.1 card.1 psmandup.1 fixps.1 pdiff.1 psset.1 \
+ texi2dvi4a2ps.1
+INFO= a2ps ogonkify regex
+WRKSRC= ${WRKDIR}/${PORTNAME}-4.13
+I18N_PACKAGE= i18n-fonts-0.1
+PORTSCOUT= skipv:4.14
+
+STRIP=
+CONFIGURE_ARGS= --with-medium=libpaper --sharedstatedir=${PREFIX}/share \
+ --sysconfdir=${PREFIX}/etc --datadir=${PREFIX}/share \
+ --localstatedir=${PREFIX}/share
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+MAKE_JOBS_SAFE= yes
+
+PAPERSIZE?=
+.if ${PAPERSIZE:L} == a4
+RUN_DEPENDS+= ${LOCALBASE}/etc/papersize:${PORTSDIR}/print/papersize-default-a4
+.endif
+
+OPTIONS_DEFINE=NLS I18N EMACS
+OPTIONS_DEFAULT=NLS
+NO_OPTIONS_SORT=yes
+EMACS_DESC=Enable Emacs support
+I18N_DESC=Enable I18N support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MEMACS}
+USE_EMACS= yes
+CONFIGURE_ARGS+= --with-lispdir=${LOCALBASE}/${EMACS_SITE_LISPDIR}
+PLIST_SUB+= WITHEMACS=""
+.else
+CONFIGURE_ENV+= EMACS=no
+PLIST_SUB+= WITHEMACS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MI18N}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${I18N_PACKAGE}${EXTRACT_SUFX}:i18n
+PLIST_SUB+= WITHI18N=""
+
+pre-configure:
+ cd ${WRKDIR}/${I18N_PACKAGE}/afm && \
+ ${ECHO_CMD} *.afm > afms.lst && \
+ ${MV} *.afm ${WRKSRC}/afm
+ cd ${WRKDIR}/${I18N_PACKAGE}/fonts && \
+ ${MV} *.pfb ${WRKSRC}/fonts
+
+post-configure:
+ @cd ${WRKSRC}/fonts && { ${ECHO_CMD} ''; \
+ ${ECHO_CMD} "pfb_fonts =" *.pfb; } >> Makefile && \
+ ${REINPLACE_CMD} 's,^\(fonts_DATA = .*\),\1 $$(pfb_fonts),' Makefile
+ @cd ${WRKSRC}/afm && { ${ECHO} ''; \
+ ${ECHO} "i18n_afms =" `cat ${WRKDIR}/${I18N_PACKAGE}/afm/afms.lst`; } >> Makefile && \
+ ${REINPLACE_CMD} 's,^\(all_afms = .*\),\1 $$(i18n_afms),' Makefile
+.else
+PLIST_SUB+= WITHI18N="@comment "
+.endif
+
+post-install:
+ ${STRIP_CMD} ${PREFIX}/bin/a2ps
+.if ${PORT_OPTIONS:MEMACS}
+ ${MKDIR} ${PREFIX}/lib/xemacs/site-lisp
+ ${LN} -sf ${PREFIX}/share/emacs/site-lisp/a2ps-print.el \
+ ${PREFIX}/lib/xemacs/site-lisp/a2ps-print.el
+ ${LN} -sf ${PREFIX}/share/emacs/site-lisp/a2ps.el \
+ ${PREFIX}/lib/xemacs/site-lisp/a2ps.el
+.endif
+ cd ${WRKSRC}/doc && \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${.MAKEFLAGS} ${INSTALL_TARGET}
+ ${RM} -f ${PREFIX}/lib/liba2ps.la
+
+.include <bsd.port.mk>
diff --git a/print/a2ps/distinfo b/print/a2ps/distinfo
new file mode 100644
index 000000000000..f5a7b78eb097
--- /dev/null
+++ b/print/a2ps/distinfo
@@ -0,0 +1,4 @@
+SHA256 (a2ps-4.13b.tar.gz) = f4d2ac6f09f44eeb82621530b1970afe88fd97cfe82da43b61069800d0c06d12
+SIZE (a2ps-4.13b.tar.gz) = 1944289
+SHA256 (i18n-fonts-0.1.tar.gz) = 20628df682359044b8e5241c97a3c8da7a098aa260a7d281a87f67486a531786
+SIZE (i18n-fonts-0.1.tar.gz) = 352530
diff --git a/print/a2ps/files/patch-ad b/print/a2ps/files/patch-ad
new file mode 100644
index 000000000000..4b8428030547
--- /dev/null
+++ b/print/a2ps/files/patch-ad
@@ -0,0 +1,11 @@
+--- ogonkify/Makefile.in.orig Tue Apr 20 00:07:03 1999
++++ ogonkify/Makefile.in Tue Apr 20 00:07:07 1999
+@@ -37,7 +37,7 @@
+
+ DESTDIR =
+
+-pkgdatadir = $(datadir)/@PACKAGE@
++pkgdatadir = $(datadir)/a2ps/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+ pkgincludedir = $(includedir)/@PACKAGE@
+
diff --git a/print/a2ps/files/patch-ae b/print/a2ps/files/patch-ae
new file mode 100644
index 000000000000..e85e42c0dc42
--- /dev/null
+++ b/print/a2ps/files/patch-ae
@@ -0,0 +1,18 @@
+--- lib/options.c.orig Thu Sep 21 23:22:36 2000
++++ lib/options.c Thu Sep 21 23:22:42 2000
+@@ -493,6 +493,15 @@
+ /* A font size is given */
+ job->fontsize = get_length ("--font-size", cp,
+ 0.0, 0.0, "pt", range_min_strict);
++ if (job->fontsize == 0.0)
++ {
++ error (0, 0, _("invalid argument %s for -f or --font-size option"),
++ cp);
++ fprintf (stderr,
++ _("Valid arguments are floats with optonal units!\n"));
++ fprintf (stderr, _("Try `a2ps --help' for more information.\n"));
++ exit (EXIT_FAILURE);
++ }
+ job->columns_requested = 0;
+ job->lines_requested = 0;
+ }
diff --git a/print/a2ps/files/patch-contrib-emacs-Makefile.in b/print/a2ps/files/patch-contrib-emacs-Makefile.in
new file mode 100644
index 000000000000..c1dab47d2a50
--- /dev/null
+++ b/print/a2ps/files/patch-contrib-emacs-Makefile.in
@@ -0,0 +1,25 @@
+Index: contrib/emacs/Makefile.in
+--- Makefile.in.orig 2011-09-27 15:17:26.000000000 +0900
++++ Makefile.in 2011-09-27 15:18:10.000000000 +0900
+@@ -159,8 +159,9 @@
+
+ install-dist_lispLISP: $(dist_lisp_LISP) $(ELCFILES)
+ @$(NORMAL_INSTALL)
+- $(mkinstalldirs) $(DESTDIR)$(lispdir)
+- @list='$(dist_lisp_LISP)'; for p in $$list; do \
++ if test $(EMACS) != no; then \
++ $(mkinstalldirs) $(DESTDIR)$(lispdir); \
++ list='$(dist_lisp_LISP)'; for p in $$list; do \
+ if test -f "$$p"; then d= ; else d="$(srcdir)/"; fi; \
+ f="`echo $$p | sed -e 's|^.*/||'`"; \
+ echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(lispdir)/$$f"; \
+@@ -169,7 +170,8 @@
+ echo " $(INSTALL_DATA) $${p}c $(DESTDIR)$(lispdir)/$${f}c"; \
+ $(INSTALL_DATA) $${p}c $(DESTDIR)$(lispdir)/$${f}c; \
+ else : ; fi; \
+- done
++ done; \
++ fi
+
+ uninstall-dist_lispLISP:
+ @$(NORMAL_UNINSTALL)
diff --git a/print/a2ps/files/patch-contrib-tmpdircreation b/print/a2ps/files/patch-contrib-tmpdircreation
new file mode 100644
index 000000000000..e47e97120ad4
--- /dev/null
+++ b/print/a2ps/files/patch-contrib-tmpdircreation
@@ -0,0 +1,116 @@
+diff -ru contrib.orig/card.in contrib/card.in
+--- contrib.orig/card.in Thu Dec 30 19:23:25 2004
++++ contrib/card.in Thu Dec 30 19:29:49 2004
+@@ -38,7 +38,7 @@
+ LC_ALL="${LC_ALL-C}" export LC_ALL
+ print_form_feeds=:
+ RM="/bin/rm -rf"
+-tmp_dir=${TMPDIR-/tmp}/$program.$$
++tmp_dir=$(mktemp -d -t ${program}) || exit 1
+ tmp_file=$tmp_dir/card
+ success=false
+ verbose=:
+@@ -190,7 +190,6 @@
+
+ # Create a tmp dir and be ready to clean up
+ trap "$RM $tmp_dir" 0 1 2 15
+-(umask 077 && mkdir $tmp_dir) || exit 1
+
+ case $LC_ALL in
+ fr) footer="Engendré par $version_short" ;;
+diff -ru contrib.orig/fixps.in contrib/fixps.in
+--- contrib.orig/fixps.in Thu Dec 30 19:23:25 2004
++++ contrib/fixps.in Thu Dec 30 19:31:22 2004
+@@ -38,7 +38,7 @@
+ run_gs=0
+ # What action to perform: fixps, cat, check, and gs
+ task=fixps
+-tmpdir=/tmp/$program.$$
++tmpdir=$(mktemp -d -t ${program}) || exit 1
+ verbose=echo
+
+ # The version/usage strings
+@@ -191,7 +191,6 @@
+ trap "/bin/rm -rf $tmpdir" 0 1 2 3 13 15
+ fi
+
+-mkdir $tmpdir
+ fixps_sed=$tmpdir/fixps.sed
+
+ # If printing from stdin, save into a tmp file
+diff -ru contrib.orig/pdiff.in contrib/pdiff.in
+--- contrib.orig/pdiff.in Thu Dec 30 19:23:25 2004
++++ contrib/pdiff.in Thu Dec 30 19:16:59 2004
+@@ -34,7 +34,7 @@
+ diff_options='-u'
+ file=
+ output=
+-tmpdir=/tmp/$program.$$
++tmpdir=$(mktemp -d -t ${program}) || exit 1
+ verbose=echo
+ wdiff_prog=${WDIFF:-wdiff}
+ wdiff_options='-w[wd- -x-wd] -y{wd+ -z+wd}'
+diff -ru contrib.orig/psmandup.in contrib/psmandup.in
+--- contrib.orig/psmandup.in Thu Dec 30 19:23:25 2004
++++ contrib/psmandup.in Thu Dec 30 19:32:30 2004
+@@ -36,7 +36,7 @@
+ message=
+ psselect=${PSSELECT:-psselect}
+ psset=${PSSET:-psset}
+-tmpdir=/tmp/$program.$$
++tmpdir=$(mktemp -d -t ${program}) || exit 1
+
+ # These two must be kept in synch. They are opposed.
+ verbose=echo
+@@ -184,8 +184,6 @@
+ # Temp dir. Get ready not to leave junk (if not debugging)
+ trap "/bin/rm -rf $tmpdir" 0 1 2 3 13 15
+ fi
+-
+-mkdir $tmpdir
+
+ # If printing from stdin, save into a tmp file
+ if test $file = '-'; then
+diff -ru contrib.orig/psset.in contrib/psset.in
+--- contrib.orig/psset.in Thu Dec 30 19:23:25 2004
++++ contrib/psset.in Thu Dec 30 19:33:50 2004
+@@ -33,7 +33,7 @@
+ output=-
+ pagedevices= # `;' separated list of `key:value'
+ quiet=: # i.e., verbose
+-tmpdir=${TMPDIR:-/tmp}/$program.$$
++tmpdir=$(mktemp -d -t ${program}) || exit 1
+ sedscript=$tmpdir/psset.sed
+
+ # The version/usage strings
+@@ -185,8 +185,6 @@
+ echo "$help" 1>&2
+ exit 1;;
+ esac
+-
+-mkdir $tmpdir
+
+ if test -n "$debug"; then
+ # Set -x now if debugging
+diff -ru contrib.orig/texi2dvi4a2ps contrib/texi2dvi4a2ps
+--- contrib.orig/texi2dvi4a2ps Thu Dec 30 19:23:25 2004
++++ contrib/texi2dvi4a2ps Thu Dec 30 19:34:36 2004
+@@ -91,7 +91,7 @@
+ quiet= # by default let the tools' message be displayed
+ set_language=
+ textra=
+-tmpdir=${TMPDIR:-/tmp}/t2d$$ # avoid collisions on 8.3 filesystems.
++tmpdir=$(mktemp -d -t ${program}) || exit 1
+ txincludes= # TEXINPUTS extensions
+ txiprereq=19990129 # minimum texinfo.tex version to have macro expansion
+ verbose=false # echo for verbose mode
+@@ -202,9 +202,6 @@
+ if test -z "$debug"; then
+ trap "cd / && rm -rf $tmpdir" 0 1 2 15
+ fi
+-
+-# Create the temporary directory with strict rights
+-(umask 077 && mkdir $tmpdir) || exit 1
+
+ # Prepare the tools we might need. This may be extra work in some
+ # cases, but improves the readibility of the script.
diff --git a/print/a2ps/files/patch-etc-Makefile.in b/print/a2ps/files/patch-etc-Makefile.in
new file mode 100644
index 000000000000..6dddd830dcbf
--- /dev/null
+++ b/print/a2ps/files/patch-etc-Makefile.in
@@ -0,0 +1,11 @@
+--- etc/Makefile.in.orig Tue Nov 20 19:09:45 2001
++++ etc/Makefile.in Tue Nov 20 19:09:53 2001
+@@ -131,7 +131,7 @@
+ lispdir = @lispdir@
+
+
+-ogonkifydir = $(datadir)/ogonkify
++ogonkifydir = $(datadir)/a2ps/ogonkify
+ libpath = $(pkgdatadir)/sheets:$(pkgdatadir)/ps:$(pkgdatadir)/encoding:$(pkgdatadir)/afm:$(ogonkifydir)/afm:$(pkgdatadir)/ppd:$(pkgdatadir)/fonts:$(ogonkifydir)/fonts:$(pkgdatadir)
+
+ pkgdata_DATA = README
diff --git a/print/a2ps/files/patch-intl-localealias.c b/print/a2ps/files/patch-intl-localealias.c
new file mode 100644
index 000000000000..074a19569ca5
--- /dev/null
+++ b/print/a2ps/files/patch-intl-localealias.c
@@ -0,0 +1,20 @@
+--- intl/localealias.c.orig Tue Aug 31 13:29:35 1999
++++ intl/localealias.c Tue Aug 12 11:09:53 2003
+@@ -329,6 +329,17 @@
+ FREE_BLOCKS (block_list);
+ return added;
+ }
++ if (string_space != new_pool)
++ {
++ size_t i;
++
++ for (i = 0; i < nmap; i++)
++ {
++ map[i].alias += new_pool - string_space;
++ map[i].value += new_pool - string_space;
++ }
++ }
++
+ string_space = new_pool;
+ string_space_max = new_size;
+ }
diff --git a/print/a2ps/files/patch-lib-xgethostname.c b/print/a2ps/files/patch-lib-xgethostname.c
new file mode 100644
index 000000000000..06312ddf88e3
--- /dev/null
+++ b/print/a2ps/files/patch-lib-xgethostname.c
@@ -0,0 +1,19 @@
+--- lib/xgethostname.c.orig Tue Nov 20 20:26:31 2001
++++ lib/xgethostname.c Tue Nov 20 20:26:03 2001
+@@ -21,6 +21,7 @@
+ # include <config.h>
+ #endif
+
++#include <sys/param.h>
+ #include <sys/types.h>
+
+ #include <errno.h>
+@@ -38,7 +39,7 @@
+ int gethostname ();
+
+ #ifndef INITIAL_HOSTNAME_LENGTH
+-# define INITIAL_HOSTNAME_LENGTH 34
++# define INITIAL_HOSTNAME_LENGTH MAXHOSTNAMELEN
+ #endif
+
+ char *
diff --git a/print/a2ps/files/patch-printers.c b/print/a2ps/files/patch-printers.c
new file mode 100644
index 000000000000..943fc6445a24
--- /dev/null
+++ b/print/a2ps/files/patch-printers.c
@@ -0,0 +1,13 @@
+--- lib/printers.c.orig Tue Oct 12 00:01:59 1999
++++ lib/printers.c Wed May 2 11:23:25 2001
+@@ -315,8 +315,8 @@
+ res->ppd = NULL; /* Printer's ppd are not read yet */
+
+ /* Output */
+- /* Default is to send to default printer */
+- res->flag_output_is_printer = true;
++ /* Default is to send to stdout */
++ res->flag_output_is_printer = false;
+ res->flag_output_name = NULL;
+ res->output_is_file = true;
+ res->output_name = NULL;
diff --git a/print/a2ps/files/patch-select.c b/print/a2ps/files/patch-select.c
new file mode 100644
index 000000000000..a2c38898fdc6
--- /dev/null
+++ b/print/a2ps/files/patch-select.c
@@ -0,0 +1,57 @@
+--- src/select.c.orig Thu Dec 16 02:04:56 1999
++++ src/select.c Sat Aug 21 12:05:31 2004
+@@ -131,6 +131,36 @@
+ return 1;
+ }
+
++/* escapes the name of a file so that the shell groks it in 'single' q.marks.
++ The resulting pointer has to be free()ed when not longer used. */
++char *
++shell_escape(const char *fn)
++{
++ size_t len = 0;
++ const char *inp;
++ char *retval, *outp;
++
++ for(inp = fn; *inp; ++inp)
++ switch(*inp)
++ {
++ case '\'': len += 4; break;
++ default: len += 1; break;
++ }
++
++ outp = retval = malloc(len + 1);
++ if(!outp)
++ return NULL; /* perhaps one should do better error handling here */
++ for(inp = fn; *inp; ++inp)
++ switch(*inp)
++ {
++ case '\'': *outp++ = '\''; *outp++ = '\\'; *outp++ = '\'', *outp++ = '\''; break;
++ default: *outp++ = *inp; break;
++ }
++ *outp = 0;
++
++ return retval;
++}
++
+ /* What says file about the type of a file (result is malloc'd). NULL
+ if could not be run. */
+
+@@ -144,11 +174,15 @@
+ if (IS_EMPTY (job->file_command))
+ return NULL;
+
++ filename = shell_escape(filename);
++ if(filename == NULL)
++ return NULL;
+ /* Call file(1) with the correct option */
+- command = ALLOCA (char, (2
++ command = ALLOCA (char, (4
+ + strlen (job->file_command)
+ + ustrlen (filename)));
+- sprintf (command, "%s %s", job->file_command, (const char *) filename);
++ sprintf (command, "%s '%s'", job->file_command, (const char *) filename);
++ free(filename);
+ message (msg_tool, (stderr, "Reading pipe: `%s'\n", command));
+ file_out = popen (command, "r");
+
diff --git a/print/a2ps/files/patch-xgethostname.c b/print/a2ps/files/patch-xgethostname.c
new file mode 100644
index 000000000000..bfc7c33e0a6d
--- /dev/null
+++ b/print/a2ps/files/patch-xgethostname.c
@@ -0,0 +1,12 @@
+--- lib/xgethostname.c Tue Sep 4 00:51:26 2001
++++ lib/xgethostname.c.new Tue Sep 4 00:55:39 2001
+@@ -63,7 +63,7 @@
+ if (err == 0 && hostname[k] == '\0')
+ break;
+ #ifdef ENAMETOOLONG
+- else if (err != 0 && errno != ENAMETOOLONG && errno != 0)
++ else if (err != 0 && errno != ENAMETOOLONG && errno != ENOMEM && errno != 0)
+ error (EXIT_FAILURE, errno, "gethostname");
+ #endif
+ size *= 2;
+
diff --git a/print/a2ps/pkg-descr b/print/a2ps/pkg-descr
new file mode 100644
index 000000000000..2e47ab4fab5b
--- /dev/null
+++ b/print/a2ps/pkg-descr
@@ -0,0 +1,13 @@
+A2ps formats each named file for printing in a postscript printer; if
+no file is given, a2ps reads from the standard input. The format used
+is nice and compact: normally two pages on each physical page, borders
+surrounding pages, headers with useful information (page number,
+printing date, file name or supplied header), line numbering, etc.
+This is very useful for making archive listings of programs.
+
+Additionally, A2ps "pretty print"s using special fonts for a wide array
+of languages, making things like program listings much more legible.
+
+LICENSE: GPL2 or later
+
+WWW: http://www.inf.enst.fr/~demaille/a2ps/
diff --git a/print/a2ps/pkg-plist b/print/a2ps/pkg-plist
new file mode 100644
index 000000000000..2101bd94764b
--- /dev/null
+++ b/print/a2ps/pkg-plist
@@ -0,0 +1,294 @@
+bin/a2ps
+bin/card
+bin/composeglyphs
+bin/fixnt
+bin/fixps
+bin/ogonkify
+bin/pdiff
+bin/psmandup
+bin/psset
+bin/texi2dvi4a2ps
+etc/a2ps-site.cfg
+etc/a2ps.cfg
+include/liba2ps.h
+lib/liba2ps.a
+%%DATADIR%%/README
+%%DATADIR%%/afm/fonts.map
+%%DATADIR%%/afm/make_fonts_map.sh
+%%DATADIR%%/afm/pbkd.afm
+%%DATADIR%%/afm/pbkdi.afm
+%%DATADIR%%/afm/pbkl.afm
+%%DATADIR%%/afm/pbkli.afm
+%%DATADIR%%/afm/pcfont.afm
+%%DATADIR%%/afm/pcrb.afm
+%%DATADIR%%/afm/pcrbo.afm
+%%DATADIR%%/afm/pcrr.afm
+%%DATADIR%%/afm/pcrro.afm
+%%DATADIR%%/afm/phvb.afm
+%%DATADIR%%/afm/phvbo.afm
+%%DATADIR%%/afm/phvbon.afm
+%%DATADIR%%/afm/phvbrn.afm
+%%DATADIR%%/afm/phvr.afm
+%%DATADIR%%/afm/phvro.afm
+%%DATADIR%%/afm/phvron.afm
+%%DATADIR%%/afm/phvrrn.afm
+%%DATADIR%%/afm/pncb.afm
+%%DATADIR%%/afm/pncbi.afm
+%%DATADIR%%/afm/pncr.afm
+%%DATADIR%%/afm/pncri.afm
+%%DATADIR%%/afm/pplb.afm
+%%DATADIR%%/afm/pplbi.afm
+%%DATADIR%%/afm/pplr.afm
+%%DATADIR%%/afm/pplri.afm
+%%DATADIR%%/afm/psyr.afm
+%%DATADIR%%/afm/ptmb.afm
+%%DATADIR%%/afm/ptmbi.afm
+%%DATADIR%%/afm/ptmi.afm
+%%DATADIR%%/afm/ptmr.afm
+%%DATADIR%%/afm/pzcmi.afm
+%%DATADIR%%/afm/pzdr.afm
+%%WITHI18N%%%%DATADIR%%/afm/colle10.afm
+%%WITHI18N%%%%DATADIR%%/afm/colle8.afm
+%%WITHI18N%%%%DATADIR%%/afm/colle9.afm
+%%WITHI18N%%%%DATADIR%%/afm/crr35__i.afm
+%%WITHI18N%%%%DATADIR%%/afm/crr36__i.afm
+%%WITHI18N%%%%DATADIR%%/afm/crr55__i.afm
+%%WITHI18N%%%%DATADIR%%/afm/crr56__i.afm
+%%WITHI18N%%%%DATADIR%%/afm/textb18.afm
+%%WITHI18N%%%%DATADIR%%/afm/textb19.afm
+%%WITHI18N%%%%DATADIR%%/afm/textb20.afm
+%%DATADIR%%/encoding/ascii.edf
+%%DATADIR%%/encoding/encoding.map
+%%DATADIR%%/encoding/hp.edf
+%%DATADIR%%/encoding/ibm-cp437.edf
+%%DATADIR%%/encoding/ibm-cp850.edf
+%%DATADIR%%/encoding/iso1.edf
+%%DATADIR%%/encoding/iso10.edf
+%%DATADIR%%/encoding/iso13.edf
+%%DATADIR%%/encoding/iso15.edf
+%%DATADIR%%/encoding/iso2.edf
+%%DATADIR%%/encoding/iso3.edf
+%%DATADIR%%/encoding/iso4.edf
+%%DATADIR%%/encoding/iso5.edf
+%%DATADIR%%/encoding/iso7.edf
+%%DATADIR%%/encoding/iso9.edf
+%%DATADIR%%/encoding/koi8.edf
+%%DATADIR%%/encoding/mac.edf
+%%DATADIR%%/encoding/ms-cp1250.edf
+%%DATADIR%%/fonts/pcfont.pfa
+%%WITHI18N%%%%DATADIR%%/fonts/colle10.pfb
+%%WITHI18N%%%%DATADIR%%/fonts/colle8.pfb
+%%WITHI18N%%%%DATADIR%%/fonts/colle9.pfb
+%%WITHI18N%%%%DATADIR%%/fonts/crr35__i.pfb
+%%WITHI18N%%%%DATADIR%%/fonts/crr36__i.pfb
+%%WITHI18N%%%%DATADIR%%/fonts/crr55__i.pfb
+%%WITHI18N%%%%DATADIR%%/fonts/crr56__i.pfb
+%%WITHI18N%%%%DATADIR%%/fonts/textb18.pfb
+%%WITHI18N%%%%DATADIR%%/fonts/textb19.pfb
+%%WITHI18N%%%%DATADIR%%/fonts/textb20.pfb
+%%DATADIR%%/ogonkify/README
+%%DATADIR%%/ogonkify/adobe.enc
+%%DATADIR%%/ogonkify/afm/pcrb-o.afm
+%%DATADIR%%/ogonkify/afm/pcrbo-o.afm
+%%DATADIR%%/ogonkify/afm/pcrr-o.afm
+%%DATADIR%%/ogonkify/afm/pcrro-o.afm
+%%DATADIR%%/ogonkify/afm/phvb-o.afm
+%%DATADIR%%/ogonkify/afm/phvbo-o.afm
+%%DATADIR%%/ogonkify/afm/phvr-o.afm
+%%DATADIR%%/ogonkify/afm/phvro-o.afm
+%%DATADIR%%/ogonkify/afm/ptmb-o.afm
+%%DATADIR%%/ogonkify/afm/ptmbi-o.afm
+%%DATADIR%%/ogonkify/afm/ptmr-o.afm
+%%DATADIR%%/ogonkify/afm/ptmri-o.afm
+%%DATADIR%%/ogonkify/allchars.ps
+%%DATADIR%%/ogonkify/ascii.enc
+%%DATADIR%%/ogonkify/compose.ps
+%%DATADIR%%/ogonkify/cp1250.enc
+%%DATADIR%%/ogonkify/fonts/pcrb-o.pfa
+%%DATADIR%%/ogonkify/fonts/pcrbo-o.pfa
+%%DATADIR%%/ogonkify/fonts/pcrr-o.pfa
+%%DATADIR%%/ogonkify/fonts/pcrro-o.pfa
+%%DATADIR%%/ogonkify/fonts/phvb-o.pfa
+%%DATADIR%%/ogonkify/fonts/phvbo-o.pfa
+%%DATADIR%%/ogonkify/fonts/phvr-o.pfa
+%%DATADIR%%/ogonkify/fonts/phvro-o.pfa
+%%DATADIR%%/ogonkify/fonts/ptmb-o.pfa
+%%DATADIR%%/ogonkify/fonts/ptmbi-o.pfa
+%%DATADIR%%/ogonkify/fonts/ptmr-o.pfa
+%%DATADIR%%/ogonkify/fonts/ptmri-o.pfa
+%%DATADIR%%/ogonkify/helper.ps
+%%DATADIR%%/ogonkify/hp.enc
+%%DATADIR%%/ogonkify/ibmpc.enc
+%%DATADIR%%/ogonkify/latin1.enc
+%%DATADIR%%/ogonkify/latin2.enc
+%%DATADIR%%/ogonkify/latin3.enc
+%%DATADIR%%/ogonkify/latin4.enc
+%%DATADIR%%/ogonkify/latin5.enc
+%%DATADIR%%/ogonkify/latin6.enc
+%%DATADIR%%/ogonkify/latin7.enc
+%%DATADIR%%/ogonkify/latin9.enc
+%%DATADIR%%/ogonkify/mac.enc
+%%DATADIR%%/ogonkify/ogonki.enc
+%%DATADIR%%/ogonkify/pcrb-o.ps
+%%DATADIR%%/ogonkify/pcrbo-o.ps
+%%DATADIR%%/ogonkify/pcrr-o.ps
+%%DATADIR%%/ogonkify/pcrro-o.ps
+%%DATADIR%%/ogonkify/phvb-o.ps
+%%DATADIR%%/ogonkify/phvbo-o.ps
+%%DATADIR%%/ogonkify/phvr-o.ps
+%%DATADIR%%/ogonkify/phvro-o.ps
+%%DATADIR%%/ogonkify/printenc.ps
+%%DATADIR%%/ogonkify/ptmb-o.ps
+%%DATADIR%%/ogonkify/ptmbi-o.ps
+%%DATADIR%%/ogonkify/ptmr-o.ps
+%%DATADIR%%/ogonkify/ptmri-o.ps
+%%DATADIR%%/ppd/README
+%%DATADIR%%/ppd/level1.ppd
+%%DATADIR%%/ppd/level2.ppd
+%%DATADIR%%/ps/a2ps.hdr
+%%DATADIR%%/ps/base.ps
+%%DATADIR%%/ps/bold.pro
+%%DATADIR%%/ps/bw.pro
+%%DATADIR%%/ps/color.hdr
+%%DATADIR%%/ps/color.pro
+%%DATADIR%%/ps/diff.pro
+%%DATADIR%%/ps/ehandler.ps
+%%DATADIR%%/ps/fixed.pro
+%%DATADIR%%/ps/gray.pro
+%%DATADIR%%/ps/gray2.pro
+%%DATADIR%%/ps/matrix.pro
+%%DATADIR%%/ps/ul.pro
+%%DATADIR%%/sheets/68000.ssh
+%%DATADIR%%/sheets/a2psrc.ssh
+%%DATADIR%%/sheets/ada.ssh
+%%DATADIR%%/sheets/asn1.ssh
+%%DATADIR%%/sheets/autoconf.ssh
+%%DATADIR%%/sheets/awk.ssh
+%%DATADIR%%/sheets/b.ssh
+%%DATADIR%%/sheets/bc.ssh
+%%DATADIR%%/sheets/c.ssh
+%%DATADIR%%/sheets/caml.ssh
+%%DATADIR%%/sheets/card.ssh
+%%DATADIR%%/sheets/chlog.ssh
+%%DATADIR%%/sheets/cidl.ssh
+%%DATADIR%%/sheets/claire.ssh
+%%DATADIR%%/sheets/clisp.ssh
+%%DATADIR%%/sheets/coqv.ssh
+%%DATADIR%%/sheets/cpp.ssh
+%%DATADIR%%/sheets/csh.ssh
+%%DATADIR%%/sheets/cxx.ssh
+%%DATADIR%%/sheets/dc_shell.ssh
+%%DATADIR%%/sheets/eiffel.ssh
+%%DATADIR%%/sheets/elisp.ssh
+%%DATADIR%%/sheets/eps.ssh
+%%DATADIR%%/sheets/for-fixed.ssh
+%%DATADIR%%/sheets/for-free.ssh
+%%DATADIR%%/sheets/for77-fixed.ssh
+%%DATADIR%%/sheets/for77-free.ssh
+%%DATADIR%%/sheets/for77kwds.ssh
+%%DATADIR%%/sheets/for90-fixed.ssh
+%%DATADIR%%/sheets/for90-free.ssh
+%%DATADIR%%/sheets/for90kwds.ssh
+%%DATADIR%%/sheets/fortran.ssh
+%%DATADIR%%/sheets/gmake.ssh
+%%DATADIR%%/sheets/gnuc.ssh
+%%DATADIR%%/sheets/haskell.ssh
+%%DATADIR%%/sheets/html.ssh
+%%DATADIR%%/sheets/idl.ssh
+%%DATADIR%%/sheets/initora.ssh
+%%DATADIR%%/sheets/is5rul.ssh
+%%DATADIR%%/sheets/java.ssh
+%%DATADIR%%/sheets/js.ssh
+%%DATADIR%%/sheets/lace.ssh
+%%DATADIR%%/sheets/lex.ssh
+%%DATADIR%%/sheets/lout.ssh
+%%DATADIR%%/sheets/mail.ssh
+%%DATADIR%%/sheets/make.ssh
+%%DATADIR%%/sheets/maple.ssh
+%%DATADIR%%/sheets/matlab4.ssh
+%%DATADIR%%/sheets/mib.ssh
+%%DATADIR%%/sheets/mly.ssh
+%%DATADIR%%/sheets/modula2.ssh
+%%DATADIR%%/sheets/modula3.ssh
+%%DATADIR%%/sheets/o2c.ssh
+%%DATADIR%%/sheets/oberon.ssh
+%%DATADIR%%/sheets/objc.ssh
+%%DATADIR%%/sheets/ocaml.ssh
+%%DATADIR%%/sheets/octave.ssh
+%%DATADIR%%/sheets/oracle.ssh
+%%DATADIR%%/sheets/pascal.ssh
+%%DATADIR%%/sheets/perl.ssh
+%%DATADIR%%/sheets/plsql.ssh
+%%DATADIR%%/sheets/pov.ssh
+%%DATADIR%%/sheets/ppd.ssh
+%%DATADIR%%/sheets/pre.ssh
+%%DATADIR%%/sheets/pretex.ssh
+%%DATADIR%%/sheets/prolog.ssh
+%%DATADIR%%/sheets/promela.ssh
+%%DATADIR%%/sheets/ps.ssh
+%%DATADIR%%/sheets/python.ssh
+%%DATADIR%%/sheets/rexx.ssh
+%%DATADIR%%/sheets/sather.ssh
+%%DATADIR%%/sheets/scheme.ssh
+%%DATADIR%%/sheets/sdl88.ssh
+%%DATADIR%%/sheets/sed.ssh
+%%DATADIR%%/sheets/sh.ssh
+%%DATADIR%%/sheets/sheets.map
+%%DATADIR%%/sheets/shell.ssh
+%%DATADIR%%/sheets/sml.ssh
+%%DATADIR%%/sheets/sql.ssh
+%%DATADIR%%/sheets/sql92.ssh
+%%DATADIR%%/sheets/ssh.ssh
+%%DATADIR%%/sheets/symbols.ssh
+%%DATADIR%%/sheets/tcl.ssh
+%%DATADIR%%/sheets/tclx.ssh
+%%DATADIR%%/sheets/tcsh.ssh
+%%DATADIR%%/sheets/tex.ssh
+%%DATADIR%%/sheets/texinfo.ssh
+%%DATADIR%%/sheets/texscript.ssh
+%%DATADIR%%/sheets/tiger.ssh
+%%DATADIR%%/sheets/tk.ssh
+%%DATADIR%%/sheets/udiff.ssh
+%%DATADIR%%/sheets/unity.ssh
+%%DATADIR%%/sheets/vba.ssh
+%%DATADIR%%/sheets/verilog.ssh
+%%DATADIR%%/sheets/vhdl.ssh
+%%DATADIR%%/sheets/vrml.ssh
+%%DATADIR%%/sheets/vtcl.ssh
+%%DATADIR%%/sheets/wdiff.ssh
+%%DATADIR%%/sheets/xs.ssh
+%%DATADIR%%/sheets/yacc.ssh
+%%DATADIR%%/sheets/zsh.ssh
+%%NLS%%share/locale/ca/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/da/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/de/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/es/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/et/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/it/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/no/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/a2ps.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/a2ps.mo
+%%WITHEMACS%%%%EMACS_SITE_LISPDIR%%/a2ps-print.el
+%%WITHEMACS%%%%EMACS_SITE_LISPDIR%%/a2ps-print.elc
+%%WITHEMACS%%%%EMACS_SITE_LISPDIR%%/a2ps.el
+%%WITHEMACS%%%%EMACS_SITE_LISPDIR%%/a2ps.elc
+@dirrm %%DATADIR%%/ogonkify/fonts
+@dirrm %%DATADIR%%/ogonkify/afm
+@dirrm %%DATADIR%%/ogonkify
+@dirrm %%DATADIR%%/ps
+@dirrm %%DATADIR%%/ppd
+@dirrm %%DATADIR%%/sheets
+@dirrm %%DATADIR%%/fonts
+@dirrm %%DATADIR%%/encoding
+@dirrm %%DATADIR%%/afm
+@dirrm %%DATADIR%%
+%%WITHEMACS%%@dirrm lib/xemacs/site-lisp
+%%WITHEMACS%%@dirrm lib/xemacs