aboutsummaryrefslogtreecommitdiff
path: root/print/foomatic-filters/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2005-01-28 14:15:22 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2005-01-28 14:15:22 +0000
commit4cc2f8ac07483c75f53da63728b83200c962500e (patch)
tree61f0aa2d5cf5f3de295f37a1d682264dab967ef8 /print/foomatic-filters/Makefile
parent9d3fdccee2d2f148a42fe1cc56fd1bc73e9a9c94 (diff)
downloadports-4cc2f8ac07483c75f53da63728b83200c962500e.tar.gz
ports-4cc2f8ac07483c75f53da63728b83200c962500e.zip
Remove all BUILD_DEPENDS, specify paths of possible text-to-postscript
filters to configure directly and add a pkg-message that advises about possible filters to install.
Notes
Notes: svn path=/head/; revision=127550
Diffstat (limited to 'print/foomatic-filters/Makefile')
-rw-r--r--print/foomatic-filters/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/print/foomatic-filters/Makefile b/print/foomatic-filters/Makefile
index 55ae2f7e87bf..065e198f451d 100644
--- a/print/foomatic-filters/Makefile
+++ b/print/foomatic-filters/Makefile
@@ -7,21 +7,26 @@
PORTNAME= foomatic-filters
PORTVERSION= 3.0.2
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= http://www.linuxprinting.org/download/foomatic/
MAINTAINER= lofi@FreeBSD.org
COMMENT= Foomatic wrapper scripts
-BUILD_DEPENDS= a2ps:${PORTSDIR}/print/a2ps-letter \
- cups-config:${PORTSDIR}/print/cups-base \
- enscript:${PORTSDIR}/print/enscript-letter \
- mpage:${PORTSDIR}/print/mpage
-
USE_PERL= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= ac_cv_path_PPR=${LOCALBASE}/lib/ppr \
+CONFIGURE_ENV= ac_cv_path_A2PS=${LOCALBASE}/bin/a2ps \
+ ac_cv_path_CUPS=${LOCALBASE}/libexec/cups \
+ ac_cv_path_CUPS_FILTERS=${LOCALBASE}/libexec/cups/filter \
+ ac_cv_path_ENSCRIPT=${LOCALBASE}/bin/enscript \
+ ac_cv_path_MPAGE=${LOCALBASE}/bin/mpage \
+ ac_cv_path_PPR=${LOCALBASE}/lib/ppr \
ac_cv_path_PPR_INTERFACES=${LOCALBASE}/lib/ppr/interfaces \
- ac_cv_path_PPR_LIB=${LOCALBASE}/lib/ppr/lib
+ ac_cv_path_PPR_LIB=${LOCALBASE}/lib/ppr/lib \
+ ac_cv_path_TEXTTOPS=${LOCALBASE}/libexec/cups/filter/texttops
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>