aboutsummaryrefslogtreecommitdiff
path: root/print/ghostscript8
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-04-27 22:11:29 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-04-27 22:11:29 +0000
commitb814dd1ef6c5a3ed7e7170dec6a9bec9c358b558 (patch)
tree80cdfddf4e0abeb01c2bac3621475e8aba78ed8f /print/ghostscript8
parent79671f3f8ad3d6f72a0e689b3c75f027193dee31 (diff)
downloadports-b814dd1ef6c5a3ed7e7170dec6a9bec9c358b558.tar.gz
ports-b814dd1ef6c5a3ed7e7170dec6a9bec9c358b558.zip
- Fix EPLASER driver support
- chown font files to root:wheel after extracting them into datadir PR: 51061 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=79763
Diffstat (limited to 'print/ghostscript8')
-rw-r--r--print/ghostscript8/Makefile10
-rw-r--r--print/ghostscript8/pkg-plist5
-rw-r--r--print/ghostscript8/scripts/configure7
3 files changed, 13 insertions, 9 deletions
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index cb67ed012f8a..ac1821661e7f 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ghostscript
PORTVERSION= ${GS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S/$/:gs_srcs,gs_fonts,bjc250/} \
http://hp.sourceforge.net/:hp2200 \
@@ -59,7 +59,7 @@ USE_REINPLACE= yes
USE_GMAKE= yes
MAKE_ENV= CC="${CC}" CXX="${CXX}" CFLAGS_STANDARD="${CFLAGS}" \
XCFLAGS="${XCFLAGS}" WITHOUT_X11="${WITHOUT_X11}"
-PLIST_SUB= GS_VERSION=${GS_VERSION} EPLASER_GSVERS=${EPLASER_GSVERS}
+PLIST_SUB= GS_VERSION=${GS_VERSION}
SCRIPTS_ENV= GS_OPTIONS="${GS_OPTIONS}" WITHOUT_X11="${WITHOUT_X11}"
@@ -175,9 +175,8 @@ EPAG_SRCS= ${EPAG_NAME}.tar.gz
# http://www.epkowa.co.jp/linux/lpd.html
EPLASER= eplaser
EPLASER_VERS= 3.0.6
-EPLASER_GSVERS= 652
EPLASER_NAME= ${EPLASER}-${EPLASER_VERS}
-EPLASER_SRCS= ${EPLASER_NAME}-${EPLASER_GSVERS}.tgz
+EPLASER_SRCS= ${EPLASER_NAME}-652.tgz
# MJC - additional driver for Epson MachJet series
MJC= mjc
@@ -412,6 +411,7 @@ pre-install:
${ECHO_MSG} ">>> extracting ghostscript fonts ..."
${TAR} -C ${DATADIR} -xzf ${DISTDIR}/${DIST_SUBDIR}/${GS_FONTS_STD}
${TAR} -C ${DATADIR} -xzf ${DISTDIR}/${DIST_SUBDIR}/${GS_FONTS_OTHER}
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
post-install:
${ECHO_MSG} ">>> in post-install ..."
@@ -492,7 +492,7 @@ post-install:
# for EPLASER driver
${ECHO_MSG} ">>> installing ${EPLASER} docs ..."
${MKDIR} ${DOCSDIR}/${GS_VERSION}/${EPLASER}
-.for i in readme-eplaser-${EPLASER_GSVERS}.euc readme-eplaser-${EPLASER_GSVERS}-jp.euc
+.for i in readme-eplaser-652.euc readme-eplaser-652-jp.euc
${INSTALL_DATA} ${WRKSRC}/${EPLASER_NAME}/${i} \
${DOCSDIR}/${GS_VERSION}/${EPLASER}
.endfor
diff --git a/print/ghostscript8/pkg-plist b/print/ghostscript8/pkg-plist
index 69aa5bd5e54f..21f9ead5ac23 100644
--- a/print/ghostscript8/pkg-plist
+++ b/print/ghostscript8/pkg-plist
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
bin/bdftops
bin/dvipdf
bin/eps2eps
@@ -43,8 +44,8 @@ bin/wftopfa
%%PORTDOCS%%share/doc/ghostscript/%%GS_VERSION%%/epag/gdevepag.txt
%%PORTDOCS%%share/doc/ghostscript/%%GS_VERSION%%/epag/gsepagif.sh
%%PORTDOCS%%share/doc/ghostscript/%%GS_VERSION%%/epag/psprint
-%%PORTDOCS%%share/doc/ghostscript/%%GS_VERSION%%/eplaser/readme-eplaser-%%EPLASER_GSVERS%%.euc
-%%PORTDOCS%%share/doc/ghostscript/%%GS_VERSION%%/eplaser/readme-eplaser-%%EPLASER_GSVERS%%-jp.euc
+%%PORTDOCS%%share/doc/ghostscript/%%GS_VERSION%%/eplaser/readme-eplaser-652.euc
+%%PORTDOCS%%share/doc/ghostscript/%%GS_VERSION%%/eplaser/readme-eplaser-652-jp.euc
%%PORTDOCS%%share/doc/ghostscript/%%GS_VERSION%%/gdi/README
%%PORTDOCS%%share/doc/ghostscript/%%GS_VERSION%%/lips/Gdevlips.htm
%%PORTDOCS%%share/doc/ghostscript/%%GS_VERSION%%/md2k/README.jis
diff --git a/print/ghostscript8/scripts/configure b/print/ghostscript8/scripts/configure
index eb40ba77557b..d4a4cad25d3a 100644
--- a/print/ghostscript8/scripts/configure
+++ b/print/ghostscript8/scripts/configure
@@ -30,9 +30,9 @@ else
lj250 declj250 ap3250 epson eps9mid eps9high lp8000 \
epag \
escpage lp2000 \
- alc8600 alc8500 alc2000 alc4000 \
+ alc8600 alc8500 alc2000 alc4000 alc1900 \
lp9500c lp8800c lp8300c lp8500c lp3000c lp8200c lp8000c \
- epl5900 epl5800 epl2050 epl2050p epl2120 \
+ epl6100 epl5900 epl5800 epl2050 epl2050p epl2120 epl2750 \
lp7500 lp2400 lp2200 lp9400 lp8900 lp8700 lp8100 lp7700 \
lp8600f lp8400f lp8300f lp1900 lp9600s lp9300 lp9600 lp8600 \
lp1800 \
@@ -148,6 +148,7 @@ Have fun with this new configuration style ! -andreas \n\n\
"alc8500" "Epson AL-C8500 color laser printer [EPLASER]" "$status_alc8500" \
"alc2000" "Epson AL-C2000 color laser printer [EPLASER]" "$status_alc2000" \
"alc4000" "Epson AL-C4000 color laser printer [EPLASER]" "$status_alc4000" \
+ "alc1900" "Epson AL-C1900 color laser printer [EPLASER]" "$status_alc1900" \
"lp9500c" "Epson LP-9500C color laser printer [EPLASER]" "$status_lp9500c" \
"lp8800c" "Epson LP-8800C color laser printer [EPLASER]" "$status_lp8800c" \
"lp8300c" "Epson LP-8300C color laser printer [EPLASER]" "$status_lp8300c" \
@@ -155,11 +156,13 @@ Have fun with this new configuration style ! -andreas \n\n\
"lp3000c" "Epson LP-3000C color laser printer [EPLASER]" "$status_lp3000c" \
"lp8200c" "Epson LP-8200C color laser printer [EPLASER]" "$status_lp8200c" \
"lp8000c" "Epson LP-8000C color laser printer [EPLASER]" "$status_lp8000c" \
+ "epl6100" "Epson EPL-6100 laser printer [EPLASER]" "$status_epl6100" \
"epl5900" "Epson EPL-5900 laser printer [EPLASER]" "$status_epl5900" \
"epl5800" "Epson EPL-5800 laser printer [EPLASER]" "$status_epl5800" \
"epl2050" "Epson EPL-N2050 laser printer [EPLASER]" "$status_epl2050" \
"epl2050p" "Epson EPL-N2050+ laser printer [EPLASER]" "$status_epl2050p" \
"epl2120" "Epson EPL-N2120 laser printer [EPLASER]" "$status_epl2120" \
+ "epl2750" "Epson EPL-N2750 laser printer [EPLASER]" "$status_epl2750" \
"lp7500" "Epson LP-7500(R) laser printer [EPLASER]" "$status_lp7500" \
"lp2400" "Epson LP-2400 laser printer [EPLASER]" "$status_lp2400" \
"lp2200" "Epson LP-2200 laser printer [EPLASER]" "$status_lp2200" \