aboutsummaryrefslogtreecommitdiff
path: root/print/ghostscript9/files
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2011-06-10 09:10:53 +0000
committerHiroki Sato <hrs@FreeBSD.org>2011-06-10 09:10:53 +0000
commit17219d27772f5df7cc43fb8005b7c0f8b7a558cc (patch)
tree89c8a5b4b99ac2bb5d3830e1feb04f1500b741b2 /print/ghostscript9/files
parent61aadf573d6eff9f12207d57ecfe8a13b14eefbd (diff)
downloadports-17219d27772f5df7cc43fb8005b7c0f8b7a558cc.tar.gz
ports-17219d27772f5df7cc43fb8005b7c0f8b7a558cc.zip
- Fix build when WITHOUT_X11=yes.
- Fix CONFLICTS. - Build and install a dynamic module X11.so when !WITHOUT_X11.
Notes
Notes: svn path=/head/; revision=275298
Diffstat (limited to 'print/ghostscript9/files')
-rw-r--r--print/ghostscript9/files/Makefile.drivers_post6
-rw-r--r--print/ghostscript9/files/patch-base-configure.ac25
-rw-r--r--print/ghostscript9/files/patch-base-lib.mak11
3 files changed, 40 insertions, 2 deletions
diff --git a/print/ghostscript9/files/Makefile.drivers_post b/print/ghostscript9/files/Makefile.drivers_post
index f742282848d3..8a99e84be0c5 100644
--- a/print/ghostscript9/files/Makefile.drivers_post
+++ b/print/ghostscript9/files/Makefile.drivers_post
@@ -114,10 +114,11 @@ WITH_GS_${D}=yes
.if defined(_X11_DEVS)
USE_XORG= xt xext
+X11BITS= ""
CONFIGURE_ARGS+=--with-x \
--x-includes=${X11BASE}/include \
--x-libraries=${X11BASE}/lib
-CONFLICTS+= ghostscript8-nox11-[0-9]*
+CONFLICTS+= ghostscript9-nox11-[0-9]*
.if defined(WITH_GTK)
USE_GNOME= atk gdkpixbuf glib20 gtk20
CONFIGURE_ARGS+=--enable-gtk
@@ -127,7 +128,8 @@ CONFIGURE_ARGS+=--disable-gtk
.else # defined(_X11_DEVS)
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-nox11
CONFIGURE_ARGS+=--without-x --disable-gtk
-CONFLICTS+= ghostscript8-[0-9]*
+CONFLICTS+= ghostscript9-[0-9]*
+X11BITS= "@comment "
.endif # defined(_X11_DEVS)
# iconv specific
diff --git a/print/ghostscript9/files/patch-base-configure.ac b/print/ghostscript9/files/patch-base-configure.ac
new file mode 100644
index 000000000000..60be403d058b
--- /dev/null
+++ b/print/ghostscript9/files/patch-base-configure.ac
@@ -0,0 +1,25 @@
+--- base/configure.ac.orig 2011-03-30 15:48:01.000000000 +0900
++++ base/configure.ac 2011-06-10 14:36:19.000000000 +0900
+@@ -1019,7 +1019,7 @@
+ X_DEVS=""
+ X_LIBS=""
+
+-if test x$no_x != xyes; then
++if test x$with_x != xno; then
+ if test "$x_libraries" = "/usr/lib"; then
+ echo "Ignoring X library directory \"$x_libraries\" requested by configure."
+ x_libraries="NONE"
+@@ -1412,7 +1412,12 @@
+ DBG_CFLAGS="$DYNAMIC_CFLAGS $DBG_CFLAGS"
+ ;;
+ *BSD)
+- DYNAMIC_DEVS="\$(GLOBJDIR)/X11.so"
++ if test "x$X_DEVS" != x; then
++ DYNAMIC_DEVS="\$(GLOBJDIR)/X11.so"
++ INSTALL_SHARED="install-shared"
++ else
++ DYNAMIC_DEVS=""
++ fi
+ DYNAMIC_FLAGS="-DGS_DEVS_SHARED -DGS_DEVS_SHARED_DIR=\\\"\$(gssharedir)\\\""
+ X11_DEVS=""
+ OPT_CFLAGS="$DYNAMIC_CFLAGS $OPT_CFLAGS"
diff --git a/print/ghostscript9/files/patch-base-lib.mak b/print/ghostscript9/files/patch-base-lib.mak
new file mode 100644
index 000000000000..13d1ff5daf8c
--- /dev/null
+++ b/print/ghostscript9/files/patch-base-lib.mak
@@ -0,0 +1,11 @@
+--- base/lib.mak.orig 2011-06-10 13:41:36.000000000 +0900
++++ base/lib.mak 2011-06-10 13:42:59.000000000 +0900
+@@ -25,7 +25,7 @@
+ GLI_=$(GLGENDIR) $(II)$(GLSRCDIR)
+ GLF_=
+ GLCCFLAGS=$(I_)$(GLI_)$(_I) $(GLF_)
+-GLCC=$(CC_) $(GLCCFLAGS)
++GLCC=$(GLCCSHARED)
+ GLJCC=$(CC_) $(I_)$(GLI_) $(II)$(JI_)$(_I) $(JCF_) $(GLF_)
+ GLZCC=$(CC_) $(I_)$(GLI_) $(II)$(ZI_)$(_I) $(ZCF_) $(GLF_)
+ GLJBIG2CC=$(CC_) $(I_)$(GLI_) $(II)$(JB2I_)$(_I) $(JB2CF_) $(GLF_)