aboutsummaryrefslogtreecommitdiff
path: root/print/gimp-print/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-12 14:07:16 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-12 14:07:16 +0000
commit584fa45064ff4f18daddf7a622215566e7d02402 (patch)
treeff10d9bd7509e6612b3b3200a5aaa75a6f0e2a4d /print/gimp-print/Makefile
parentbef0a02e255c9a759d5f7cf30fd0b0c4e340b201 (diff)
downloadports-584fa45064ff4f18daddf7a622215566e7d02402.tar.gz
ports-584fa45064ff4f18daddf7a622215566e7d02402.zip
- Update to version 4.2.6
PR: 61250 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=97999
Diffstat (limited to 'print/gimp-print/Makefile')
-rw-r--r--print/gimp-print/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/print/gimp-print/Makefile b/print/gimp-print/Makefile
index d2ed794fa689..db97b93d397e 100644
--- a/print/gimp-print/Makefile
+++ b/print/gimp-print/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= gimp-print
-PORTVERSION= 4.2.5
-PORTREVISION= 1
+PORTVERSION= 4.2.6
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,12 +15,11 @@ COMMENT= GIMP Print Printer Driver
LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
+USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- MAKEINFO="makeinfo --no-split"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-gimp=no
INSTALLS_SHLIB= yes
@@ -31,6 +29,10 @@ MAN7= gimpprint-color.7 gimpprint-dithers.7 gimpprint-imagetypes.7 \
gimpprint-inktypes.7 gimpprint-mediasizes.7 gimpprint-mediasources.7 \
gimpprint-mediatypes.7 gimpprint-models.7 gimpprint-resolutions.7
MAN8= cups-calibrate.8
+INFO= gimpprint
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
.if defined(WITHOUT_CUPS)
PLIST_SUB+= CUPS="@comment "
@@ -45,7 +47,7 @@ PLIST_SUB+= CUPS=""
PLIST_SUB+= IJS="@comment "
.else
LIB_DEPENDS+= ijs.1:${PORTSDIR}/print/libijs
-CONFIGURE_ARGS+= --with-ijs=yes
+CONFIGURE_ARGS+= --with-ijs=yes
PLIST_SUB+= IJS=""
.endif
@@ -57,8 +59,8 @@ pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} "You may use the following build options:"
@${ECHO_MSG}
- @${ECHO_MSG} "WITHOUT_CUPS=yes build without CUPS driver"
- @${ECHO_MSG} "WITHOUT_IJS=yes build without IJS-based Ghostscript driver"
+ @${ECHO_MSG} " WITHOUT_CUPS=yes build without CUPS driver"
+ @${ECHO_MSG} " WITHOUT_IJS=yes build without IJS-based Ghostscript driver"
@${ECHO_MSG}
post-extract:
@@ -66,9 +68,9 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|=makeinfo|="makeinfo --no-split"|g ; \
- s|\$${CFLAGS:=} -O|$${CFLAGS}|g' ${WRKSRC}/configure
+ s|$${CFLAGS:=} -O|$${CFLAGS}|g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|\$$(PACKAGE)/doc|doc/$$(PACKAGE)|g ; \
- s|\$$(RM) -r|$$(RM) -f -r|g'
+ 's|$$(PACKAGE)/doc|doc/$$(PACKAGE)|g ; \
+ s|$$(RM) -r|$$(RM) -f -r|g'
.include <bsd.port.mk>