aboutsummaryrefslogtreecommitdiff
path: root/print/hplip/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-12-11 12:32:31 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-12-11 12:32:31 +0000
commit0d577cde6169966f335eddfcd27774a2dbdeb70b (patch)
tree9a8e7720828c75fdd107c71a92d33a292e26fe31 /print/hplip/Makefile
parent90fb4b4e5c4b673b941a4bee9c090ae8cacfc025 (diff)
downloadports-0d577cde6169966f335eddfcd27774a2dbdeb70b.tar.gz
ports-0d577cde6169966f335eddfcd27774a2dbdeb70b.zip
- Update to 3.12.11
- Remove stale patches - Trim Makefile header
Notes
Notes: svn path=/head/; revision=308681
Diffstat (limited to 'print/hplip/Makefile')
-rw-r--r--print/hplip/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/print/hplip/Makefile b/print/hplip/Makefile
index 681b50b30292..99bf5a5cca88 100644
--- a/print/hplip/Makefile
+++ b/print/hplip/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: hplip
-# Date created: 1 April 2006
-# Whom: amistry@am-productions.biz
-#
+# Created by: amistry@am-productions.biz
# $FreeBSD$
-#
PORTNAME= hplip
-PORTVERSION= 3.12.2
-PORTREVISION= 2
+PORTVERSION= 3.12.11
CATEGORIES= print
MASTER_SITES= SF
@@ -41,7 +36,8 @@ CONFIGURE_ARGS= --enable-foomatic-ppd-install \
--with-hpppddir=${PREFIX}/share/ppd/HP \
--with-mimedir=${PREFIX}/etc/cups \
--with-docdir=${DOCSDIR} \
- --with-drvdir=${PREFIX}/libexec/cups/driver
+ --with-drvdir=${PREFIX}/libexec/cups/driver \
+ --enable-libusb01_build
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
@@ -155,6 +151,11 @@ post-patch:
${WRKSRC}/Makefile.in
${REINPLACE_CMD} -e '/[[:space:]]install-dist_rulesDATA/ s,install-dist_rulesDATA,,' \
-e '/[[:space:]]install-hplip_confDATA/ s,install-hplip_confDATA,,' \
+ -e '/[[:space:]]install-dist_hplip_LogDATA/ s,install-dist_hplip_LogDATA,,' \
+ -e '/[[:space:]]install-dist_cronDATA/ s,install-dist_cronDATA,,' \
+ -e '/[[:space:]]install-dist_halpreDATA/ s,install-dist_halpreDATA,,' \
+ -e '/[[:space:]]install-dist_hplip_stateDATA/ s,install-dist_hplip_stateDATA,,' \
+ -e '/[[:space:]]install-dist_hplip_tmpDATA/ s,install-dist_hplip_tmpDATA,,' \
${WRKSRC}/Makefile.in
${REINPLACE_CMD} -e 's,/etc/hp,${PREFIX}&,g' \
-e 's,/etc/cups,${LOCALBASE}&,g' \
@@ -171,7 +172,9 @@ post-patch:
.endif
post-install:
+.if ${PORT_OPTIONS:MQT}
${INSTALL_DATA} ${WRKSRC}/hplip-systray.desktop ${PREFIX}/etc/xdg/autostart/hplip-systray.desktop
+.endif
${MKDIR} ${PREFIX}/etc/hp
${INSTALL_DATA} ${WRKSRC}/hplip.conf ${PREFIX}/etc/hp/hplip.conf.sample
if [ ! -f ${PREFIX}/etc/hp/hplip.conf ]; then \