aboutsummaryrefslogtreecommitdiff
path: root/print/hplip
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-01-12 21:25:30 +0000
committerRene Ladan <rene@FreeBSD.org>2021-01-12 21:25:30 +0000
commitd217e9878f7db8c6ece39eab028b16f0df058f73 (patch)
treeda33b7846c82ee3943b4e0e9f6caa4bb71c331d8 /print/hplip
parent480925a4c90cd50942fe1209dfed2f674998c183 (diff)
downloadports-d217e9878f7db8c6ece39eab028b16f0df058f73.tar.gz
ports-d217e9878f7db8c6ece39eab028b16f0df058f73.zip
Simplify some ports using PYTHON_MAJOR_VER and Python 3.6+
Notes
Notes: svn path=/head/; revision=561385
Diffstat (limited to 'print/hplip')
-rw-r--r--print/hplip/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/print/hplip/Makefile b/print/hplip/Makefile
index aecd20ac3cb0..0c53964ac6a3 100644
--- a/print/hplip/Makefile
+++ b/print/hplip/Makefile
@@ -16,7 +16,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcupsimage.so:print/cups \
libdbus-1.so:devel/dbus
RUN_DEPENDS= cups-filters>=0:print/cups-filters \
- ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gobject3>=0:devel/py-gobject3@${PY_FLAVOR}
CONFLICTS_INSTALL= hpijs-[0-9]*
@@ -69,12 +70,6 @@ XSANE_DESC= Install XSane for scanning (implies SCAN)
XSANE_IMPLIES= SCAN
XSANE_RUN_DEPENDS= xsane:graphics/xsane
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_MAJOR_VER} >= 3
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gobject3>=0:devel/py-gobject3@${PY_FLAVOR}
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-ldld||g;' \
-e 's|-ldl||g' \
@@ -136,4 +131,4 @@ post-install-SCAN-on:
${MV} ${STAGEDIR}${PREFIX}/etc/sane.d/dll.conf \
${STAGEDIR}${PREFIX}/etc/sane.d/dll.d/hpaio
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>