aboutsummaryrefslogtreecommitdiff
path: root/print/lilypond
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-17 07:06:07 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-17 07:06:07 +0000
commit985700ac5343f29dd6d2ada34f25b079c715c54b (patch)
tree2c55c14237022f739f73e2926eb4a4918bfaa883 /print/lilypond
parent70883a12ada3ec8bc9626382e1134668a2dfb34a (diff)
downloadports-985700ac5343f29dd6d2ada34f25b079c715c54b.tar.gz
ports-985700ac5343f29dd6d2ada34f25b079c715c54b.zip
print/lilypond: Unbreak
Port changes: * Add patch removing fc-cache that caused the fs violation problem * Fix COMMENT * Add LIB_DEPENDS
Notes
Notes: svn path=/head/; revision=464762
Diffstat (limited to 'print/lilypond')
-rw-r--r--print/lilypond/Makefile16
-rw-r--r--print/lilypond/files/patch-lily_font-config.cc11
2 files changed, 19 insertions, 8 deletions
diff --git a/print/lilypond/Makefile b/print/lilypond/Makefile
index 5185c14c1348..d80c09b6b400 100644
--- a/print/lilypond/Makefile
+++ b/print/lilypond/Makefile
@@ -3,12 +3,12 @@
PORTNAME= lilypond
PORTVERSION= 2.18.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= print audio
MASTER_SITES= http://download.linuxaudio.org/lilypond/sources/v${PORTVERSION:R}/
MAINTAINER= ports@FreeBSD.org
-COMMENT= The GNU music typesetter
+COMMENT= GNU music typesetter
LICENSE= GPLv3
@@ -26,13 +26,13 @@ BUILD_DEPENDS= pdftexi2dvi:print/texinfo \
zip:archivers/zip \
texi2html:textproc/texi2html \
${LOCALBASE}/share/ghostscript/fonts/c059033l.pfb:print/gsfonts
-
-RUN_DEPENDS= mftrace:print/mftrace \
- ${LOCALBASE}/share/fonts/dejavu/DejaVuSans-Bold.ttf:x11-fonts/dejavu
-
LIB_DEPENDS= libguile.so:lang/guile \
libgmp.so:math/gmp \
- libfreetype.so:print/freetype2
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libltdl.so:devel/libltdl
+RUN_DEPENDS= mftrace:print/mftrace \
+ ${LOCALBASE}/share/fonts/dejavu/DejaVuSans-Bold.ttf:x11-fonts/dejavu
INFO= internals \
lilypond-changes \
@@ -55,7 +55,7 @@ USE_GNOME= pango
MAKEFILE= GNUmakefile
GNU_MAKEFILE= yes
-MAKE_JOBS_UNSAFE= yes
+#MAKE_JOBS_UNSAFE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-ncsb-dir=${LOCALBASE}/share/ghostscript/fonts \
diff --git a/print/lilypond/files/patch-lily_font-config.cc b/print/lilypond/files/patch-lily_font-config.cc
new file mode 100644
index 000000000000..2493fce1cebe
--- /dev/null
+++ b/print/lilypond/files/patch-lily_font-config.cc
@@ -0,0 +1,11 @@
+--- lily/font-config.cc.orig 2018-03-17 05:17:54 UTC
++++ lily/font-config.cc
+@@ -19,7 +19,7 @@
+
+ #include "config.hh"
+
+-#if HAVE_FONTCONFIG
++#if HAVE_FONTCONFIG && 0 // fontconfig shouldn't be run during build: it causes fs violation
+
+ #include <cstdio>
+ #include <fontconfig/fontconfig.h>