aboutsummaryrefslogtreecommitdiff
path: root/print/muttprint/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-10-30 18:08:16 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-12-11 13:50:53 +0000
commit45526ecbeec33dbb87f0b678d4c04988aab9b657 (patch)
treeb77614b463af0ed929512fcc838ff5cb20c96275 /print/muttprint/Makefile
parenta148ebec4e0afe980f949de0dea5ef4931cb7e86 (diff)
downloadports-45526ecbeec33dbb87f0b678d4c04988aab9b657.tar.gz
ports-45526ecbeec33dbb87f0b678d4c04988aab9b657.zip
framework: Add new USES 'magick' for graphics/ImageMagick*
A new USES has been added to depend on ImageMagick. USES=magick adds a LIB_DEPENDS on graphics/ImageMagick${IMAGEMAGICK_DEFAULT}. If a specific version is required, use for example USES=magick:6 resp. USES=magick:7 If only a build, run or test is required, use for example USES=magick:build resp. USES=magick:6,build,test If a dependency on the nox11 flavor is required, use for example USES=magick:nox11 resp. USES=magick:7,nox11,run,test See magick.mk for more details on the available flags. The tree has been completely converted to make use of this. Approved by: bapt Differential Revision: https://reviews.freebsd.org/D32754
Diffstat (limited to 'print/muttprint/Makefile')
-rw-r--r--print/muttprint/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/print/muttprint/Makefile b/print/muttprint/Makefile
index d4dcc5171d31..6e63e0aca984 100644
--- a/print/muttprint/Makefile
+++ b/print/muttprint/Makefile
@@ -45,9 +45,9 @@ PRINT_COMMAND=lpr -P$$PRINTER
.endif
.if ${PORT_OPTIONS:MX11}
-RUN_DEPENDS+= convert:graphics/ImageMagick6
+USES+= magick:6,run
.else
-RUN_DEPENDS+= convert:graphics/ImageMagick6-nox11
+USES+= magick:6,run,nox11
.endif
pre-everything::