aboutsummaryrefslogtreecommitdiff
path: root/print/p5-Net-Printer/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-08-28 20:15:39 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-08-28 20:15:39 +0000
commita99424ed008d505d379ae1f9e17f428ac884c2c9 (patch)
treeb4ec9c8c2a5abb26eba54fb58a86311e154ae0ee /print/p5-Net-Printer/Makefile
parent39bb0e1750287365eb8a4ad75b044fce9a34a187 (diff)
downloadports-a99424ed008d505d379ae1f9e17f428ac884c2c9.tar.gz
ports-a99424ed008d505d379ae1f9e17f428ac884c2c9.zip
Add p5-Net-Printer 0.32, perl extension for direct-to-lpd printing.
Perl module for directly printing to a print server/printer without having to create a pipe to either lpr or lp. This essentially mimics what the BSD LPR program does by connecting directly to the line printer printer port (almost always 515), and transmitting the data and control information to the print server. PR: 55577 Submitted by: andrew@scoop.co.nz
Notes
Notes: svn path=/head/; revision=87927
Diffstat (limited to 'print/p5-Net-Printer/Makefile')
-rw-r--r--print/p5-Net-Printer/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/print/p5-Net-Printer/Makefile b/print/p5-Net-Printer/Makefile
new file mode 100644
index 000000000000..cea738e2ab7f
--- /dev/null
+++ b/print/p5-Net-Printer/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Net-Printer
+# Date created: 14 August 2003
+# Whom: andrew@scoop.co.nz
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Printer
+PORTVERSION= 0.32
+CATEGORIES= print perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= andrew@scoop.co.nz
+COMMENT= Perl extension for direct-to-lpd printing
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Printer.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>