aboutsummaryrefslogtreecommitdiff
path: root/print/papersize-default-a4/Makefile
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2012-03-17 09:34:50 +0000
committerHiroki Sato <hrs@FreeBSD.org>2012-03-17 09:34:50 +0000
commit350c353727e14e33773170008d1454d5d599a0e0 (patch)
tree5e56c9f5f41218efb7fac63eb12c8ee34b655511 /print/papersize-default-a4/Makefile
parent5f190aa347e3f1c22112c578ca3f6b2a08b4b45c (diff)
downloadports-350c353727e14e33773170008d1454d5d599a0e0.tar.gz
ports-350c353727e14e33773170008d1454d5d599a0e0.zip
Add print/papersize-default-{a4,letter}, which install default paper size
configuration used by libpaper. Discussed with: bsam Feature safe: yes
Notes
Notes: svn path=/head/; revision=293446
Diffstat (limited to 'print/papersize-default-a4/Makefile')
-rw-r--r--print/papersize-default-a4/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/print/papersize-default-a4/Makefile b/print/papersize-default-a4/Makefile
new file mode 100644
index 000000000000..346ab3a383c5
--- /dev/null
+++ b/print/papersize-default-a4/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: papersize-default-a4
+# Date created: March 2, 2012
+# Whom: hrs
+#
+# $FreeBSD$
+#
+
+PORTNAME= papersize-default
+PORTVERSION= 0.0.20120302
+CATEGORIES= print
+MASTER_SITES= # none
+PKGNAMESUFFIX= -${DEFAULTPAPERSIZE:L}
+DISTFILES= # none
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= A default paper size configuration file for libpaper
+
+LIB_DEPENDS= paper:${PORTSDIR}/print/libpaper
+
+NO_BUILD= yes
+
+DEFAULTPAPERSIZE?= a4
+.for P in a4 letter
+.if ${DEFAULTPAPERSIZE:L:M${P}} != ${P}
+CONFLICTS+= papersize-default-${P}-[0-9]*
+.endif
+.endfor
+
+PLIST_FILES= etc/papersize
+
+do-install:
+ ${LN} -s -f papersize.${DEFAULTPAPERSIZE:L} ${PREFIX}/etc/papersize
+
+.include <bsd.port.mk>