aboutsummaryrefslogtreecommitdiff
path: root/print/passivetex/Makefile
diff options
context:
space:
mode:
authorNik Clayton <nik@FreeBSD.org>2004-02-03 17:11:16 +0000
committerNik Clayton <nik@FreeBSD.org>2004-02-03 17:11:16 +0000
commit808c598ccc300636087b283800c72fe55c6a4806 (patch)
tree6d307190d09cc82ccd28e6a0c67d465ed0457248 /print/passivetex/Makefile
parent07ba1772bc2c8bbe8c9071a152dfb26ad14b1aaa (diff)
downloadports-808c598ccc300636087b283800c72fe55c6a4806.tar.gz
ports-808c598ccc300636087b283800c72fe55c6a4806.zip
Update to 1.24, and hand maintainership over to hrs.
PR: ports/48683, ports/62095
Notes
Notes: svn path=/head/; revision=99886
Diffstat (limited to 'print/passivetex/Makefile')
-rw-r--r--print/passivetex/Makefile66
1 files changed, 52 insertions, 14 deletions
diff --git a/print/passivetex/Makefile b/print/passivetex/Makefile
index 7464c5cb0272..b7a3a3aefea2 100644
--- a/print/passivetex/Makefile
+++ b/print/passivetex/Makefile
@@ -6,41 +6,79 @@
#
PORTNAME= passivetex
-PORTVERSION= 1.21
+PORTVERSION= 1.24
CATEGORIES= print
MASTER_SITES= http://www.tei-c.org.uk/Software/passivetex/
-DISTFILES= passivetex.zip
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= ${PORTNAME}
-MAINTAINER= nik@FreeBSD.org
-COMMENT= XSL FO processor, written in TeX
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= XSL FO processor, written in TeX
-BUILD_DEPENDS= ${LOCALBASE}/share/texmf/web2c/xmltex.fmt:${PORTSDIR}/print/xmltex
+BUILD_DEPENDS= kpsewhich:${PORTSDIR}/print/teTeX \
+ ${LOCALBASE}/share/texmf/web2c/xmltex.fmt:${PORTSDIR}/print/xmltex
-DIST_SUBDIR= passivetex
NO_BUILD= yes
USE_ZIP= yes
-
WRKSRC= ${WRKDIR}/passivetex
-
MAKE_ENV= TEXMFCNF=${FILESDIR}:${LOCALBASE}/share/texmf/web2c
MESSAGE= ${PKGDIR}/pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+.include <bsd.port.pre.mk>
+
+PLIST_SUB= MKTEXLSR=${MKTEXLSR} CLASSDIR=${CLASSDIR}
+
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+.if exists(${LOCALBASE}/bin/kpsewhich)
+TEXMFDIR!= ${LOCALBASE}/bin/kpsewhich -expand-var '$$TEXMFMAIN'
+.else
+TEXMFDIR= # empty
+.endif
+CLASSDIR= ${TEXMFDIR:S,^${PREFIX},,:S,^/,,}/tex/passivetex
+
+CLASS_FILES= dummyels.sty fotex.xmt fotex.sty
+CLASS_FILES+= mlnames.sty ucharacters.sty unicode.sty
+CLASS_FILES+= dummyels.sty nomulticol.sty
+
+DOC_FILES= LICENSE README.passivetex index.html index.xml
+
+TEST_FILES= Makefile
+TEST_FILES+= chap01.xml chap02.xml chap03.xml chap04.xml
+TEST_FILES+= check.xsl
+TEST_FILES+= darkness.fo darkness.pdf darkness.xml darkness.xsl
+TEST_FILES+= exercise-print.xsl exercise.fo exercise.pdf exercise.xml
+TEST_FILES+= fezziPic.png fotex.cfg.eg hyperref.cfg
+TEST_FILES+= mathex.xml mathex.xsl mathml.xsl
+TEST_FILES+= mathtei.dtd novel.dtd
+TEST_FILES+= phys332-1.jpg phys332-2.jpg
+TEST_FILES+= rmsd.xml
+TEST_FILES+= tei-oucs.dtd tei.sty teimath-print.xsl teimath.aux teimath.fo
+TEST_FILES+= teimath.log teimath.out teimath.pdf teimath.xml teimath.xsl
+TEST_FILES+= teimath2.xml teiu5-print.xsl teiu5.fo teiu5.pdf teiu5.xml
+TEST_FILES+= teixlite.dtd teixml.cfg test1.fot test2.fot
+
post-patch:
- @${SED} -e 's,%%LOCALBASE%%,${LOCALBASE},' ${MESSAGE} > ${PKGMESSAGE}
+ @${SED} -e 's,%%TEXMFDIR%%,${TEXMFDIR},' \
+ ${MESSAGE} > ${PKGMESSAGE}
do-install:
- @cd ${WRKSRC}; TEXMFMAIN=$$(kpsewhich -expand-var '$$TEXMFMAIN'); \
- ${MKDIR} -m 555 $$TEXMFMAIN/tex/passivetex; \
- ${INSTALL_DATA} dummyels.sty fotex.xmt fotex.sty mlnames.sty ucharacters.sty unicode.sty $$TEXMFMAIN/tex/passivetex;
+ ${MKDIR} -m 555 ${PREFIX}/${CLASSDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${CLASSDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S@^@${WRKSRC}/@} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/test
+ ${INSTALL_DATA} ${TEST_FILES:S@^@${WRKSRC}/test/@} ${DOCSDIR}/test
+.endif
post-install: rebuild-tex-database display-message
rebuild-tex-database:
- ${LOCALBASE}/bin/mktexlsr
+ ${MKTEXLSR}
display-message:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>