aboutsummaryrefslogtreecommitdiff
path: root/print/pdfmod
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2010-09-30 20:57:21 +0000
committerRomain Tartière <romain@FreeBSD.org>2010-09-30 20:57:21 +0000
commit4d7a1c8d566e481119cf417a7c86d4d3cfab6283 (patch)
tree791e7443547d983e65e8e19a6527b4f504dc1e84 /print/pdfmod
parent7bc589787c9097ee0222c8f26db0cd0c417e99a2 (diff)
downloadports-4d7a1c8d566e481119cf417a7c86d4d3cfab6283.tar.gz
ports-4d7a1c8d566e481119cf417a7c86d4d3cfab6283.zip
PDF Mod can rotate, extract, and remove pages, and supports reordering pages
via drag and drop. You can edit the title, subject, author, and keywords, and you can combine documents via drag and drop. WWW: http://live.gnome.org/PdfMod
Notes
Notes: svn path=/head/; revision=262210
Diffstat (limited to 'print/pdfmod')
-rw-r--r--print/pdfmod/Makefile26
-rw-r--r--print/pdfmod/distinfo3
-rw-r--r--print/pdfmod/files/patch-icon-theme-installer35
-rw-r--r--print/pdfmod/pkg-descr5
-rw-r--r--print/pdfmod/pkg-plist70
5 files changed, 139 insertions, 0 deletions
diff --git a/print/pdfmod/Makefile b/print/pdfmod/Makefile
new file mode 100644
index 000000000000..fe7850ce647a
--- /dev/null
+++ b/print/pdfmod/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: pdfmod
+# Date created: 2009-07-28
+# Whom: Romain Tartiere <romain@blogreen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdfmod
+PORTVERSION= 0.9.0
+CATEGORIES= print
+MASTER_SITES= GNOME
+
+MAINTAINER= mono@FreeBSD.org
+COMMENT= A tool for modifying PDF documents
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/hyena.pc:${PORTSDIR}/devel/hyena
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnomesharp20
+USE_GETTEXT= yes
+INSTALLS_ICONS= yes
+
+.include <bsd.port.mk>
diff --git a/print/pdfmod/distinfo b/print/pdfmod/distinfo
new file mode 100644
index 000000000000..83b21d5b67d4
--- /dev/null
+++ b/print/pdfmod/distinfo
@@ -0,0 +1,3 @@
+MD5 (pdfmod-0.9.0.tar.bz2) = 80ee1628611b84aca0850888462136a5
+SHA256 (pdfmod-0.9.0.tar.bz2) = eacf6cdd3f64a8cc37958a98c2cbc3a76de39a11b4d83307df51e7b6b861079c
+SIZE (pdfmod-0.9.0.tar.bz2) = 659370
diff --git a/print/pdfmod/files/patch-icon-theme-installer b/print/pdfmod/files/patch-icon-theme-installer
new file mode 100644
index 000000000000..e388cbbbfe01
--- /dev/null
+++ b/print/pdfmod/files/patch-icon-theme-installer
@@ -0,0 +1,35 @@
+
+$FreeBSD$
+
+--- icon-theme-installer.orig
++++ icon-theme-installer
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ # icon-theme-installer
+ # Copyright (C) 2006 Novell, Inc.
+@@ -101,12 +101,12 @@
+ exit 1
+ fi
+
+-if test ! -x $(echo "$MKINSTALLDIRS_EXEC" | cut -f1 -d' '); then
++if ! which $(echo "$MKINSTALLDIRS_EXEC" | cut -f1 -d' ') > /dev/null; then
+ echo "Cannot find '$MKINSTALLDIRS_EXEC'; You probably want to pass -m \$(mkinstalldirs)"
+ exit 1
+ fi
+
+-if test ! -x $(echo "$INSTALL_DATA_EXEC" | cut -f1 -d' '); then
++if ! which $(echo "$INSTALL_DATA_EXEC" | cut -f1 -d' ') > /dev/null; then
+ echo "Cannot find '$INSTALL_DATA_EXEC'; You probably want to pass -x \$(INSTALL_DATA)"
+ exit 1
+ fi
+@@ -160,7 +160,7 @@
+ fi
+ done
+
+-gtk_update_icon_cache_bin="$((which gtk-update-icon-cache || echo /opt/gnome/bin/gtk-update-icon-cache)2>/dev/null)"
++gtk_update_icon_cache_bin="$( (which gtk-update-icon-cache || echo /opt/gnome/bin/gtk-update-icon-cache)2>/dev/null)"
+ gtk_update_icon_cache="$gtk_update_icon_cache_bin -f -t $INSTALL_BASE_DIR"
+
+ if test -z "$INSTALL_DEST_DIR"; then
diff --git a/print/pdfmod/pkg-descr b/print/pdfmod/pkg-descr
new file mode 100644
index 000000000000..0d572ee9faee
--- /dev/null
+++ b/print/pdfmod/pkg-descr
@@ -0,0 +1,5 @@
+PDF Mod can rotate, extract, and remove pages, and supports reordering pages
+via drag and drop. You can edit the title, subject, author, and keywords, and
+you can combine documents via drag and drop.
+
+WWW: http://live.gnome.org/PdfMod
diff --git a/print/pdfmod/pkg-plist b/print/pdfmod/pkg-plist
new file mode 100644
index 000000000000..6a64f300b342
--- /dev/null
+++ b/print/pdfmod/pkg-plist
@@ -0,0 +1,70 @@
+@comment $FreeBSD$
+bin/pdfmod
+lib/pdfmod/Hyena.Gui.dll
+lib/pdfmod/Hyena.Gui.dll.config
+lib/pdfmod/Hyena.Gui.dll.mdb
+lib/pdfmod/Hyena.dll
+lib/pdfmod/Hyena.dll.mdb
+lib/pdfmod/PdfMod.exe
+lib/pdfmod/PdfMod.exe.mdb
+lib/pdfmod/PdfSharp.dll
+lib/pdfmod/PdfSharp.dll.mdb
+lib/pdfmod/poppler-sharp.dll
+lib/pdfmod/poppler-sharp.dll.config
+lib/pdfmod/poppler-sharp.dll.mdb
+share/applications/pdfmod.desktop
+share/gnome/help/pdfmod/C/pdfmod.xml
+share/gnome/help/pdfmod/ca/pdfmod.xml
+share/gnome/help/pdfmod/cs/pdfmod.xml
+share/gnome/help/pdfmod/da/pdfmod.xml
+share/gnome/help/pdfmod/de/pdfmod.xml
+share/gnome/help/pdfmod/es/pdfmod.xml
+share/gnome/help/pdfmod/fr/pdfmod.xml
+share/gnome/help/pdfmod/hr/pdfmod.xml
+share/gnome/help/pdfmod/pl/pdfmod.xml
+share/gnome/help/pdfmod/sv/pdfmod.xml
+share/gnome/help/pdfmod/zh_CN/pdfmod.xml
+share/icons/hicolor/16x16/apps/pdfmod.png
+share/icons/hicolor/22x22/apps/pdfmod.png
+share/icons/hicolor/24x24/apps/pdfmod.png
+share/icons/hicolor/256x256/apps/pdfmod.png
+share/icons/hicolor/32x32/apps/pdfmod.png
+share/icons/hicolor/scalable/apps/pdfmod.svg
+share/locale/bn_IN/LC_MESSAGES/pdfmod.mo
+share/locale/ca/LC_MESSAGES/pdfmod.mo
+share/locale/cs/LC_MESSAGES/pdfmod.mo
+share/locale/da/LC_MESSAGES/pdfmod.mo
+share/locale/de/LC_MESSAGES/pdfmod.mo
+share/locale/es/LC_MESSAGES/pdfmod.mo
+share/locale/et/LC_MESSAGES/pdfmod.mo
+share/locale/fr/LC_MESSAGES/pdfmod.mo
+share/locale/gl/LC_MESSAGES/pdfmod.mo
+share/locale/hr/LC_MESSAGES/pdfmod.mo
+share/locale/it/LC_MESSAGES/pdfmod.mo
+share/locale/ja/LC_MESSAGES/pdfmod.mo
+share/locale/lt/LC_MESSAGES/pdfmod.mo
+share/locale/nb/LC_MESSAGES/pdfmod.mo
+share/locale/nl/LC_MESSAGES/pdfmod.mo
+share/locale/pl/LC_MESSAGES/pdfmod.mo
+share/locale/pt/LC_MESSAGES/pdfmod.mo
+share/locale/pt_BR/LC_MESSAGES/pdfmod.mo
+share/locale/ru/LC_MESSAGES/pdfmod.mo
+share/locale/sl/LC_MESSAGES/pdfmod.mo
+share/locale/sv/LC_MESSAGES/pdfmod.mo
+share/locale/ta/LC_MESSAGES/pdfmod.mo
+share/locale/zh_CN/LC_MESSAGES/pdfmod.mo
+@dirrmtry share/icons/hicolor/256x256/apps
+@dirrmtry share/icons/hicolor/256x256
+@dirrm share/gnome/help/pdfmod/zh_CN
+@dirrm share/gnome/help/pdfmod/sv
+@dirrm share/gnome/help/pdfmod/pl
+@dirrm share/gnome/help/pdfmod/hr
+@dirrm share/gnome/help/pdfmod/fr
+@dirrm share/gnome/help/pdfmod/es
+@dirrm share/gnome/help/pdfmod/de
+@dirrm share/gnome/help/pdfmod/da
+@dirrm share/gnome/help/pdfmod/cs
+@dirrm share/gnome/help/pdfmod/ca
+@dirrm share/gnome/help/pdfmod/C
+@dirrm share/gnome/help/pdfmod
+@dirrm lib/pdfmod