aboutsummaryrefslogtreecommitdiff
path: root/print/pecl-haru
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-23 18:12:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-23 18:12:48 +0000
commita066b89dc999bc7fff3b0c55cee6069396e0170e (patch)
tree97b3a3d521514fe71e4eb192c861e46c572c2436 /print/pecl-haru
parentbd7248f465b6d0129eb0f9019a1ff890cf01db99 (diff)
downloadports-a066b89dc999bc7fff3b0c55cee6069396e0170e.tar.gz
ports-a066b89dc999bc7fff3b0c55cee6069396e0170e.zip
The PECL-haru extension provides bindings to the
libHaru library. libHaru is a free, cross platform, and Open Source library for generating PDF files. WWW: http://pecl.php.net/package/haru/ PR: ports/129033 Submitted by: Wen Heping <wenheping at gmail.com>
Notes
Notes: svn path=/head/; revision=223293
Diffstat (limited to 'print/pecl-haru')
-rw-r--r--print/pecl-haru/Makefile30
-rw-r--r--print/pecl-haru/distinfo3
-rw-r--r--print/pecl-haru/pkg-descr5
3 files changed, 38 insertions, 0 deletions
diff --git a/print/pecl-haru/Makefile b/print/pecl-haru/Makefile
new file mode 100644
index 000000000000..399b7796f404
--- /dev/null
+++ b/print/pecl-haru/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: pecl-haru
+# Date created: 20 Nov 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= haru
+PORTVERSION= 1.0.0
+CATEGORIES= print pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+#DIST_SUBDIR= PECL
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A PECL extension to Haru PDF functions
+
+BUILD_DEPENDS= ${LOCALBASE}/include/hpdf.h:${PORTSDIR}/print/libharu
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+CONFIGURE_ARGS+= --with-haru=${LOCALBASE}
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+.include <bsd.port.mk>
diff --git a/print/pecl-haru/distinfo b/print/pecl-haru/distinfo
new file mode 100644
index 000000000000..756a8718cdc9
--- /dev/null
+++ b/print/pecl-haru/distinfo
@@ -0,0 +1,3 @@
+MD5 (haru-1.0.0.tgz) = 967b9cf8394432547ce850ef6a3fb375
+SHA256 (haru-1.0.0.tgz) = 90180684438ce6ad4ac8f1c2ac496d6c132d2345590f11ce230ed7cc1e26b5a5
+SIZE (haru-1.0.0.tgz) = 23336
diff --git a/print/pecl-haru/pkg-descr b/print/pecl-haru/pkg-descr
new file mode 100644
index 000000000000..bb22e506b2be
--- /dev/null
+++ b/print/pecl-haru/pkg-descr
@@ -0,0 +1,5 @@
+The PECL-haru extension provides bindings to the
+libHaru library. libHaru is a free, cross platform,
+and Open Source library for generating PDF files.
+
+WWW: http://pecl.php.net/package/haru/